EGR valve solenoid - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > EGR valve solenoid

Year End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-13-2014, 12:18 AM   #1
DonBC
Registered User
1989 MJ Comanche 
 
Join Date: Jan 2011
Location: Gabriola, British Columbia
Posts: 34
EGR valve solenoid

I have been having problems with my 89 Comanche 4.0 not wanting to idle and stalling when I put in the clutch when driving. From the various threads this appears to be an EGR problem. Today I pulled off the vacuum line to the EGR valve solenoid and the engine idled properly. I could feel the suction on the vacuum line. I looked at the EGR while putting the hose on and off and I could see the stem on the EGR moving to open and close the EGR valve so this indicates to me that the EGR valve is good. I took a drive with the vacuum line off and the truck ran properly. It appears as if the solenoid is the problem. Anyone else have a similar problem?

DonBC is offline   Reply With Quote Quick reply to this message
Unread 03-13-2014, 08:46 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,325
The solenoid gets it's signal from the ECU. Perhaps the solenoid is stuck? Doubtful the ECU is bad. Unplug the wire connector and see if you still have vacuum present.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote Quick reply to this message
Unread 03-16-2014, 06:18 PM   #3
DonBC
Registered User
1989 MJ Comanche 
 
Join Date: Jan 2011
Location: Gabriola, British Columbia
Posts: 34
Unplugging the connector does not change anything, there is still vacuum at the output of the solenoid valve. Until I can get a new or replaement solenoid valve I have been running with the vacuum line disconnected.
DonBC is offline   Reply With Quote Quick reply to this message
Unread 03-16-2014, 09:05 PM   #4
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,325
You're good to go then
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2014, 07:51 PM   #5
DonBC
Registered User
1989 MJ Comanche 
 
Join Date: Jan 2011
Location: Gabriola, British Columbia
Posts: 34
I picked up a solenoid valve for $20 and it solved the problem. $135 new. I had to visit 5 salvage yards before I found a salvage yard that had a Cherokee of that vintage with the correct part. The better salvage yards are not keeping anything older than 2000 vintage vehicles. I am going to go back and see if I can pick anything else off it before it too goes to be melted down.
DonBC is offline   Reply With Quote Quick reply to this message
Unread 03-20-2014, 07:59 PM   #6
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,325
I have a list of stuff I may need in the future.

CPS bolts, radiator upper rubber mounts, yada yada.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.