88 comanche 4.0 belt screech - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > 88 comanche 4.0 belt screech

Artec Holiday Sale!Bead Lock Wheels! Raceline, Trail Ready, & Trail-GearROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 08-11-2013, 10:05 PM   #1
sbwell1020
Registered User
 
Join Date: Aug 2013
Location: san luis obispo, CA
Posts: 3
88 comanche 4.0 belt screech

Sounds like a bearing screech the mechanic said it was my a/c eliminator bearing and the water pump bearing so I replaced that pulley and the water pump. Still have the same screech but when I put oil on the belt it goes away for a minute. Could it be a bearing if it goes away when I put oil on the belt?

sbwell1020 is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 10:13 PM   #2
sbwell1020
Registered User
 
Join Date: Aug 2013
Location: san luis obispo, CA
Posts: 3
Sounds like it is coming from the new water pump bearing. Could I have wrecked the bearing so quick by over tightening the belt?
sbwell1020 is offline   Reply With Quote Quick reply to this message
Unread 08-27-2013, 12:50 PM   #3
TrucksBootsNGun
Registered User
1988 MJ Comanche 
 
Join Date: Aug 2013
Location: Flagstaff, ARIZONA
Posts: 46
I also have a '88 Comanche 4.0L and when I first bought it did was doing the same thing. Guy told me he thought it was the water pump but he had just replaced the idler and belt. I also noticed that it went away when you hit the belt with grease or even water. So I left it and drove it. The noise disappeared about a week or week and a half later (about 1000 miles). That was at 185,XXX. I'm now at 190,XXX and I just switched my truck over to a open radiator design like the '92 and later Cherokees had. In doing so I replaced the water pump while I was at it. Now the squeal is back. I think that it is due to the belt just re-breaking in because if I splash some water on the belt it disappears. Plus after a 3 days of driving and 500 miles later the squeal is noticeably quieter but still present. I know its annoying but I'd say based on my experience just drive it.
TrucksBootsNGun is offline   Reply With Quote Quick reply to this message
Unread 08-30-2013, 12:51 PM   #4
TrucksBootsNGun
Registered User
1988 MJ Comanche 
 
Join Date: Aug 2013
Location: Flagstaff, ARIZONA
Posts: 46
Just thought you might like an update, my squeal stopped somewhere between 562 and 575 miles after the messing with the engine. Hope yours stops soon as well
TrucksBootsNGun is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.