87 comanche 4x4 4.0 5spd - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > 87 comanche 4x4 4.0 5spd

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 02-19-2013, 07:26 PM   #46
97_4popper
Registered User
1990 MJ Comanche 
 
Join Date: Jan 2005
Location: Guston, KY
Posts: 463
If heater core is bad, it would probably be leaking.
Check your thermostat. that may be why it doesn't blow warm.

__________________
90 MJ 4.0 4X4 5sp LB Pioneer Big Ton.
Truck contains parts from 3 MJs, 2 XJs, 1 TJ and a dishwasher.
http://img.photobucket.com/albums/v1...IMG_0101-2.jpg
Check out comancheclub.com...
My build thread: http://comancheclub.com/forums/viewt...hp?f=7&t=27756
Wifes: 97 TJ 2.5 4X4 5sp 31's stock. . . Slow but; reliable.
97_4popper is offline   Reply With Quote Quick reply to this message
Unread 02-20-2013, 08:20 AM   #47
Mishimoto
Registered User
 
Join Date: Apr 2012
Location: Wilmington, Delaware
Posts: 410
Quote:
Originally Posted by 97_4popper View Post
If heater core is bad, it would probably be leaking.
Check your thermostat. that may be why it doesn't blow warm.
+1, unless the core is clogged and restricting coolant flow.
Mishimoto is offline   Reply With Quote Quick reply to this message
Unread 02-21-2013, 09:35 AM   #48
donutman07
Registered User
1987 MJ Comanche 
 
Join Date: Sep 2012
Location: lainsing, michigan
Posts: 27
my friend and i somewhat cleaned out the heater core by flushing out a bunch of what looked to be rust and gunk, we flushed it out with water, and when he drove it over to my house he said that there was a little bit of heat comming out of it now.
donutman07 is offline   Reply With Quote Quick reply to this message
Unread 02-21-2013, 05:58 PM   #49
donutman07
Registered User
1987 MJ Comanche 
 
Join Date: Sep 2012
Location: lainsing, michigan
Posts: 27
i took irt fora little drive out back behind the house and had to use the 4wd and now the 4wd light is staying on does anybody have any ideas on what i should check? any help would be much appreciated
donutman07 is offline   Reply With Quote Quick reply to this message
Unread 02-22-2013, 11:48 PM   #50
carnuck
Registered User
1984 J-Series Truck 
 
Join Date: Nov 2004
Posts: 3,212
Probably bad hose or the switch on the trans is stuck.
__________________
"Usually found in a Jeep near Reiter, WA"
FOR SALE STUFF
http://tinyurl.com/jimsclads

'81 Eagle wagon with upgrades $2500
'87 Comanche shortbox 4.0/AW4/NP242 on 33" tires $3500
carnuck is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.