86 comanche trouble - JeepForum.com

 
LinkBack Thread Tools
post #1 of 15 Old 09-17-2012, 06:05 PM Thread Starter
goatroper57
Registered User
 
Join Date: Jun 2012
Location: annapolis
Posts: 5
86 comanche trouble

hello all
i have an 86 comanche its running but when i drive it it gets up to about 40 mph or so and then starts buckin like its starvin for gas so i replaced the fuel pump and no change i do have a barrel filter between the gas tank and carb. on the inside fender wall and i see ther is a lot of air bubbles in it when its running and for a little bit after its shut off then after a whyll the barrel filter it dose not have any gas in it at all the filter is new i allso change the filter in the carb. to i drove it to day and when i was comin back home i have to go up a hill about 1/2 mile long and i had to let off the gas goin up it all most to an idle before i got up the hill what could be cusin the problem can any one help please
thanks
goatroper57

goatroper57 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 09-17-2012, 06:55 PM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
2.1/2.5 or 2.8l...

fuel pump in the tank- did you replace the hose on the pump to the sending unit.... thinking maybe its split and recurculating fuel in the tank and your not getting the right fuel psi as well air mixed in it..

or
engine driven fuel pump... the sending unit pick up pipe is rotten/holes or lines leaking and sucking air in..
mj40 is offline  
post #3 of 15 Old 09-17-2012, 08:03 PM Thread Starter
goatroper57
Registered User
 
Join Date: Jun 2012
Location: annapolis
Posts: 5
thanks for the fast reply and its a 2.8l engine driven fuel pump where is the sending unit pick up pipe
goatroper57 is offline  
post #4 of 15 Old 09-18-2012, 04:48 AM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
in the tank, only good pic of one i could find..

http://www.ebay.com/itm/New-NOS-86-J...-/271048773289
mj40 is offline  
post #5 of 15 Old 09-18-2012, 07:02 AM
Rican142
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2012
Location: Vineland
Posts: 1,226
Im havein the same prob but its when I'm goin cryisin at a faster speed Like 50 nd up. But if I give it more gas it stops doin it for a sec till the rest of the truck catches up. Might I need bigger injectors? Or a faster fuel pump

64 Ford F-100
89 Jeep Comanche
97 Jeep Wrangler
Rican142 is offline  
post #6 of 15 Old 09-18-2012, 03:19 PM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
Quote:
Originally Posted by Rican142 View Post
Im havein the same prob but its when I'm goin cryisin at a faster speed Like 50 nd up. But if I give it more gas it stops doin it for a sec till the rest of the truck catches up. Might I need bigger injectors? Or a faster fuel pump
4.0l? your fuel psi will need to be checked...maybe bad fuel pressure regulator or a weak fuel pump
mj40 is offline  
post #7 of 15 Old 09-18-2012, 04:22 PM Thread Starter
goatroper57
Registered User
 
Join Date: Jun 2012
Location: annapolis
Posts: 5
thank you mj40 so i guess ill have to take the gas tank out to get to that part right one good thing i have another truck just like tis one for parts i think ill just swap gas tanks and hope for the best again thank you for the info. mj40 ill let ya know how thing went after i get it swaped it mite be a few days or more before ican get to it thou later all
goatroper57 is offline  
post #8 of 15 Old 09-18-2012, 04:39 PM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
Quote:
Originally Posted by goatroper57 View Post
thank you mj40 so i guess ill have to take the gas tank out to get to that part right one good thing i have another truck just like tis one for parts i think ill just swap gas tanks and hope for the best again thank you for the info. mj40 ill let ya know how thing went after i get it swaped it mite be a few days or more before ican get to it thou later all
your sending unit will be on the topside of the tank...likly better to swap tank as if you disturb the sending unit you will need a new seal and lock ring most times..

good luck..
mj40 is offline  
post #9 of 15 Old 09-18-2012, 06:11 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,064
Whoa!! He has a 2.8 V-6 with an engine mounted pump as stated in Post #3..
cruiser54 is offline  
post #10 of 15 Old 09-18-2012, 06:32 PM
Rican142
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2012
Location: Vineland
Posts: 1,226
Quote:
Originally Posted by mj40

4.0l? your fuel psi will need to be checked...maybe bad fuel pressure regulator or a weak fuel pump
Yes its a 4.0

64 Ford F-100
89 Jeep Comanche
97 Jeep Wrangler
Rican142 is offline  
post #11 of 15 Old 09-18-2012, 06:36 PM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
Quote:
Originally Posted by cruiser54 View Post
Whoa!! He has a 2.8 V-6 with an engine mounted pumpas stated in Post #3..

hey, i'll be like you and not read it all and bump up my post counts


mj40 is offline  
post #12 of 15 Old 09-18-2012, 07:20 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,064
Quote:
Originally Posted by mj40 View Post
hey, i'll be like you and not read it all and bump up my post counts


Read Post #3!!

And, 4.0 didn't come out til 1987. Who isn't reading?
cruiser54 is offline  
post #13 of 15 Old 09-18-2012, 07:36 PM
mj40
Registered User
1989 MJ Comanche 
 
Join Date: Jul 2011
Location: north bay/corbeil
Posts: 282
Quote:
Originally Posted by cruiser54 View Post
Read Post #3!!

And, 4.0 didn't come out til 1987. Who isn't reading?
ok, i'll keep up, theres 2 poster in this posting..

1st post was 86 2.8
2nd is 89 4.0
mj40 is offline  
post #14 of 15 Old 09-18-2012, 07:40 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,064
Quote:
Originally Posted by mj40 View Post
ok, i'll keep up, theres 2 poster in this posting..

1st post was 86 2.8
2nd is 89 4.0
Ah, yes. Hijacks are always so helpful, aren't they?
cruiser54 is offline  
post #15 of 15 Old 04-21-2013, 12:19 AM
Rican142
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2012
Location: Vineland
Posts: 1,226
Figured out what the problem was, it was a bad oxygen sensor and cracked distributor, replaced that and it was smooth sailing

64 Ford F-100
89 Jeep Comanche
97 Jeep Wrangler
Rican142 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
87 comanche srhdog90 MJ Comanche Technical Forum 8 04-08-2012 04:47 PM
86 comanche fernjohn MJ Comanche Technical Forum 1 10-02-2010 09:18 PM
new to comanche's 94xj-86mj MJ Comanche Technical Forum 1 04-08-2010 08:01 AM
How This Comanche Look? Gnl.Weirdness MJ Comanche Technical Forum 27 04-05-2010 01:50 PM
Trouble Code Trouble!!! Jeepthing88 XJ Cherokee Technical Forum 7 04-08-2006 03:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome