post #1 of Old 09-22-2012, 08:04 PM Thread Starter
RedJeepCreep
Registered User
 
Join Date: Sep 2012
Posts: 1
I need help!! My truck has 4wd issues!!!

Have a 97 grandcherokee and i just replaced the transfer case its a 242j selectrac fyi. When i make circles or sharp left or right turns the front wheels seem to skip or hop more than a vehicle in 4wd should it feels like the front end is wobbling almost when u turn left or right sharply. But the wheel u joints seem ok and the front ends decent besides a worn drag link . Now what could be the cause of this issue from what i can tell the wheel ujoints "seem" ok but i need a second opinion. Cmon jeepers i need some input help me out!!!!!!!!

RedJeepCreep is offline  
post #2 of Old 09-23-2012, 10:52 AM
gs69350
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Sellersburg
Posts: 327
You are still in 4wd part time. Are you sure you don't have a 249?

1998 Jeep Grand Cherokee 5.9 Limited - Stone White - Stock for now.
http://www.facebook.com/groups/59limited/ <-- 5.9 Owner's group on FB.
gs69350 is offline  
post #3 of Old 09-23-2012, 11:24 AM
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken
Posts: 1,751
Post in the ZJ forums for more help, sounds like you're either stuck in 4WD PT or you have the NP249 TC and the viscous coupler is locking up/going bad.

4.0 or 5.2 motor? The linkage may be out of alignment. It may look like you are in 2WD in the Jeep, but the TC is still in 4WD.

94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome