hey guys A/C question. help please - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 05-25-2013, 01:54 AM Thread Starter
jeepboyy
Registered User
 
Join Date: May 2013
Location: new york
Posts: 20
hey guys A/C question. help please

hey guys its me again....im having problems with my A/C.....well lets get started

i have a 2002 jeep grand cherokee laredo v6 4 wheel drive....

1.the a/c when i turn it on blows out air but it is not cool at all it is hot air......
2. i checked freon and had somebody checked too....plenty of freon..thats not a problem....
3. the compressor does not engage when A/C is turned on

2 people told me it could be an eletrical problem...perhaps a relay or fuse.....
could it be that simple where i just replace the relay for the A/C clutch in the relay/fuse box, i think its number 38?.....

what do you guys think

jeepboyy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-26-2013, 01:18 PM Thread Starter
jeepboyy
Registered User
 
Join Date: May 2013
Location: new york
Posts: 20
Anybody
jeepboyy is offline  
post #3 of 6 Old 05-26-2013, 11:50 PM Thread Starter
jeepboyy
Registered User
 
Join Date: May 2013
Location: new york
Posts: 20
Please
jeepboyy is offline  
post #4 of 6 Old 05-27-2013, 12:50 AM
25greenwrangler
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2011
Location: Hull
Posts: 163
What's the night side and low side pressure? More than likely if the fuses , relays, wires and everything else is good its probly the a/c clutch but it would have it checked for sure

why buy when you can build?
25greenwrangler is offline  
post #5 of 6 Old 05-27-2013, 09:19 PM
jasonswelding
Registered User
1999 TJ Wrangler 
 
Join Date: Apr 2011
Location: Blanchard
Posts: 405
Start with the fuse.

You could use a test light or meter to see if there is power to the clutch. If not start working backward to see where power is lost.

If the clutch doesn't engage there is no low side/high side, just static pressure.
jasonswelding is offline  
post #6 of 6 Old 05-29-2013, 07:02 PM
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell
Posts: 2,052
Check the low side switch too
dusterdude is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome