ABS light came on whats wrong - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Cheap Tricks & Fixes > ABS light came on whats wrong

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 12-01-2011, 04:49 PM   #1
jeepgirl1321
Registered User
1997 ZJ 
 
Join Date: Dec 2011
Location: , new Hampshire
Posts: 65
ABS light came on whats wrong

after a slight trail ride in my jeep the abs light came on next time i started the car. and it wont go off...help..

jeepgirl1321 is offline   Reply With Quote
Unread 12-08-2011, 11:51 AM   #2
xjmatt720
Registered User
2000 XJ Cherokee 
 
Join Date: Dec 2011
Location: wall, nj
Posts: 3
your brakes is what is wrong. but get down and into your brakes with a high pressure hose. sometimes mud. snow or sand gets in the sensor and there is no actual problem. especially if you were spinning your wheels alot.
xjmatt720 is offline   Reply With Quote
Unread 12-08-2011, 12:14 PM   #3
Jacobite
Registered User
1990 XJ Cherokee 
 
Join Date: Jun 2011
Location: Longview, WA - Washington
Posts: 2
Quote:
Originally Posted by xjmatt720
your brakes is what is wrong.
My ABS started going out a couple months ago. At first braking was kinda scary, but now that the ABS is completely gone the brakes work pretty good, except I need new pads. I plan on replacing with standard power brakes. Never liked the ABS.
Jacobite is offline   Reply With Quote
Unread 12-18-2011, 08:04 AM   #4
BandGauto
Registered User
2004 WJ 
 
Join Date: Dec 2011
Location: Buffalo, NY
Posts: 122
Most likely a wheel sensor. Have someone with a scanner that reads ABS plug into OBDII port under the dash and it will tell you which wheel sensor is at fault.
BandGauto is offline   Reply With Quote
Unread 12-29-2011, 06:37 PM   #5
Griff1918
Web Wheeler
2003 TJ Wrangler 
 
Join Date: Oct 2011
Posts: 1,624
Wheel speed sensor. Check for mud, loose or broken wire.
Griff1918 is offline   Reply With Quote
Unread 01-02-2012, 07:43 AM   #6
jeepgirl1321
Registered User
1997 ZJ 
 
Join Date: Dec 2011
Location: , new Hampshire
Posts: 65
yeah thats what i believe it iss! thankss
jeepgirl1321 is offline   Reply With Quote
Unread 01-03-2012, 02:15 PM   #7
Spiffums
Registered User
2000 TJ Wrangler 
 
Join Date: Apr 2011
Location: Sweetwater, Tennessee
Posts: 92
I have had the light on my Explorer for years. Apparently the only thing to do is take the bulb out...... both times I have had it "fixed" this is what they did.
__________________
Zombie Outbreak Response Unit
Spiffums is offline   Reply With Quote
Unread 01-03-2012, 02:59 PM   #8
jeepgirl1321
Registered User
1997 ZJ 
 
Join Date: Dec 2011
Location: , new Hampshire
Posts: 65
well i cheaked my senores and i think the one on my drivers side is broken but there pricy to replace /:
jeepgirl1321 is offline   Reply With Quote
Unread 01-03-2012, 10:59 PM   #9
Griff1918
Web Wheeler
2003 TJ Wrangler 
 
Join Date: Oct 2011
Posts: 1,624
Just for the part, cause its easy to install
Griff1918 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.