99 TJ Battery problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Cheap Tricks & Fixes > 99 TJ Battery problems

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineJeep parts, deals and more at JeepHut.comTJ BDS 2" suspension lift!! FINALLY a GREAT 2" l

Reply
Unread 03-18-2015, 12:21 PM   #1
eldanimal
Registered User
 
Join Date: Mar 2015
Location: WILLIAMSPORT, PA
Posts: 7
99 TJ Battery problems

I roughly cleaned my corroding terminals on Sunday to fix a sluggish start. It worked for two days. Last night I had to hit the throttle to turn the engine over. This morning the battery was dead, and I was unable to jump it.

I was unable to get the positive cable off the terminal and will try again tonight, but it was strange that everything worked for the first two days and then nothing.

The only thing I can guess is that the battery acid wasn't fully neutralized before I rinsed it off and it got into something else.

I really appreciate any advice.

eldanimal is online now   Reply With Quote Quick reply to this message
Unread 03-21-2015, 01:21 AM   #2
OMNIMAN
Junior Member
 
OMNIMAN's Avatar
1999 TJ Wrangler 
 
Join Date: Jan 2015
Location: Nashville, TN
Posts: 35
How old is the battery?
__________________
I'm not your buddy, friend !
I'm not your friend, Pal !
I'm not your pal, buddy !
OMNIMAN is offline   Reply With Quote Quick reply to this message
Unread 03-21-2015, 01:26 AM   #3
OMNIMAN
Junior Member
 
OMNIMAN's Avatar
1999 TJ Wrangler 
 
Join Date: Jan 2015
Location: Nashville, TN
Posts: 35
One time about a year ago my battery kept dying. I got a new battery... after a few days it was dying again. Checked and recheck ed everything twice. Everytime i would go more than a day without driving my battery was dead. After a few months i got under the jeep looked up and realized that my under the hood light was activating when the hood was down and off when it was up. Finally cut the thing off and my battery stopped dying. Everything has been good ever since.
__________________
I'm not your buddy, friend !
I'm not your friend, Pal !
I'm not your pal, buddy !
OMNIMAN is offline   Reply With Quote Quick reply to this message
Unread 03-27-2015, 02:38 PM   #4
eldanimal
Registered User
 
Join Date: Mar 2015
Location: WILLIAMSPORT, PA
Posts: 7
It turns out I DEFINITELY did not clean my terminals well enough. I think that I loosened up the corrosion enough to work, but without removing it all it reset between the terminals and the posts.
Redid the job right and everything worked without a jump. Thank you both for the help.
eldanimal is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.