Oil pressure sending unit - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Advanced Jeep Tech > Oil pressure sending unit

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 08-02-2013, 01:41 PM   #1
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
Oil pressure sending unit

90 xj oil pressure sending unit help
So i was reading on some forums on here and alot of people say that their oil pressure sending unit was leaking oil. So i went to check mine out, it had a little oil on it but the wire coming out was hanging there not connected to anything! I looked all around the area and could not find any other disconnected wires. Does anybody know where the wire goes to from the unit? i was having problems with my oil gauge, and I think i might have found the problem. Now if i can just figure out where the wire needs to be reconnected I will be golden. Thanks!

Elrod90xj is offline   Reply With Quote
Unread 08-03-2013, 10:54 AM   #2
19Mike95
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2013
Location: Port orchard, Wa
Posts: 40
Just follow the wire you'll always find out where it goes
19Mike95 is offline   Reply With Quote
Unread 08-04-2013, 01:02 AM   #3
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
Quote:
Originally Posted by 19Mike95 View Post
Just follow the wire you'll always find out where it goes
The wire is connected to the unit, and is about a foot long at the end is a splicer that is disconnected so the wire just ends. My problem is that I can't find the other end that it came off of it. Is it just one wire running from the gauge to the unit? If so I should be able to just run a new wire from the gauge to the unit, right?
Elrod90xj is offline   Reply With Quote
Unread 08-04-2013, 01:16 AM   #4
19Mike95
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2013
Location: Port orchard, Wa
Posts: 40
The rubber booted end is unplugged? Lemme go look at mine real quick ill let u know where it's supposed to go unless mines messed up to lol
19Mike95 is offline   Reply With Quote
Unread 08-04-2013, 01:26 AM   #5
19Mike95
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2013
Location: Port orchard, Wa
Posts: 40
I don't know what color wire yours may be but mine is yellow/black and goes to the harness than branches off from there one runs up along the valve cover to the battery one runs under the tub I'm assuming it goes into gauge on your dash
19Mike95 is offline   Reply With Quote
Unread 08-04-2013, 01:52 AM   #6
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
The rubber booted end is plugged into the unit and has one wire coming out that is not connected to anything.
Elrod90xj is offline   Reply With Quote
Unread 08-04-2013, 01:56 AM   #7
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
Quote:
Originally Posted by 19Mike95 View Post
I don't know what color wire yours may be but mine is yellow/black and goes to the harness than branches off from there one runs up along the valve cover to the battery one runs under the tub I'm assuming it goes into gauge on your dash
Also the wire coming out of the unit is blue, and I don't have any wires runningalong the valve cover, all the wire looms are running between the battery and overflow tank. Mines a 1990 so maybe it's different
Elrod90xj is offline   Reply With Quote
Unread 08-04-2013, 01:58 AM   #8
19Mike95
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2013
Location: Port orchard, Wa
Posts: 40
But the harness also y s off to under the firewall
19Mike95 is offline   Reply With Quote
Unread 08-04-2013, 02:01 AM   #9
19Mike95
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2013
Location: Port orchard, Wa
Posts: 40
I could also be wrong so best bet go to your local parts store they should print off a diagram which would show you exactly where it goes.
19Mike95 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.