JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Advanced Jeep Tech (http://www.jeepforum.com/forum/f369/)
-   -   4.7 stroker problems (http://www.jeepforum.com/forum/f369/4-7-stroker-problems-1497597/)

blu3fan 03-22-2013 09:11 PM

4.7 stroker problems
 
ok so here goes.
i got a 92 cherokee xj 4.0 inline 6
bored it 30 thou over stroked to 4.7
skat crank
comp cams K68-231-4 cam
mopar valvetrain
new stock pushrods
pistons and rods i dont know got them off ebay but they were good quality
yella terra 1.6 roller rockers
flowcooler water pump
upgraded oil pump
mustang injectors
new spark plugs reused distributor
so heres what happened.
about four years ago we pulled the motor. and rebuild it. life happened and the car ended up sitting. i got the motor back into it in december of last year. fired fine on startup
so heres the list of things wrong.
1. rear main seal is leaking oil between transmission and engine. <-- i can just pull the oil pan and snake another in correct ?
2. electrical issues. theres a drain. batteries die after 5 days sitting in car its a slow one but there is one. im thinking i hooked up a wire off the alternator to the wrong spot
i need a wiring diagram for the wires off the alternator, also theres a wire coming out of the fusebox. i routed it to the battery post. correct ?
lights blinkers and dash lights etc doesn't work while car is running. but work fine if engine is off
3. valve train is noisy, Ive heard comp cams cams are loud, or could there be an issue ?
4. the big one.
so. car has trouble starting. sometimes have to crank and hit gas for a good few seconds before she finally turns over.
when she starts she idles really low for a warmup. engine feels like its surging. if i hit the gas. when it gets to about 2400/2900 it does what seems like a misfire/backfire and rpms literally drop off it jumps from 2900 to 2400 in a second. it smells like gas.
we did a fuel pressure test seems fine. i need to do a fuel volume test on it. how would i do that ?
the gas that was sitting in the tank (4/5 gallons) i pumped out. filtered and put into another car. there was orange goo in it, so i changed the fuel filter
still same issue.
so now im thinking it may be the fuel pump, yes i have the tank skid :( so its not fun for a maybe to be pulling the tank down.
anyone have any ideas ?
im thinking it smells like gas and drops of cos theres not enough fuel to ignite so it misfires because the pump maybe is blocked by crap left over in the tank or maybe my 210000mile old pump is dying.

blu3fan 03-28-2013 12:55 PM

re did the timing. no luck yet
ideas anyone ?

kw89425 04-01-2013 09:40 PM

Its not all of your problems but if it sat 4 years after it was put together and valves adjusted it needs new springs.

foggybottombob 04-03-2013 03:37 PM

You might get more help here:
http://www.jeepstrokers.com/forum/

blu3fan 04-05-2013 05:38 PM

allready posted there.
its something stupid i know it.

blu3fan 04-05-2013 05:46 PM


foggybottombob 04-08-2013 08:14 AM

What do you have for a fuel regulator? Is the fuel regulator leaking?

CZDiesel 07-29-2013 03:38 PM

Did you ever get it figured out?

blu3fan 07-30-2013 01:47 PM

it ended up being an issue with timing. had to hack up the distributor and manually set it.

CZDiesel 07-30-2013 06:03 PM

So, how does she run?


The time now is 08:47 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.