CB problems - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Four Wheeling Forums > Wheelin' Neighborhood > South Central USA > Colorado Jeep Forum > CB problems

Get ready!! CyberMonday deals are coming!!!Last few hours of great savings JeepHut.comFinal Hours! Last Chance to Save Big for the Year.

Unread 07-27-2007, 09:05 PM   #1
Web Wheeler
KUK9's Avatar
2000 TJ Wrangler 
Join Date: Oct 2003
Location: Denver, Colorado
Posts: 3,194
CB problems

Ok. Those of you who have been on runs with me know the problems I have been having with my CB. For those that don't know, here's a quick run down.

I am currently running a Cobra 29 WX NW ST Mobile CB, with a 3' Firestick (brand new antenna). It was not purchased new, but was fine when I got it. The antenna wire was also used. Anyhow, the first time on a run, it took me a bit to get it working- a quick SWR tune, adjusting a little bit, but I eventually got it to work. However, on successive trail runs, the CB will work perfectly at times, but not at other times nothing at all. At some times I can receive all the messages, but it will not let me transmit (nobody hears me). Other times only certain other radios can hear me. The antenna light on the 29 will sometimes be dimly lit as I am transmitting- this seems to be the only time it was working right. When that didn't lite up a little, nobody could hear me. However, I know this shouldn't be happening without something wrong.

Now, I had a couple other CB's in the garage, but had never changed it to see if it was just the CB itself, or if the wire was messed up (it did have some electrical tape on one end). So that brings me to tonight. I was going to swap the 29 with a Cobra 25 classic that I knew worked. So I ran a new antenna wire, got everything hooked up, and tried to turn the 25 on- nothing. Then I smelled that electrical wire burning smell, so I turned it off and unplugged everything- then I saw smoke coming out of the 25. So now the 25 is toast. I plugged back in the 29, and it's still working, as is the smaller older 25 I have.

Anyhow, right now I am in a pickle. I have 2 CB's to choose from (which I have to install tonight so I have it tomorrow for the run), and am not sure which I should go with. I have never tested the smaller 25, so I don't know if that one works right anyway. The 29 seems to be ok, but I don't have anyone around with a CB to test it on. So here's my main question. Do the problems seem to point to the CB itself, or possibly the wire? I've replaced the antenna wire with a brand new one, but I am not sure about the CB. Any ideas?

REDLYNER Racing #4550

My Build Thread:
KUK9 is offline   Reply With Quote Quick reply to this message
Unread 07-27-2007, 11:10 PM   #2
Registered User
2000 TJ Wrangler 
Join Date: Aug 2006
Location: , CO
Posts: 744
You are pretty close to the freeway, you might try the 25 and see if you can pick up some lonely truckers.
If you have replaced the coax cable from the antenna to the cb and the antenna is new, it sounds like it should be the cb itself.

Buy Shag A Lifetime Membership
Originally Posted by afbond03
....just need a nice tug it would be really simple to get me from behind just pull me back....
rbowling is a thief. I bought these gears from him, and now I am out my money and still no gears. Do not trust him.
Shag is offline   Reply With Quote Quick reply to this message
Unread 07-28-2007, 05:22 PM   #3
FPKites's Avatar
1996 ZJ 
Join Date: Sep 2004
Location: Denver, Colorado
Posts: 13,521
Day late and a buck short...Josh, check all the spots where your power can be hitting the tub or anything else and tape the **** out of it. Cobras are picky when it comes to their power source.

As far as repairing either radio if they're fried - take them over to the old farts at 900 south Sheridan. I wouldn't take my rigs anywhere else.
Jim Karlin
"How the heck do you get there?"
"Duh! Big RED Jeep!!!"
Best customer service in the states:

96 ZJ Laredo
5" lift, Claytons, KOR radiator support, rear bumper, steering brace, etc, etc, etc.

04 WJ Overland
Clean.... :D
FPKites is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Suggested Threads

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.