post #1 of Old 10-14-2012, 03:14 PM Thread Starter
pettylm
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2012
Location: West Valley City
Posts: 49
Cb radio problems

Are there any cb experts out there that wanna look at my set up, or know a good place to go. Swr is 2.5 on all channels. Galaxy 99v.

pettylm is offline  
post #2 of Old 10-20-2012, 08:21 AM
Tuffjeeper
Registered User
2000 TJ Wrangler 
 
Join Date: May 2009
Location: Utah
Posts: 1,626
Id check to make sure that there isn't a ground where there shouldnt be one. it can be backfeeding which is a nono. Keep posting questions and Ill help you however i can.

The Tuff Jeep Build Thread

Quote:
Originally Posted by plrbear View Post
Destroyed it somehow..... It went wobble wobble wobble boom
Tuffjeeper is offline  
post #3 of Old 10-22-2012, 07:34 PM Thread Starter
pettylm
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2012
Location: West Valley City
Posts: 49
As far as I know the antenna mount is the only thing grounded. I will double check.
pettylm is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome