WJ Transmission Issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > WJ Transmission Issues

Huge Soft top SaleRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!

Reply
Unread 12-14-2013, 10:22 AM   #1
Littlejon
Registered User
2000 XJ Cherokee 
 
Join Date: Jun 2013
Location: Reidsville, NC
Posts: 6
WJ Transmission Issues

OK, new to the forum, so I hope you can help. I have an '01 Grand Cherokee Laredo with the I-6, & 4WD. Absolutely wonderful vehicle, as she has 218,000 on it and still running good.

Anyway, there are two things are going on right now that concern me. First, at highway speeds I can accelerate and the tranny drops down and immediately back up, almost like the old 4 barrel carbs used to do when you floored them. I also have the problem happen when I am cruising down the highway with the cruise control on. I basically constantly drops back to 3rd and immediately goes back to 4th/OD. To the point that cruise control is useless. This happened a long time ago and the dealership installed some kind of new module that ended up costing me about $250 with parts & labor. Obviously I need to do this myself if at all possible.

Second issue happened last night while in a drive through line. As we crept along, it really started vibrating, almost like it was something in the fuel line. But, when I put it in neutral, it stopped. Put in drive, it vibrates and hesitates like crazy. With cars in front of me and cars behind me, I had to do this the whole time for fear of it shutting off. About 5 minutes after it started, it was gone and she purred like a kitten again. So far I haven't been able to get it to do it again, but with Christmas shopping and this being the wife's DD, I want to find a fix ASAP.

Could these both be the result of a bad module or sensor somewhere or am I looking at two separate issues that someone beyond a shadetree mechanic (me) needs to look at?

Thanks in advance!

Littlejon is offline   Reply With Quote Quick reply to this message
Unread 12-14-2013, 12:35 PM   #2
pdpunome
Web Wheeler
 
pdpunome's Avatar
2000 WJ 
 
Join Date: Mar 2011
Location: , NJ
Posts: 1,002
I am dealing with similiar in regards to vibration in drive while stopped but disapears in neutral been doing it for a year now. Shifts fine do hear a whine when going into 2nd or 3rd but still runs like a champ with 203k. Dropping in and out of gears I would see if it still does it with the o/d turned off. Could be a solenoid or o/d related. Either one is not terrible to fix and biggest cost maybe fluid costs and your time of dropping the pan. Could crawl underneath and see if your cables loog good underneath. Another thing you could try is adjusting the kick down cable under the hood. That will change the shift patterns according to rpms. easy and fast to adjust.
__________________
2000 4.0 Selec Trac
pdpunome is offline   Reply With Quote Quick reply to this message
Unread 12-14-2013, 12:37 PM   #3
pdpunome
Web Wheeler
 
pdpunome's Avatar
2000 WJ 
 
Join Date: Mar 2011
Location: , NJ
Posts: 1,002
youtube jeep kickdown cable great videos on "how to"
__________________
2000 4.0 Selec Trac
pdpunome is offline   Reply With Quote Quick reply to this message
Unread 12-14-2013, 10:17 PM   #4
Littlejon
Registered User
2000 XJ Cherokee 
 
Join Date: Jun 2013
Location: Reidsville, NC
Posts: 6
Ok, thanks! I will check those and see what happens. The wife drove it all day today shopping and didn't have any issues, so I am hoping it was a fluke. It was pretty cold, so it could have been that something was affected by that. I plan to check the vacuum lines as well.
Littlejon is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.