WJ massive oil consumption - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > WJ massive oil consumption

Engo winches available at www.rockridge4wd.com! Free shippThe Original 3/8" Ruffstuff Diff Cover!The Ruffstuff NOT Universal 4 Link Kit!

Reply
Unread 03-21-2010, 11:43 AM   #16
boostjunkie
Registered User
 
Join Date: Jan 2009
Location: Chicago
Posts: 13
Quote:
Originally Posted by Kruzin View Post
Don't need to drain the coolant.
Just open the cap and look at it. Maybe draw a sample from the radiator.
How's it look?

And how do you fit a whole tennis court of oil in there?
Mine can only hold 5 quarts.
Just drained the coolant and looks pretty normal, little harder then new nut idk when coolant was last flushed on it. More mucky i guess.

I pulled the throttle body and cleaned IAC. I noticed a good amount of oil in the back of it and by the IAC.

What could it be?

boostjunkie is offline   Reply With Quote
Unread 03-21-2010, 11:51 AM   #17
boostjunkie
Registered User
 
Join Date: Jan 2009
Location: Chicago
Posts: 13
Quote:
Originally Posted by Kruzin View Post
Valve seals should not cause massive oil loss.
Valve guides, maybe, but not the seals.
But bad guides will usually also produce a clattering noise.

Bad valve seals will cause some smoke out the tailpipe at startup.
But not so much once running. And generally not such a massive use of oil.

This is why we have been saying to check the coolant.
It sounds more like a bad head gasket than anything else, from the limited info we have...
I just drained the coolant as stated on my post. Seems more like it wasn't flushed in a while then anything. How would coolant with blown head gasket look.

Also to answer some questions in your post. Smokes a little at start up but once warm and running for a while, I've checked the tail pipe and was not smoking.
boostjunkie is offline   Reply With Quote
Unread 03-21-2010, 11:56 AM   #18
boostjunkie
Registered User
 
Join Date: Jan 2009
Location: Chicago
Posts: 13
Quote:
Originally Posted by QuadraTokn View Post
A lifted WJ in Chicago? I wanna see it!
Well sir, now that I've read your signature, looks like you might be seeing it in person haha. I need passanger front and driver rear lock actuator. Happen to have them? Where are u located, I work in elk grove village and live in Chicago. Pm me your number
boostjunkie is offline   Reply With Quote
Unread 03-21-2010, 12:35 PM   #19
boostjunkie
Registered User
 
Join Date: Jan 2009
Location: Chicago
Posts: 13
My pcv valve was completely shot and the rear of the intake manifold is completely caked with oil. Would that cause that much oil to burn up?
boostjunkie is offline   Reply With Quote
Unread 03-22-2010, 01:04 PM   #20
boostjunkie
Registered User
 
Join Date: Jan 2009
Location: Chicago
Posts: 13
No opinions, comments?

I put some of that motor honey stuff in during my oil change and my ticking went away for my first start up since it's been apart. Nothing else is different other then that, new spark plugs and pcv. I did hear about some head gasket repair stuff you throw in the cooling system, any opinions on that. If it last for a lol it would be awesome so I don't have to rip apart the motor now.
boostjunkie is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.