WJ making clicking noise on coasting under 30mph - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > WJ making clicking noise on coasting under 30mph

Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiJeep Gear & Install Packages!Rough Country Lift Kits and Parts!

Reply
Unread 11-23-2011, 02:15 PM   #1
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA, Henrietta, NY
Posts: 6,276
WJ making clicking noise on coasting under 30mph

Help guys! I just left the airport today and I noticed my Jeep was making a click click click noise coming from the rear it seemed. It was proportional to speed and gets much quieter over 30ish mph. It goes away completely the second I touch the brakes. Clicking seems like its metal (not a soft muffled tick) and seems to be once per wheel revolution I'd say. It may be relevant but I've had my e-brake handle disconnected for a month now. Also one of the axle seals was leaking for a little bit but that was over a year ago and it has not shown any signs of any problems since.

I have a D35 3.55 gearing.

__________________
98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 03:01 PM   #2
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA, Henrietta, NY
Posts: 6,276
I put up a youtube video... try and switch to higher quality and turn up speakers... my laptop completely slaughtered the noise but I can hear it perfectly on my phone in the source video. The more I drive it the more it almost feels like its coming from under the floor pan not even necessarily rear diff... possibly xfer case?!

__________________
98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2011, 01:21 AM   #3
indept
Registered User
2000 WJ 
 
Join Date: Aug 2007
Location: New Jersey
Posts: 1,315
I would suspect your drive shaft U- joints. Do they look "extra" rusty?
__________________
2000 WJ 4.0L 42RE 242 TC
180,081 miles & counting
indept is offline   Reply With Quote Quick reply to this message
Unread 11-24-2011, 11:44 AM   #4
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA, Henrietta, NY
Posts: 6,276
They look pretty well intact, I suspected that at first as well seeing as I've lifted the jeep (barely 2"), but the driveshaft has no play and seems to be solid
__________________
98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline   Reply With Quote Quick reply to this message
Unread 02-06-2013, 05:26 PM   #5
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City, Missouri
Posts: 1,492
Quote:
Originally Posted by compcrasher86 View Post
They look pretty well intact, I suspected that at first as well seeing as I've lifted the jeep (barely 2"), but the driveshaft has no play and seems to be solid
Old thread, but did you ever find out what the clicking noise is?
__________________
99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline   Reply With Quote Quick reply to this message
Unread 02-06-2013, 06:21 PM   #6
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA, Henrietta, NY
Posts: 6,276
Quote:
Originally Posted by ZeJokee View Post
Old thread, but did you ever find out what the clicking noise is?
Hey, thanks for the reply I forgot to post up after I fixed it. I took apart the rear brakes completely and put them back together and I think it was the e-brake hardware on the drivers side wasn't on all the way or something was loose. After putting it all back together and readjusting the e-brake my noise was gone, and has been for about 10k miles now. Hope it helps anyone who's still reading this.
__________________
98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline   Reply With Quote Quick reply to this message
Unread 02-06-2013, 06:54 PM   #7
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City, Missouri
Posts: 1,492
Quote:
Originally Posted by compcrasher86 View Post
Hey, thanks for the reply I forgot to post up after I fixed it. I took apart the rear brakes completely and put them back together and I think it was the e-brake hardware on the drivers side wasn't on all the way or something was loose. After putting it all back together and readjusting the e-brake my noise was gone, and has been for about 10k miles now. Hope it helps anyone who's still reading this.
I wasn't expecting a response! Especially one with the outcome.

I am going to start with u-joints since I am getting a clunking between r-n-d and starting to get a squeaking. The clicking is probably from me e-brake. Barely works and I have never serviced it. That's next.
__________________
99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.