WJ - GC 4.7L Ltd - Will only start when cold - Hot engine will take ages to start. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 04-22-2010, 07:54 AM Thread Starter
JMcLane
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: UK
Posts: 17
WJ - GC 4.7L Ltd - Will only start when cold - Hot engine will take ages to start.

Hey guys.

I recently had issues over in this thread.. http://www.jeepforum.com/forum/f13/n...roblem-977062/ .

Initially it was bad at starting and running badly but I have changed quite a few things now and seem to have rectified something..

I have changed in the last 4 weeks...

Battery (optima Red Top, as above post).
Crank Position Sensor.
Coil Pack on the front of engine (front of car) 2 cylinders. (changed on April 20th 2010)
New Spark Plugs.
Serviced.

Now the Jeep runs fantastically on cold startup and when it is running under any hot/cold start conditions. The issue is that it is really hard to start once the engine is running hot.

First thing in the morning since I have changed the 2 coil packs it is about a 2 second start routine and just purr's with no help from feathering the throttle. Perfection.

Where do you think I should be looking to make some progress folks?

Thanks.

JMcLane is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-08-2010, 11:15 AM
WiCkeDuDe
Registered User
2002 WJ 
 
Join Date: Dec 2007
Location: Utah
Posts: 3,181
Sounds like a fuel pump. WJs were very bad and losing fuel pressure due to the orings in the pump. You can confirm this by priming the system by turning the key to run a few times, then cranking. If it fires right up then you found the problem. Mine had the same issue.
WiCkeDuDe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
hard to start when cold liredneck ZJ Grand Cherokee Forum 1 02-12-2009 04:13 AM
cold start problems Mair ZJ Grand Cherokee Forum 2 01-29-2009 09:41 PM
99 4.0 Bad Cold Start windsors03cobra ZJ Grand Cherokee Forum 0 11-08-2008 06:10 PM
annoying noise from engine after cold start Fatsooo ZJ Grand Cherokee Forum 3 09-03-2008 12:59 PM
Hot Start Problem.... Cold Start Injector??? Mase ZJ Grand Cherokee Forum 3 02-03-2003 09:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome