Wj ac problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Wj ac problem

CurrieSavvy Billet LED Tail LightsStainless Steel Door Hinge Pins

Reply
Unread 06-20-2012, 03:18 PM   #1
Pagarcia13
Registered User
2001 WJ 
 
Join Date: Apr 2012
Location: West Covina, Ca
Posts: 13
Wj ac problem

I took my 01 wj 4.7 to the shop to get the ac serviced. They replaced the high pressure hose, gaskets and charged the system. The ac worked great for a cupple of days, but then begin blowing hot air so I took it back. The mechanic looked at it and said he disconnected the computer and it began blowing cold air again but only temporaliy , I also wanted to mention he said the blend doors where bad. I've replace the blend door and it still blows hot air. I haven't started trouble shooting yet because I'm not sure if it a mechanical problem or an electrical problem. Thanks for any advice that can be given

Pagarcia13 is offline   Reply With Quote Quick reply to this message
Unread 06-20-2012, 03:38 PM   #2
Kalali
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2012
Location: Ocean, NJ
Posts: 545
Wrong section. Probably explains the absence of any input.
Kalali is offline   Reply With Quote Quick reply to this message
Unread 06-22-2012, 03:03 PM   #3
jclaudii
Registered User
1999 WJ 
 
Join Date: Oct 2004
Location: Russellville, ar
Posts: 1,200
check on wjjeeps.com about the blend door issue and how to test it and diagnose it. Also, have him point to the place he "disconnected" the computer as I'm thinking this is not really what he did. Please come back and we'll help guide you so you don't get ripped off. Also, ask what was wrong with the high pressure line and how long it held a vacuum before they refilled it. I believe the minimum to leave it on a vacuum is like 30 min and check. longer is better.
jclaudii is offline   Reply With Quote Quick reply to this message
Unread 06-22-2012, 05:30 PM   #4
imaguy3
Registered User
2004 WJ 
 
Join Date: Jun 2009
Location: Az
Posts: 1,466
I'm wondering if it has a leak from the work they did. Maybe if it was low on freon, he jumped the low pressure cutoff switch to make the compressor work, which is when it got cold temporarily...
imaguy3 is offline   Reply With Quote Quick reply to this message
Unread 06-22-2012, 06:32 PM   #5
HVACNY
Registered User
2000 WJ 
 
Join Date: Feb 2011
Location: East Meadow, NY
Posts: 1,069
I doubt anybody would jump the LPS and send you on your way.It would mean certain death for your compressor.Could be alot of things,but just guessing till you throw some guages on it to see whats going on.
HVACNY is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.