Wj ac problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Wj ac problem

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Rough Country Lift Kits and Parts!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-20-2012, 02:18 PM   #1
Pagarcia13
Registered User
2001 WJ 
 
Join Date: Apr 2012
Location: West Covina, Ca
Posts: 13
Wj ac problem

I took my 01 wj 4.7 to the shop to get the ac serviced. They replaced the high pressure hose, gaskets and charged the system. The ac worked great for a cupple of days, but then begin blowing hot air so I took it back. The mechanic looked at it and said he disconnected the computer and it began blowing cold air again but only temporaliy , I also wanted to mention he said the blend doors where bad. I've replace the blend door and it still blows hot air. I haven't started trouble shooting yet because I'm not sure if it a mechanical problem or an electrical problem. Thanks for any advice that can be given

Pagarcia13 is offline   Reply With Quote
Unread 06-20-2012, 02:38 PM   #2
Kalali
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2012
Location: Ocean, NJ
Posts: 494
Wrong section. Probably explains the absence of any input.
Kalali is offline   Reply With Quote
Unread 06-22-2012, 02:03 PM   #3
jclaudii
Registered User
1999 WJ 
 
Join Date: Oct 2004
Location: Russellville, ar
Posts: 1,200
check on wjjeeps.com about the blend door issue and how to test it and diagnose it. Also, have him point to the place he "disconnected" the computer as I'm thinking this is not really what he did. Please come back and we'll help guide you so you don't get ripped off. Also, ask what was wrong with the high pressure line and how long it held a vacuum before they refilled it. I believe the minimum to leave it on a vacuum is like 30 min and check. longer is better.
jclaudii is offline   Reply With Quote
Unread 06-22-2012, 04:30 PM   #4
imaguy3
Registered User
2004 WJ 
 
Join Date: Jun 2009
Location: Az
Posts: 1,421
I'm wondering if it has a leak from the work they did. Maybe if it was low on freon, he jumped the low pressure cutoff switch to make the compressor work, which is when it got cold temporarily...
imaguy3 is offline   Reply With Quote
Unread 06-22-2012, 05:32 PM   #5
HVACNY
Registered User
2000 WJ 
 
Join Date: Feb 2011
Location: East Meadow, NY
Posts: 1,069
I doubt anybody would jump the LPS and send you on your way.It would mean certain death for your compressor.Could be alot of things,but just guessing till you throw some guages on it to see whats going on.
HVACNY is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.