WJ 4.7L 2001 O2 sensor problems [P0031 / P0135 / P0155 / P0132] - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > WJ 4.7L 2001 O2 sensor problems [P0031 / P0135 / P0155 / P0132]

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueRIGID LED Light Blowout Sale - All Sizes, All Series, all End of Summer Sale, 20% OFF!

Reply
Unread 12-09-2013, 03:48 AM   #1
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
Wj WJ 4.7L 2001 O2 sensor problems [P0031 / P0135 / P0155 / P0132]

Jeep info
2001 Jeep grand cherokee limited
4.7L V8 engine
California emissions (4 O2 sensors)
transmission: 45RFE

Well lets start from the begging. my Jeep was running completely fine until one day I got the dreaded P0700 code.

I replaced both speed sensors, replaced both transmission filters, replaced the solenoid pack, put new transmission fluid in and replaced the TCM - this cleared out the P0700 code.

video of that process here..


now after doing all of this the Jeep would run fine and shift fine but it started idling really rough and shaking while stopped, and sometimes it would stall out or, what it seemed like building bubbles of gas and igniting all at once so the car would just take off or building up too much gas and choking the engine out.

I decided I would clean the Idle control valve and the throttle body. right after cleaning these out and starting the jeep I got a P0031 code (Oxygen (A/F) Sensor Heater Control Circuit Low (Bank 1 Sensor 1)
I figured this was just because there was a bit of the throttle body cleaner that went into the air intake. so I disconnected the battery terminal and cleared the code. the code never came back. This helped the idling issue a little but the problem was still happening.

video of that process here:

later on as the car was idling I ended up getting P0135 and P0155. both referring to the 2 upstream O2 sensors before the mini cats.

http://www.obd-codes.com/p0135
http://www.obd-codes.com/p0155

I figured there was no way both sensors would just go out. so I cleared out the codes and the only one that came back was P0135

I ended up buying a replacement sensor here..
http://www.jeep4x4center.com/oxygen-...6029333aa.html

which is the one that matches the part on this site
http://www.wjjeeps.com/oxygen.htm
part (56029333AA)

right after replacing the sensor I ended up getting a P0132 code (which would be normal since the car is running very rich)
O2 Oxygen Sensor Circuit High Voltage (Bank1, Sensor1)
http://www.obd-codes.com/p0132

video of the o2 sensor replacement

**the video shows the P0155 and P0700 codes but they were cleared and haven't come back for a few days now**

the Jeep still idles rough and shakes, and will randomly stall out while I'm at red lights. but it will fire right up when I put it and park and re-start it.

I'm getting horrible gas mileage 10 - 11 MPG.. and I can definitely smell gas outside the car when it's sitting in park idling and warming up.

the car will typically die and shake, or choke out more if the front end is lower than the back (example: pulling out of a super market, or downhill stop light) I had it idling for almost 20 min while the front end was uphill last night and it never shook or died.

I'm completely lost at the moment, I'm thinking maybe replacing


1. all the spark plugs as some may be misfiring and choking out the engine
2. replacing the crankshaft position sensor for the engine dying issue..
3. possible fuel filter issue?
4. trying out a MOPAR O2 sensor
5. replacing the Throttle Position Sensor and / or Idle control valve
6. Replacing the ECM/PCM

but I'm really worried about the MPG and killing the mini cats because of the car running so rich

any input or guidance is appreciated

link375 is offline   Reply With Quote
Unread 12-10-2013, 06:35 PM   #2
berndog67
Registered User
2003 WJ 
 
Join Date: Nov 2011
Location: fort edward, ny
Posts: 484
i would def replace the tps, i would bet it caused all of your problems from the start, because the computer uses the tps reading for near everything, from adjusting shift points/firmness to fuel trims, only get a MOPAR brand one though!
__________________
2003 WJ Overland, 4.7HO, D30 & D44A (1 tons going in now!), RC Long Arm, lifted 4" Front 6" Rear, RC 2.2 4" Shocks, JKS track bar, custom hi-steer, 35" Procomp M/T's on JK rims, beefed up Overland rock rails, custom skids and dif gaurds, Rugged Ridge 8500 synthetic winch in custom hidden mount
berndog67 is offline   Reply With Quote
Unread 12-10-2013, 08:43 PM   #3
veiri86
Member
 
veiri86's Avatar
2003 WJ 
 
Join Date: Jan 2013
Location: Tulkarem, Tulkarem, Palestine
Posts: 495
If I were I would start with the tps then check your spark plugs conditions and the coils, it happens that a bad combustion in the first cylinder or second cylinder due bad spark plug cause an O2 sensor code (the upstream ones)
__________________
R.I.P ratmonkey
Build thread: http://www.jeepforum.com/forum/f197/...x-wjs-1872002/

01' 4.7 Limited WJ 5" lifted, Rubicon Express 4.5" coil springs with IRO critical path setup and Bilstien 5100 shocks all around, JKS adjustable Trackbar (KOR bushings), JKS HD tie rod (MOOG problem solver Ends), JKS HD drag link (Moog Probel solver Ends), 4.56 Yukon ring and pinion, Moog HD SSD107 Steering Stabilizer, IRO Front drive shaft conversion, Stillen slotted rotors all around with Stillen brake pads, IRO adjustable A-Arm, 3" all the way Kolak Exhaust with High flow Magnaflow Cat. Converter and Flowmaster Super 50 Muffler, 285/70R17 AT Kumho (33") on 17" BlackWheel rims 909B, K&N Cold air intake, Four nozzles Bosch injectors, and Flashpaq 3780.

03' 4.7 H.O WJ 3" lifted, OME HD with 0.5" Coil spacers and Bilstien 5100 shocks all around, JKS adjustable Trackbar (KOR bushings), Moog Problem solver TRE's, IRO Front drive shaft conversion, IRO adjustable A-Arm, High flow magnaflow mini cats, high flow magnaflow cat, Flowmaster Super 44 muffler, 265/65R17 AT Yokohama on 17" Rays rims, and Flashpaq 3780
veiri86 is offline   Reply With Quote
Unread 12-11-2013, 01:15 AM   #4
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
ordering this now

http://www.fuelpumpsusa.com/index.ph...roducts_id=259

I will update once I get it installed
link375 is offline   Reply With Quote
Unread 12-11-2013, 09:22 AM   #5
berndog67
Registered User
2003 WJ 
 
Join Date: Nov 2011
Location: fort edward, ny
Posts: 484
Quote:
Originally Posted by link375 View Post
ordering this now

http://www.fuelpumpsusa.com/index.ph...roducts_id=259

I will update once I get it installed
dam thats the same price i get off the ebay store i usually buy them from, nice find, just make sure it is in deed the mopar brand one and not the wells one, i've had mixed results with the wells one, sucks our wj are so picky!
__________________
2003 WJ Overland, 4.7HO, D30 & D44A (1 tons going in now!), RC Long Arm, lifted 4" Front 6" Rear, RC 2.2 4" Shocks, JKS track bar, custom hi-steer, 35" Procomp M/T's on JK rims, beefed up Overland rock rails, custom skids and dif gaurds, Rugged Ridge 8500 synthetic winch in custom hidden mount
berndog67 is offline   Reply With Quote
Unread 12-11-2013, 03:13 PM   #6
FULLJEEP
Registered User
2004 WJ 
 
Join Date: Jun 2008
Location: LIMA
Posts: 146
Quote:
Originally Posted by link375 View Post
ordering this now

http://www.fuelpumpsusa.com/index.ph...roducts_id=259

I will update once I get it installed

DAMM, I canīt open the page, they say they donīt sell outside USA, OK, but Canīt someone just see the page? !!!!
FULLJEEP is offline   Reply With Quote
Unread 12-11-2013, 08:35 PM   #7
veiri86
Member
 
veiri86's Avatar
2003 WJ 
 
Join Date: Jan 2013
Location: Tulkarem, Tulkarem, Palestine
Posts: 495
Quote:
Originally Posted by FULLJEEP View Post

DAMM, I canīt open the page, they say they donīt sell outside USA, OK, but Canīt someone just see the page? !!!!
here it is attached below (am not in USA but I stopped the browser before they recognize that am not from the US looool)

The TPS on this website costs 30 USD (Mopar) IMO excellent deal if it was really Mopar



forumrunner_20131212_073709.png
__________________
R.I.P ratmonkey
Build thread: http://www.jeepforum.com/forum/f197/...x-wjs-1872002/

01' 4.7 Limited WJ 5" lifted, Rubicon Express 4.5" coil springs with IRO critical path setup and Bilstien 5100 shocks all around, JKS adjustable Trackbar (KOR bushings), JKS HD tie rod (MOOG problem solver Ends), JKS HD drag link (Moog Probel solver Ends), 4.56 Yukon ring and pinion, Moog HD SSD107 Steering Stabilizer, IRO Front drive shaft conversion, Stillen slotted rotors all around with Stillen brake pads, IRO adjustable A-Arm, 3" all the way Kolak Exhaust with High flow Magnaflow Cat. Converter and Flowmaster Super 50 Muffler, 285/70R17 AT Kumho (33") on 17" BlackWheel rims 909B, K&N Cold air intake, Four nozzles Bosch injectors, and Flashpaq 3780.

03' 4.7 H.O WJ 3" lifted, OME HD with 0.5" Coil spacers and Bilstien 5100 shocks all around, JKS adjustable Trackbar (KOR bushings), Moog Problem solver TRE's, IRO Front drive shaft conversion, IRO adjustable A-Arm, High flow magnaflow mini cats, high flow magnaflow cat, Flowmaster Super 44 muffler, 265/65R17 AT Yokohama on 17" Rays rims, and Flashpaq 3780
veiri86 is offline   Reply With Quote
Unread 12-12-2013, 05:36 AM   #8
HighOutput
Registered User
2003 WJ 
 
Join Date: Jun 2012
Location: Red Centre, NT
Posts: 93
I got the same sensor removal tool, but if only mine would loosen the hell up!
HighOutput is offline   Reply With Quote
Unread 12-13-2013, 01:00 AM   #9
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
just another update to the thread

here is a picture of the stats while idling (very cold outside)


after warming up for a few minutes


driving


idling after it's been warmed up a bit


I cleared out the P0132

freeze frame stats, right after I got the P0132 again
link375 is offline   Reply With Quote
Unread 12-13-2013, 09:43 AM   #10
TwinchargedRX7
Registered User
2002 WJ 
 
Join Date: Sep 2012
Location: Lyndhurst, NJ
Posts: 76
what program allows you to see all that? Is it on your phone?
TwinchargedRX7 is offline   Reply With Quote
Unread 12-13-2013, 11:46 AM   #11
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
Quote:
Originally Posted by TwinchargedRX7 View Post
what program allows you to see all that? Is it on your phone?
yes, using an android phone and the Torque application

this is the reader I'm using
http://goo.gl/5zbtuc

and this is the app
http://goo.gl/6rQSb
link375 is offline   Reply With Quote
Unread 12-16-2013, 11:32 PM   #12
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
another update to the thread

I changed all the spark plugs with NGK spark plugs today, that last one on the passenger side was a real pain to get out!

I moved some of the coils to different places and it doesn't seem to be idling as bad anymore, but it's still not very good, the O2 codes haven't come back yet.. so I"m suspecting one or a couple of the coils are bad.

some of the coils didn't look very good, but I didn't have enough $$ on me at the time to replace those as well, plus everything is cheaper online. I will be purchasing 8 new coils and replacing them when I get them.

UNLESS anyone here knows of a way to test out the coils before I spend $20-$30 a piece on new coils
link375 is offline   Reply With Quote
Unread 12-18-2013, 01:29 AM   #13
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
well now the codes came back with a new surprise. since I just replaced the spark plugs I know for a fact they are good.

however as expected I'm pretty sure my coils need to be replaced, this explains the stuttering and unburned fuel smell from the exhaust.
time to replace all the coils

link375 is offline   Reply With Quote
Unread 12-25-2013, 01:03 PM   #14
link375
Registered User
2001 WJ 
 
Join Date: Nov 2013
Location: Provo, UT
Posts: 95
well the Rough idle is fixed, but the O2 code P0132 is still there

replaced spark plugs, 4 coils and TPS

link375 is offline   Reply With Quote
Unread 12-25-2013, 04:07 PM   #15
Turbozcs2003
Registered User
2002 WJ 
 
Join Date: Feb 2010
Location: NE
Posts: 279
how many miles on this?
Turbozcs2003 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.