WJ 4.7 rough idle and lack of power - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 09-21-2017, 07:54 PM Thread Starter
HarryCo4
Registered User
2000 WJ 
 
Join Date: Feb 2017
Posts: 6
WJ 4.7 rough idle and lack of power

I have a 2000 grand cherokee 4.7. I recently put new HO heads, cams, and a lot of other new parts. The problem i'm having now is that it won't idle right, it will shake the car (you can feel it in your seat) and it its not a steady idle sound coming from the exhaust. I also think its lacking some top end power but i'm not sure. I've tried just about everything I can think of and nothing will fix it.

Here is a list of the things i've tried.
-New plugs, I've tried oem and ngk plugs
-New IAC valve
-Looked for vacuum leaks
-New O2 sensors (I have an AFR gauge and the ratio seems fine at idle)
-New coil packs
-PCM reflash
-New crank sensor
-Compression is good averaged 155 and none of the cylinders were way off
-Cleaned fuel injectors and also tried a different set
-I don't think the catalytic converter is causing this but i'm not sure. I've tried removing an O2 sensor before the cat and it didn't seem to run any better or have too much pressure (I think). The inlet cat temp was around 500F and the exit was in the 600s.

Engine mods.
-K&N cold air intake
-flowmaster muffler
-HO heads, cams, and intake manifold
-68mm throttle body from a 2002

HarryCo4 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-23-2017, 12:23 AM Thread Starter
HarryCo4
Registered User
2000 WJ 
 
Join Date: Feb 2017
Posts: 6
I thought of a few things I forgot to mention. I have no codes and the fuel pressure is 60 PSI at idle. Also the interior lights flicker slightly at idle or if i rev it, they never did that before the engine rebuild. Could this be related to the idle issue? Any help on this would be greatly appreciated!
HarryCo4 is offline  
post #3 of 4 Old 09-23-2017, 01:59 AM
JMZ101586
Registered User
2004 WJ 
 
Join Date: May 2014
Location: Pgh
Posts: 682
Sounds like timing is off by one tooth

Stable:
04 WJ Special Edition 4.7
98 Camaro SLP SS with LS2 swap
05 STS4 4.6 Northstar AWD
JMZ101586 is offline  
 
post #4 of 4 Old 09-23-2017, 03:15 AM Thread Starter
HarryCo4
Registered User
2000 WJ 
 
Join Date: Feb 2017
Posts: 6
Is there any easy way to check this?
HarryCo4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome