post #16 of Old 12-17-2013, 02:31 PM Thread Starter
highoutput85
Registered User
 
Join Date: Dec 2013
Location: Highland
Posts: 8
F


Last edited by highoutput85; 12-17-2013 at 02:52 PM.
highoutput85 is offline  
post #17 of Old 12-17-2013, 02:50 PM Thread Starter
highoutput85
Registered User
 
Join Date: Dec 2013
Location: Highland
Posts: 8
Checked the fuel pressure and its good , I pulled the injectors and were a bit dirty, how do I check for exhaust problems?
highoutput85 is offline  
post #18 of Old 12-19-2013, 02:49 AM
ADragg
Registered User
2003 WJ 
 
Join Date: Apr 2013
Location: Las Vegas
Posts: 301
Quote:
Originally Posted by cde02ltd View Post
I thought the high output 4.7 took platinum plugs?
Whoops, didn't notice it was HO. I think Platinum is correct, but you're right it's not the ordinary Champion Coppers.

3.5" lifted '03 Limited Quadra Drive WJ - OME HD coils, Bilstein 5100 shocks, JKS track bar, IRO extended links, OME 10mm spacers, Moog SS, JK Moab wheels w/ 265/70/17 (32") Goodyear Duratracs.
ADragg is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome