wiring guru's, need your help - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > wiring guru's, need your help

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-23-2013, 02:31 PM   #31
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
Quote:
Originally Posted by michiganmaveric View Post
It looks like the major drop is with #8 taken out. Fuse #8 goes to the ignition sw. for the the accessories and starter functions. It supplies power to fuse #28 and #29 in the junction block, and CB #1. Pull them one at a time and see what happens. Possibly fuse s #22, 12, 21 and 32 also. Have to go for now will get back after dinner.
So install fuse #8 and pull 12, 21, 22, 28, 29 and 32 from the main fuse block one at a time and see if anything changes. When you say CB #1 you mean the one with the arrow in the pic? Also, the internals of the ignition are bad as I can pull the key out in any position. what affect would this have on my issue? I don't know how long it's been like this as it's my wife's car.

jblock_main.jpg  
curt93t/t is offline   Reply With Quote
Unread 05-23-2013, 02:56 PM   #32
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,709
With the internals of the Ignition Sw being bad I would start by changing that first, as fuse #8 in the PDC supplies power to the ign. sw.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 05-23-2013, 02:57 PM   #33
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,386
Quote:
Originally Posted by curt93t/t

So install fuse #8 and pull 12, 21, 22, 28, 29 and 32 from the main fuse block one at a time and see if anything changes. When you say CB #1 you mean the one with the arrow in the pic? Also, the internals of the ignition are bad as I can pull the key out in any position. what affect would this have on my issue? I don't know how long it's been like this as it's my wife's car.
Might be a short in your ignition switch, That makes the draw, just saying,,,

Disconect the ignition switch from harness, then recheck draw, if Good, thats your pulprit.
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 05-23-2013, 05:00 PM   #34
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
Okay, I'm stumped. I disconnected the connector's for the ignition and it was still reading high. Tried 12, 21, 28, 29, 32 and CB#1. All showed less than 2A. Hooked the ignition connectors to see if it would go back up and it didn't, it was around 2A. So either the thing is intermittent or this thing is cursed.
Funny thing is that with the leads hooked up there's a constant clicking sound from the fuse box. That is unless I unhook #8 fuse or #5 (radio AMP) and it stops, well with #5 (and #8 out) in it will click 3 or 4 times. Like I mentioned earlier, I have the dimmer switch turned off (and even disconnected the connector this time) and all the lights come on. I haven't seen the dome lights work in forever, but they are coming on now too.
curt93t/t is offline   Reply With Quote
Unread 05-23-2013, 05:27 PM   #35
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
If I disconnect the dimmer/turn signal switch the door and hatch lights come on about 10 seconds after I disconnect it. If I hook it back up with the dimmer turned off the lights turn off. The only way to get the dome light to come on is jumper the ground post and cable.
curt93t/t is offline   Reply With Quote
Unread 05-23-2013, 06:23 PM   #36
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,386
2A Are anyway to much, you will be looking for a 0.03-0.04A to be good,,,,,
About That ticking, above the fuses there Are several relays, start pulling one by one until you find the one making the sound,
Take it out,
Recheck draw,
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 05-23-2013, 06:38 PM   #37
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,709
Quote:
Originally Posted by curt93t/t View Post
Okay, I'm stumped. I disconnected the connector's for the ignition and it was still reading high. Tried 12, 21, 28, 29, 32 and CB#1. All showed less than 2A..
Did you try the fuses one at a time or all at once, and what do you mean by "all showed less then 2A"
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 05-23-2013, 06:51 PM   #38
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,709
Fuse #8 in the junction block is for all the interior lights and the Vic. Pull it then see what happens. Again, what year is this WJ, because what I am telling you is from an '04 manual. Should be the same but could be different for earlier years.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 05-23-2013, 07:01 PM   #39
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
Quote:
Originally Posted by michiganmaveric View Post
Did you try the fuses one at a time or all at once, and what do you mean by "all showed less then 2A"
I did one at a time and where it was reading 6.08 earlier today it is now around 2 amps draw. A lot lower, but from what Thomahawk is saying it's still too high. It's a 2000 WJ.

Quote:
Originally Posted by Thomahawk View Post
2A Are anyway to much, you will be looking for a 0.03-0.04A to be good,,,,,About That ticking, above the fuses there Are several relays, start pulling one by one until you find the one making the sound,Take it out,Recheck draw,

When I did the check and it clicks I noticed the headlights slowly come on! Didn't notice it earlier I guess cuz it was still daylight out. I took the low beam relay out and it no longer clicks and the reading goes down to about
.03A. Unfortunately I switched it with the fog lamp relay since they are the same and it's doing the same thing (clicks and drawing over 2A).
curt93t/t is offline   Reply With Quote
Unread 05-23-2013, 07:07 PM   #40
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,709
According to my book the low beam relay feeds fuses 14 and 15 in the junction block. Pull them one at a time and see if the clicking stops. 14 is for the left low beam and 15 is for the right. If it clicks with both the fuses out you might have a bad body control module as that is what controls the relay.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 05-23-2013, 07:17 PM   #41
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,386
^^^Back to post 4,,,,
Quote:
Originally Posted by Thomahawk
No, You should expect to se a 30-60mA total draw, thats normal,
alarm, clock, radio, etc,,,,
Most of this is controled by the BCM, check on fuse for BCM (body Control modul), and maybe more, ex interior light,,,,
Now send me a million dollar thx
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 05-23-2013, 07:25 PM   #42
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,386
You might have to recheck your battery voltage, and make sure its above 12.5V.
WJ's electronic tends to act up when voltage drops to low. With That drain voltage will drop over time.
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 05-23-2013, 08:32 PM   #43
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
It was at 13 volts. Took it for a spin and the blower turned on with the knob in the off position. going to sleep on it tonight. I'll take a look at the BCM and fuse 14/15 tomorrow.
curt93t/t is offline   Reply With Quote
Unread 05-24-2013, 07:14 AM   #44
WJChris
Web Wheeler
 
WJChris's Avatar
1999 WJ 
 
Join Date: Nov 2007
Location: Santa Rosa, California
Posts: 2,548
I wonder if this is a flood Jeep...
WJChris is offline   Reply With Quote
Unread 05-24-2013, 07:44 AM   #45
curt93t/t
Registered User
 
Join Date: Mar 2006
Posts: 104
Nope, bought it brand new in 2000, but thinking of driving it into a river! After charging the battery last night to make sure it had a good charge I checked it again. Now the headlights don't try and come one and it only clicks for a few seconds and stops. Now the CD disc changer mechanism moves a couple of times. When it stops the draw goes down to around .08 amp. Going to call a couple of junk yards and see how much the BCM is going for. I doubt they will allow me to bring it back if it doesn't fix the problem as I plan on swapping it out in their parking lot.

I'm pretty sure the BCM (if that's what is clicking) isn't supposed to click when I do this check. I see the BCM monitors the lift gate. The overhead constantly says the lift gate is open. I pulled everything out and there is a burnt smell, more prevalent with the right side lock switch.
curt93t/t is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.