What is worn, and what is not? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 10-05-2013, 05:41 PM Thread Starter
ronj35
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Concord
Posts: 121
Wj What is worn, and what is not?

Hey all, I have some clarification questions about my front end. Could someone please review the videos and tell me if my tie rod end and or my steering stabilizer are worn out? The first video is my tie rod end coming from the drag link and connecting to the wheel hub that will rock back and forth when the wheel is turned, even when the car is off (itís the source of the clunking noise heard in the video). My question is if the movement is normal or if the TRE is worn out and I need to replace it. The second clip is of my stock steering stabilizer as I touch the plastic housing, is it supposed to be loose like it is and be able to spin/move? I know most guys on here upgraded their steering stabilizers long ago but I'm still on my stock setup so I'm wondering what the deal is. Thanks in advance!

TRE:
SS:


ronj35 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-05-2013, 08:42 PM
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,788
Garage
That tie rod end is shot. Furthermore, it looks like the nut on the tie rod is not even tight! You were just spinning the dust cover on the SS. The way to test the SS is to pull it off and see how easily it gives to you pushing and pulling it back and forth.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #3 of 6 Old 10-05-2013, 08:59 PM Thread Starter
ronj35
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Concord
Posts: 121
Thanks snobrdrkid07, but how do you know the TRE is definitely ruined? I have the nut tightened down just far enough to get the cotter pin through the holes in the castle nut, should i go farther? The reason I question your diagnosis is because i replaced that TRE about 1000 miles ago and i dont want to think about replacing it this soon.
ronj35 is offline  
 
post #4 of 6 Old 10-05-2013, 09:10 PM
snobrdrkid07
Web Wheeler
 
snobrdrkid07's Avatar
2004 WJ 
 
Join Date: Jul 2010
Location: Chesapeake/Blacksburg
Posts: 8,788
Garage
Short answer is that there should be NO movement between the tie rod end and the knuckle.

~ 04 WJ Overland 4.7 HO | Graphite Metallic | Quadra-Drive | Vari-Locks | Bilstein 4600ís | ADDCO Sway Bar | Powerstick Exhaust | RB1 | SuperChips Tuned | Much More to Come ~

~ 04 WJ Laredo 4.0 | Selec-Trac | MBP | OME HD 3" Lift | JKS TB | IRO Front LCA's and UCA's| Bilstein 5100's | Silent Armor 245/70/17's | Custom Front D.S. | Stillen Rotors/Pads | Tow Package w/ 3.73's | Moog HD Steering | Kenwood eXcelon HU | Alpine Speakers, Amps, and Subs | Bilstein SS | Auxiliary Transmission Cooler | Rock Lights | Light Bars | Lots of Cool Stuff ~

~ 05 Rubicon Unlimited 4.0 | 6-Speed | Dana 44's | Air Lockers | 4.11 Gears | Rock-Trac 241OR T-Case with 4:1 4-Low | OME HD Springs | Bilstein 5100ís | 245/75/16 Kevlar MT/R's on Moabs | Hansen Offroad Steel F/R Bumpers | Warn 9000xi Winch | Edge Performance Chip | Custom CAI | Hella Off-road Lights | Cobra 29 CB | Flash Lights | Recovery Gear | Fire Extinguisher ~

~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
~



-Michael-
snobrdrkid07 is offline  
post #5 of 6 Old 10-05-2013, 11:23 PM
SirSilvia
Registered User
2002 WJ 
 
Join Date: Sep 2013
Location: Pittsburgh
Posts: 216
^^yeah, that's hella loose. would be surprised if you don't feel that when driving

2002 Jeep Grand Cherokee Limited V8
SirSilvia is offline  
post #6 of 6 Old 10-06-2013, 10:11 PM
2ndhandWJman
Registered User
2004 WJ 
 
Join Date: May 2013
Location: Baltimore
Posts: 473
The entire stub is moving, if it was properly seated it shouldn't move at all. I'd take it out and see if the tapered hole is destroyed.
2ndhandWJman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome