post #1 of Old 08-24-2013, 03:03 PM Thread Starter
hookandladder
Registered User
 
Join Date: Aug 2013
Location: Waynesboro
Posts: 1
What in the world??? 04 4.7 WJ probs...

Hi everyone, new Jeeper here. Just bought an 04 WJ Limited 4.7 with 87k on it back in May. Replaced the battery last month as it was hesitant to start once it got warm, and a cell finally gave out. Last week, heavy white smoke and the dreaded antifreeze smell upon starting (it made a clanging sound when it turned over as well), which went away in about 5 minutes. It happened the day after as well and lasted about the same period of time. Checked the dipstick, no water in the oil, and after cooling it down took off the radiator cap and started, with no gases bubbling out. It has a faint antifreeze smell occasionally, but it's only smoked those two times. The check engine light came on the other day reading cylinder 3 misfire. Is this a head gasket problem?

hookandladder is offline  
post #2 of Old 08-24-2013, 06:17 PM
coopdc78
Registered User
2004 WJ 
 
Join Date: Sep 2008
Location: Buffalo
Posts: 820
Sound a little more than head gasket. Did u overheat it at all? I don't think a head gasket will make a clanking noise. Do u have a video of this noise? Maybe pull the plug and check it out

2004 overland 4 inch rc long arm/ 3/4 inch spacers, 242 swap with SYE, Tom woods front and rear
coopdc78 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome