What did you do to your WJ today? - Page 744 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 06-05-2012, 02:52 PM   #11146
liquidxit2
Registered User
2002 WJ 
 
Join Date: Sep 2008
Location: Dixie, Maryland
Posts: 1,082
Front and rear service with new covers.

forumrunner_20120605_165202.jpg



forumrunner_20120605_165211.jpg

__________________
2002 Jeep Grand Cherokee Limited 4.7 low output quadradrive. 31in General Grabber AT2, OME HD, bilstein 5100, IRO sway links, addco rear sway. Kolak 3in exhaust with flowmaster SUV 50, magnaflow 3in cat, Custom K and N FIPK, modded airbox with ram air, Fastman 71mm Throttle body, PML RFE Deep pan, Autometer digital trans temp gauge, P.I.E. aux adapter, Infinity reference 3.5/6x9/6.5, 200w inverter, surco rack, front/rear/cargo husky liners.
WJ Build!
liquidxit2 is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 06:06 PM   #11147
Cnolenwj
Web Wheeler
 
Cnolenwj's Avatar
2000 WJ 
 
Join Date: Apr 2011
Location: Texoma, tx
Posts: 1,089
Finally got that sob fan/clutch off (boy was that a pain) put a new clutch on and still have the same problem.
Jeep runs at the right temp at slow speeds, even on a 3hr trail run I did the other weekend in 90 degree heat.
Get on the road running 50mph temp will go about 1/8 past 210 and at 70mph will go just over 1/4 past.
Have never seen this problem. The clutch had play so figured simple fix, of course not.
May try water pump next.
__________________
2000 wj limited, 4" IRO, long armed front.

Build thread- http://www.jeepforum.com/forum/f197/...build-1195835/

North Texas Grands- http://www.jeepforum.com/forum/f348/...rands-1323367/

Grand Slam Texas- http://www.jeepforum.com/forum/f197/...texas-1419143/

Grand Slam Texas Group- http://m.facebook.com/?_rdr#!/groups...00000454207551
Cnolenwj is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 06:37 PM   #11148
Scurv14
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: Myrtle Beach, SC
Posts: 77
Wj

Quote:
Originally Posted by Cnolenwj View Post
Finally got that sob fan/clutch off (boy was that a pain) put a new clutch on and still have the same problem.
Jeep runs at the right temp at slow speeds, even on a 3hr trail run I did the other weekend in 90 degree heat.
Get on the road running 50mph temp will go about 1/8 past 210 and at 70mph will go just over 1/4 past.
Have never seen this problem. The clutch had play so figured simple fix, of course not.
May try water pump next.
check radiator hoses and all. make sure you dont have coolant leaking. busted upper hose on mine after i got it. check before it way over heats.made that mistake already.
Scurv14 is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 07:29 PM   #11149
C5_WJ
Registered User
 
Join Date: Dec 2011
Location: Rockville, MD
Posts: 14
Took the WJ out on the beach in Corolla, NC. went through some pretty deep stuff as well, good times...
__________________
02' WJ Special Edition; stock on BFG AT's (Workhorse)
C5 Corvette; full bolt ons (track car)
1966 Mustang Coupe (project vehicle)
BMW E36 3 series (beater)
C5_WJ is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 08:28 PM   #11150
MWyatt
Registered User
1999 WJ 
 
Join Date: Nov 2010
Location: Folsom, CA
Posts: 454
Cut my fenders a little...
Time for 33s!



Also noticed my e-fan isn't turning on. Did the full blast AC check and no fan. Time to replace the relay
__________________
'99 4.0 - IRO 3" Lift, 31s, JCR Stage 3 Sliders, KOR 3/4" Spacers, Thrush Welded Muffler, Cut Fenders
http://www.jeepforum.com/forum/f197/mwyatts-wj-build-1180994/
"If you can't fix it with a hammer, then you have an electrical problem."
MWyatt is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 08:43 PM   #11151
SBWJ
Registered User
2000 WJ 
 
Join Date: Sep 2011
Location: Islip, NY
Posts: 11
So just like many others im sure i had an overheating issue for a while and if the wj sat still in one place for too long it would slowly heat up becuase the electric fan wouldnt work, i finally went and bought a new electric fan and relay and it started to work.... once in a while. I was completly lost after tons of research on this! so im just staring at the set up and i notice that the plug that goes from the jeep directly into the fan (the plastic connector) was messed up on the inside! so i get a new connector, rewire it and bam! a stupid little $20 peice of plastic is all it took, i suggest anyone with an overheating problem CHECKS THIS. a simple fix. so happy now
SBWJ is offline   Reply With Quote Quick reply to this message
Unread 06-05-2012, 09:31 PM   #11152
FULLJEEP
Registered User
2004 WJ 
 
Join Date: Jun 2008
Location: LIMA
Posts: 147
Just bought front a rear control arms from JKS, just receive them, goijng to install tomorrow.
Any special sugestion, thinking of just using standad length, for now.

Need some advice cause, jks are expandable.
FULLJEEP is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 08:01 AM   #11153
Bretthn
Registered User
2001 WJ 
 
Join Date: Mar 2012
Location: Greensboro, NC
Posts: 84
Quote:
Originally Posted by liquidxit2 View Post
Front and rear service with new covers.

Attachment 409785



Attachment 409786
What covers are these? I am looking for stockish options with solid fill plugs.
Bretthn is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 09:45 AM   #11154
liquidxit2
Registered User
2002 WJ 
 
Join Date: Sep 2008
Location: Dixie, Maryland
Posts: 1,082
Quote:
Originally Posted by Bretthn View Post
What covers are these? I am looking for stockish options with solid fill plugs.
Stock d30 and an SRT8 d44a both painted hemi orange. I used high temp rattle cans from advanced auto.
__________________
2002 Jeep Grand Cherokee Limited 4.7 low output quadradrive. 31in General Grabber AT2, OME HD, bilstein 5100, IRO sway links, addco rear sway. Kolak 3in exhaust with flowmaster SUV 50, magnaflow 3in cat, Custom K and N FIPK, modded airbox with ram air, Fastman 71mm Throttle body, PML RFE Deep pan, Autometer digital trans temp gauge, P.I.E. aux adapter, Infinity reference 3.5/6x9/6.5, 200w inverter, surco rack, front/rear/cargo husky liners.
WJ Build!
liquidxit2 is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 09:50 AM   #11155
USMCBehrensDVLD
Registered User
2004 WJ 
 
Join Date: Aug 2011
Location: Smithtown, New York
Posts: 605
Got a few things done this weekend. Painted my front grill and finally got my JCR stage II rock sliders, painted and installed, still iffy on them though.
img_0393.jpg   img_0398.jpg   img_0399.jpg   img_0400.jpg  
__________________
2004 Jeep WJ Freedom Edition
4.5inch TerraFlex Lift, 2014 Rubicon Wheels, 35inch BFG AT, 1 inch spacers
Build Thread-http://www.jeepforum.com/forum/f197/2004-wj-freedom-edition-into-devildog-edition-1279757/
USMCBehrensDVLD is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 10:05 AM   #11156
mrJ
Registered User
2002 KJ Liberty 
 
Join Date: Sep 2010
Posts: 3,874
ive had my stage 2's for a while. they're solid. i've dropped onto rocks/concrete quite a few times
__________________
Build In Progress...[url]http://www.jeepforum.com/forum/f22/03-wj-limited-build-she-needs-name-1113549/[/url]

It's a Jeep, it's not supposed to work right all the time.

Live in Florida? Check out Florida4x4.org!!!
mrJ is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 10:05 AM   #11157
aleet25
Registered User
2003 WJ 
 
Join Date: Apr 2012
Location: Auburn, Georgia
Posts: 230
Quote:
Originally Posted by USMCBehrensDVLD
Got a few things done this weekend. Painted my front grill and finally got my JCR stage II rock sliders, painted and installed, still iffy on them though.
I'd be happy to take those sliders off of your hands.
aleet25 is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 10:15 AM   #11158
wj4play
Web Wheeler
 
wj4play's Avatar
1999 WJ 
 
Join Date: Apr 2010
Location: Des Moines, Iowa
Posts: 1,251
Quote:
Originally Posted by Cnolenwj View Post
Finally got that sob fan/clutch off (boy was that a pain) put a new clutch on and still have the same problem.
Jeep runs at the right temp at slow speeds, even on a 3hr trail run I did the other weekend in 90 degree heat.
Get on the road running 50mph temp will go about 1/8 past 210 and at 70mph will go just over 1/4 past.
Have never seen this problem. The clutch had play so figured simple fix, of course not.
May try water pump next.
make sure radiator tubes are not plugged with the stop leak crap if it was PO jeep. or water pump is not circulating fluid
wj4play is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 11:23 AM   #11159
holder14
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Aberdeen, SD
Posts: 96
Quote:
Originally Posted by USMCBehrensDVLD
Got a few things done this weekend. Painted my front grill and finally got my JCR stage II rock sliders, painted and installed, still iffy on them though.
What about those sliders are you not sure on? What dont you like about them?
__________________
2001 Grand Cherokee Laredo 4.0L Patriot Blue (Named ATOM)
Interior: Pioneer DEH-P4900IB Head unit, Eclipse SE6900 6x9 Front speaker, Alpine Type-R 5 1/4 Component Rears, Alpine PDX-F4 Amp.
Exterior: IRO 3 inch Lift, 265/75-R16 General Grabber AT2's, 40' Rigid Industries SR SERIES LED Light Bar, Saguaro 3/4in Shackle mounts, Rola Roof Rack, Kolak Stillen Rotors, EBC green stuff pads, Addco Rear Sway, KOR 1.5" Wheel Spacers
holder14 is offline   Reply With Quote Quick reply to this message
Unread 06-06-2012, 12:03 PM   #11160
victor_927
Registered User
2000 WJ 
 
Join Date: Sep 2008
Location: wa
Posts: 40
Quote:
Originally Posted by aleet25

i'd be happy to take those sliders off of your hands.
x2
victor_927 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.