What did you do to your WJ today? - Page 46 - JeepForum.com

 285Likes
Reply
 
LinkBack Thread Tools
post #676 of 42258 Old 11-18-2010, 08:10 PM
Scibbyz99WJ
Registered User
1999 WJ 
 
Join Date: Jun 2010
Location: Howell
Posts: 866
talked to the shop today, shes all done and waiting for me to return home and pick her up on saturday. wohoo!
ill put up pics of my new brush guard and paint job. shiiiiny


'99 stroked 4.5L WJ 2" BDS lift
2008 Fire Red F150 XLT 4X4 3V 5.4LV8

Closed minds should go hand in hand with closed mouths
Scibbyz99WJ is offline  
Sponsored Links
Advertisement
 
post #677 of 42258 Old 11-18-2010, 11:11 PM
cb0y1
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Woodland Park
Posts: 16
Got the drivers side IRO rock slider mounted. Drove it to work.
cb0y1 is offline  
post #678 of 42258 Old 11-19-2010, 01:39 AM
myjeeplovesmud
Registered User
2004 WJ 
 
Join Date: Mar 2009
Location: Madison
Posts: 3,240
Quote:
Originally Posted by cb0y1 View Post
Got the drivers side IRO rock slider mounted. Drove it to work.
only one? lol

2004 WJ Limited 4.7 H.O
K&N FIPK - Magnaflow Exhaust
17" XD Series Spy Rims- Custom Painted
ZONE 4" Lift With 32" Duratracs
Hella Lighting - Rola Rack - KOR 3/4 Spacers
IRO Sliders - Rusty's Hooks - Cobra CB

MY BUILD THREAD
BAD TO THE BONE ZONE


November 2010 GCOTM
myjeeplovesmud is offline  
post #679 of 42258 Old 11-19-2010, 06:04 AM
Mud_Crazy
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Goldsboro
Posts: 701
installed my K&N Fipk last night. In the process broke the T-fitting for the vacuum line going to the intake piping. was a little pissed, but when removeing the check valves and the elbows i found that both elbows were dry rotted to hell. could possibly be why i was getting code P0455 for a large EVAP leak. cleared the code for it while intsalling the FIPK. waiting to see if the check engine light comes back on. oh a rigged a new line with clear high preasure hose from lowes. auto zone and advanced were out of blakc. haha

SILVER&BLACK 02 JEEP GRAND CHEROKEE 4.7L V8 HO, Clayton 6" liftT w/ Bilstien 5100's and 2in pucks , 37X12.5 Nitto Trail Grappler M/T's on red and black Creeper Locks, front and back Dana 60 w/ ARB lockers, Chromolly shafts and 5.13 gears, ARB compressor, Flowmaster 50 exhuast, K&N FIPK, IRO front bumper and flares, and Cobra 29NW with firestick antenna.

Build Thread
Mud_Crazy is offline  
post #680 of 42258 Old 11-19-2010, 02:52 PM
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 471
took out my front driveshaft. TPMS came in the mail so i'll probably get that done soon.
huntandfish is offline  
post #681 of 42258 Old 11-19-2010, 05:48 PM
GhostKnife
Registered User
2012 JK Wrangler 
 
Join Date: Mar 2010
Location: St Clair
Posts: 597
washed it

13 Ram Cummins, PPEI Tuned and Full Carli/Thuren. JK Arctic Edition 2dr Winter Chill
GhostKnife is offline  
post #682 of 42258 Old 11-19-2010, 06:32 PM
cb0y1
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Woodland Park
Posts: 16
Finished the installing the second rock slider. drove it to work.
cb0y1 is offline  
post #683 of 42258 Old 11-19-2010, 07:16 PM
88yjproject
Registered User
2002 WJ 
 
Join Date: Feb 2010
Location: Wyoming, Michigan
Posts: 1,078
Did oil change. While doing oil change found left front wheel bearing smoked. Replaced it on my lunch break.

2002 WJ 4.0 3" IRO, ES9000 shocks. Midland CB. 245/75R16 Dunlop M/T.
HydroLocked Offroad
88yjproject is offline  
post #684 of 42258 Old 11-19-2010, 09:48 PM
TheBoss
Registered User
2012 JK Wrangler 
 
Join Date: May 2010
Posts: 1,949
JKS front bar pin eliminators and new Rough country 9000 shocks front and rear
TheBoss is offline  
post #685 of 42258 Old 11-20-2010, 12:32 AM
cedxc2005
Registered User
2004 WJ 
 
Join Date: Jun 2010
Location: Queens, NY
Posts: 74
Went on my first trail ride....100% stock WJ vs. washed out forest service road/forgotten road. Not MOAB, but fun for me. Also got to see how my new duelers would take it. Good times.

My Jeep Thread (not a build thread!) - http://www.jeepforum.com/forum/f310/long-overdue-greetings-root-thread-1128437/
Something useful - http://www.jeep4x4center.com/jeep-service-manuals/index.htm
cedxc2005 is offline  
post #686 of 42258 Old 11-20-2010, 10:00 AM
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 471
Got my 1.5 inch wheel spacers, JKS BPE's, and Donkey dicks for all the shocks and the SS. Thninking about puting it on tomorrow.

Only took 11 days to get from IRO to my Box here in germany.
Attached Thumbnails
DSCN0701small.jpg  
huntandfish is offline  
post #687 of 42258 Old 11-20-2010, 10:05 AM
tayloredone
Registered User
2000  
 
Join Date: Feb 2010
Location: Florida
Posts: 2
HELP A damsel in distress



I purchased a 2000 Grand Cherokee Laredo in Feb in Fla and recently moved to upstate NY and my oil gauge stays at 80 all the time before I moved it was always in the middle around 40. I only use Mobil One and I was told it may be due to the cold weather but it really isn't that cold yet. I am concerned that something underlying as I sometimes smell a bit of burning. HELP please I truly am very concerned especially with winter looming...

Thanks so much, JOY

TheTayloredWord@yahoo.com

TayloredOne
tayloredone is offline  
post #688 of 42258 Old 11-20-2010, 03:06 PM
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 471
Quote:
Originally Posted by tayloredone View Post

I purchased a 2000 Grand Cherokee Laredo in Feb in Fla and recently moved to upstate NY and my oil gauge stays at 80 all the time before I moved it was always in the middle around 40. I only use Mobil One and I was told it may be due to the cold weather but it really isn't that cold yet. I am concerned that something underlying as I sometimes smell a bit of burning. HELP please I truly am very concerned especially with winter looming...

Thanks so much, JOY

TheTayloredWord@yahoo.com
could be a clogged oil filter(not sure if these engines have a bypass), junk in your oil, or a post in the wrong thread.
huntandfish is offline  
post #689 of 42258 Old 11-20-2010, 06:34 PM
Eshindi
Registered User
1999 WJ 
 
Join Date: Sep 2007
Location: Long Island, NY
Posts: 591
Just drove 300 miles to pick up a Dana 44 HP and a Ford 9" for the WJ.
Hope to have them prepped and ready to bolt in before spring.

'15 JK Stock | 4k Miles | Bone Stock
SOLD '99 WJ I6 | Claytons LA | 6.5" | HP D44 | F9" | 35's
Eshindi is offline  
post #690 of 42258 Old 11-20-2010, 07:40 PM
jadeDHero
Registered User
2003 WJ 
 
Join Date: Sep 2010
Location: Las Cruces
Posts: 94
I tried to drive mine to my Alcohol Server's Certification class this morning, but it didn't start. I jiggled the negative battery cable (which usually makes it work) but still no cigar. So I went to AutoZone and bought a corrosion prevention kit, installed it, jumped it, and it seems to work. Hopefully that holds out!
jadeDHero is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 4 (3 members and 1 guests)
et2473 , keekee1 , Mael
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Tried to do Spark Plugs today in the 4.7--Didn't happend Astorm WJ Grand Cherokee Forum 43 03-24-2014 08:35 PM
Died today... jimbo141 WJ Grand Cherokee Forum 28 05-09-2011 08:20 PM
I want to order some brakes today matrix849 WJ Grand Cherokee Forum 30 07-25-2010 01:01 AM
found an ad today KI4KWF WJ Grand Cherokee Forum 3 07-30-2007 12:27 AM
Just got my xenon on today ! unbelivable ! gaignstar WJ Grand Cherokee Forum 8 05-12-2002 08:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome