What did you do to your WJ today? - Page 46 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 11-18-2010, 08:10 PM   #676
Scibbyz99WJ
Registered User
1999 WJ 
 
Join Date: Jun 2010
Location: Howell, Michigan
Posts: 867
talked to the shop today, shes all done and waiting for me to return home and pick her up on saturday. wohoo!
ill put up pics of my new brush guard and paint job. shiiiiny

__________________
'99 stroked 4.5L WJ 2" BDS lift
2008 Fire Red F150 XLT 4X4 3V 5.4LV8

Closed minds should go hand in hand with closed mouths
Scibbyz99WJ is offline   Reply With Quote
Unread 11-18-2010, 11:11 PM   #677
cb0y1
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Woodland Park, CO
Posts: 16
Got the drivers side IRO rock slider mounted. Drove it to work.
cb0y1 is offline   Reply With Quote
Unread 11-19-2010, 01:39 AM   #678
myjeeplovesmud
Registered User
2004 WJ 
 
Join Date: Mar 2009
Location: Madison, WI
Posts: 3,240
Quote:
Originally Posted by cb0y1 View Post
Got the drivers side IRO rock slider mounted. Drove it to work.
only one? lol
__________________
2004 WJ Limited 4.7 H.O
K&N FIPK - Magnaflow Exhaust
17" XD Series Spy Rims- Custom Painted
ZONE 4" Lift With 32" Duratracs
Hella Lighting - Rola Rack - KOR 3/4 Spacers
IRO Sliders - Rusty's Hooks - Cobra CB

MY BUILD THREAD
BAD TO THE BONE ZONE


November 2010 GCOTM
myjeeplovesmud is offline   Reply With Quote
Unread 11-19-2010, 06:04 AM   #679
Mud_Crazy
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Goldsboro, North Carolina
Posts: 680
installed my K&N Fipk last night. In the process broke the T-fitting for the vacuum line going to the intake piping. was a little pissed, but when removeing the check valves and the elbows i found that both elbows were dry rotted to hell. could possibly be why i was getting code P0455 for a large EVAP leak. cleared the code for it while intsalling the FIPK. waiting to see if the check engine light comes back on. oh a rigged a new line with clear high preasure hose from lowes. auto zone and advanced were out of blakc. haha
__________________
SILVER&BLACK 02 JEEP GRAND CHEROKEE 4.7L V8 HO, Clayton 6" liftT w/ Bilstien 5100's and 2in pucks , 37X12.5 Nitto Trail Grappler M/T's on red and black Creeper Locks, front and back Dana 60 w/ ARB lockers, Chromolly shafts and 5.13 gears, ARB compressor, Flowmaster 50 exhuast, K&N FIPK, IRO front bumper and flares, and Cobra 29NW with firestick antenna.

[URL="http://www.jeepforum.com/forum/f197/backdoor_artist-first-ever-jeep-build-1167659/index7.html#post12830094"]Build Thread[/URL]
Mud_Crazy is offline   Reply With Quote
Unread 11-19-2010, 02:52 PM   #680
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 472
took out my front driveshaft. TPMS came in the mail so i'll probably get that done soon.
huntandfish is offline   Reply With Quote
Unread 11-19-2010, 05:48 PM   #681
GhostKnife
Registered User
2010  
 
Join Date: Mar 2010
Location: Port Huron, Michigan
Posts: 590
washed it
__________________
[FONT="Showcard Gothic"]2010 Dodge Ram Quadcab Sport, 5.7l with a Diablo Sport Predator.[/FONT]
GhostKnife is offline   Reply With Quote
Unread 11-19-2010, 06:32 PM   #682
cb0y1
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Woodland Park, CO
Posts: 16
Finished the installing the second rock slider. drove it to work.
cb0y1 is offline   Reply With Quote
Unread 11-19-2010, 07:16 PM   #683
88yjproject
Registered User
2002 WJ 
 
Join Date: Feb 2010
Location: Wyoming, Michigan, Michigan
Posts: 1,075
Did oil change. While doing oil change found left front wheel bearing smoked. Replaced it on my lunch break.
__________________
2002 WJ 4.0 3" IRO, ES9000 shocks. Midland CB. 245/75R16 Dunlop M/T.
HydroLocked Offroad
88yjproject is offline   Reply With Quote
Unread 11-19-2010, 09:48 PM   #684
TheBoss
Registered User
2012 JK Wrangler 
 
Join Date: May 2010
Location: , Madiganistan, Illi-noise
Posts: 1,830
JKS front bar pin eliminators and new Rough country 9000 shocks front and rear
TheBoss is offline   Reply With Quote
Unread 11-20-2010, 12:32 AM   #685
cedxc2005
Registered User
2004 WJ 
 
Join Date: Jun 2010
Location: Queens, NY, New York
Posts: 74
Went on my first trail ride....100% stock WJ vs. washed out forest service road/forgotten road. Not MOAB, but fun for me. Also got to see how my new duelers would take it. Good times.
__________________
My Jeep Thread (not a build thread!) - http://www.jeepforum.com/forum/f310/long-overdue-greetings-root-thread-1128437/
Something useful - http://www.jeep4x4center.com/jeep-service-manuals/index.htm
cedxc2005 is offline   Reply With Quote
Unread 11-20-2010, 10:00 AM   #686
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 472
Got my 1.5 inch wheel spacers, JKS BPE's, and Donkey dicks for all the shocks and the SS. Thninking about puting it on tomorrow.

Only took 11 days to get from IRO to my Box here in germany.
dscn0701small.jpg  
huntandfish is offline   Reply With Quote
Unread 11-20-2010, 10:05 AM   #687
tayloredone
Registered User
2000  
 
Join Date: Feb 2010
Location: Florida
Posts: 2
HELP A damsel in distress



I purchased a 2000 Grand Cherokee Laredo in Feb in Fla and recently moved to upstate NY and my oil gauge stays at 80 all the time before I moved it was always in the middle around 40. I only use Mobil One and I was told it may be due to the cold weather but it really isn't that cold yet. I am concerned that something underlying as I sometimes smell a bit of burning. HELP please I truly am very concerned especially with winter looming...

Thanks so much, JOY

TheTayloredWord@yahoo.com
__________________
TayloredOne
tayloredone is offline   Reply With Quote
Unread 11-20-2010, 03:06 PM   #688
huntandfish
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: einsedlerhof
Posts: 472
Quote:
Originally Posted by tayloredone View Post

I purchased a 2000 Grand Cherokee Laredo in Feb in Fla and recently moved to upstate NY and my oil gauge stays at 80 all the time before I moved it was always in the middle around 40. I only use Mobil One and I was told it may be due to the cold weather but it really isn't that cold yet. I am concerned that something underlying as I sometimes smell a bit of burning. HELP please I truly am very concerned especially with winter looming...

Thanks so much, JOY

TheTayloredWord@yahoo.com
could be a clogged oil filter(not sure if these engines have a bypass), junk in your oil, or a post in the wrong thread.
huntandfish is offline   Reply With Quote
Unread 11-20-2010, 06:34 PM   #689
Eshindi
Registered User
1999 WJ 
 
Join Date: Sep 2007
Location: Long Island, NY
Posts: 589
Just drove 300 miles to pick up a Dana 44 HP and a Ford 9" for the WJ.
Hope to have them prepped and ready to bolt in before spring.
__________________
'99 WJ I6 w/ 180k (and Purrs like a kitten)
Claytons LA | 6.5" | HP D44 | F9" | 35's\

My Build Log
Eshindi is offline   Reply With Quote
Unread 11-20-2010, 07:40 PM   #690
jadeDHero
Registered User
2003 WJ 
 
Join Date: Sep 2010
Location: Las Cruces, New Mexico
Posts: 51
I tried to drive mine to my Alcohol Server's Certification class this morning, but it didn't start. I jiggled the negative battery cable (which usually makes it work) but still no cigar. So I went to AutoZone and bought a corrosion prevention kit, installed it, jumped it, and it seems to work. Hopefully that holds out!
jadeDHero is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.