What did you do to your WJ today? - Page 2116 - JeepForum.com

 333Likes
 
LinkBack Thread Tools
post #31726 of 42541 Old 09-03-2014, 10:27 PM
wjidaho
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: boise
Posts: 2,119
Quote:
Originally Posted by afearlesshunter
Got DW....
Happens to us all ;-) now to fix it check your track bar, your ball joints, your tie rod ends, make sure your tires are balanced.. Pretty much check your whole front end... Get back to us with what you find and have fun it's a jeep!! :-D

wjidaho is offline  
Sponsored Links
Advertisement
 
post #31727 of 42541 Old 09-04-2014, 03:16 AM
SierraRipper
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Conyers
Posts: 169
Broken axle
SierraRipper is offline  
post #31728 of 42541 Old 09-04-2014, 08:01 AM
Hierotochan
Registered User
2001 WJ 
 
Join Date: Jul 2014
Location: Leeds
Posts: 236
RTV'd my PCVs:



Also did the LED bonnet light strips:


50% ideas, 50% guesswork. 100% winging it!
Hierotochan is offline  
post #31729 of 42541 Old 09-04-2014, 12:23 PM
Spyder328
Registered User
2000 WJ 
 
Join Date: Jun 2014
Posts: 205
Put my JGCJeeps dash speakers in today, no more buzzing

2000 WJ Laredo, 255/70R16, 2.5" front and 2" rear BB, 1.25" wheel spacers
Spyder328 is offline  
post #31730 of 42541 Old 09-04-2014, 12:47 PM
Beagle751
Registered User
2004 WJ 
 
Join Date: Aug 2014
Location: Lone Tree
Posts: 60
Just refreshed the gas tank with flat black looks good as new. Also picked up a new fuel filter "Wix" WJ has a 117k think it's about time after reading some posts here and getting close to posting pics
Beagle751 is offline  
post #31731 of 42541 Old 09-04-2014, 01:43 PM
Zacedward
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Midvale
Posts: 706
Quote:
Originally Posted by Spyder328 View Post
Put my JGCJeeps dash speakers in today, no more buzzing
Do they sound pretty good

UJC #181 2004 jeep Grand Cherokee 4.7L v8, 2"bb, kolak 3 " exhaust flowmaster 50 SUV , Rola roof basket, k&n cai,245/75 /16 A/T
Zacedward is offline  
post #31732 of 42541 Old 09-04-2014, 02:30 PM
4x4Jeep
Registered User
2001 WJ 
 
Join Date: Jan 2009
Location: Orlando
Posts: 2,340
removed my brush guard/lights and bumper cover, painted the bumper and radiator support black...because i'm having a tube winch bumper built. also painting my long arms black cause p.o. had them yellow

Build - http://www.jeepforum.com/forum/f197/4x4jeeps-build-thread-1341031 - SOLD
4x4Jeep is offline  
post #31733 of 42541 Old 09-04-2014, 06:40 PM
Spyder328
Registered User
2000 WJ 
 
Join Date: Jun 2014
Posts: 205
Quote:
Originally Posted by Zacedward View Post
Do they sound pretty good
Yeah, I think they sound pretty darn good

2000 WJ Laredo, 255/70R16, 2.5" front and 2" rear BB, 1.25" wheel spacers
Spyder328 is offline  
post #31734 of 42541 Old 09-04-2014, 06:44 PM
ace4usmc
Registered User
2004 WJ 
 
Join Date: Jul 2011
Location: Gainesville
Posts: 121
Replaced the CV shaft that had recently sprung a leak an was slinging grease every where. It's so much easier to remove the hub when you have the right tool i.e. a slide hammer.
ace4usmc is offline  
post #31735 of 42541 Old 09-04-2014, 06:53 PM
Jaketit
Registered User
2002 WJ 
 
Join Date: Mar 2011
Location: Port St. Lucie
Posts: 860
Quote:
Originally Posted by StrokedWJ
Spent a little time over the long weekend doing odds and ends. Replaced the hood struts and passenger window motor/regulator. Neither of those have worked for probably 10 years LOL. I also finally painted over the cladding. I cleaned with dish soap, and Krud Kutter, lightly sanded, sprayed plastic primer on the cladding, and Rustoleum bed liner from the spray can. I like the way it came out...just hope it lasts.
Looks better as it ages in my opinion. More salted.
Jaketit is offline  
post #31736 of 42541 Old 09-04-2014, 07:13 PM
Zacedward
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Midvale
Posts: 706
Quote:
Originally Posted by Spyder328 View Post
Yeah, I think they sound pretty darn good
I am going to have to get me some you just got them from the website

UJC #181 2004 jeep Grand Cherokee 4.7L v8, 2"bb, kolak 3 " exhaust flowmaster 50 SUV , Rola roof basket, k&n cai,245/75 /16 A/T
Zacedward is offline  
post #31737 of 42541 Old 09-05-2014, 07:48 AM
WJ02FNG
Registered User
2002 WJ 
 
Join Date: Jun 2013
Location: Longwood
Posts: 152
Freaked out cause my WJ was overheating. Since I have read about the radiator fan relays going bad- I replaced it and it worked perfect. Thank you all on jeep forum!

2002 Jeep Grand Cherokee 4.0L, 4x4, Selec-Trac TC, Auto Transmission
K&N drop-in air filter, B&M Supercooler Transmission Cooler, Rusty's Off Road Front Tow Hooks, Mopar Hitch. Iron Rock Off Road 3 inch lift.
WJ02FNG is offline  
post #31738 of 42541 Old 09-05-2014, 08:19 AM
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor
Posts: 5,783
Quote:
Originally Posted by EmeraldGreenXJ View Post
Replaced tail lights and used it to pull a rim off a junk xj
Amazing.....you would not think a tail light would be strong enough to do that!!

If you can't fix it with a hammer, you've got yourself an electrical problem!
alfaitalia is offline  
post #31739 of 42541 Old 09-05-2014, 09:23 AM
derekmac
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2012
Location: Elmsdale
Posts: 1,218
Garage
Ordered a Viair kit, coiled hose, and a couple of odds and ends for the install. I'd rather run the power cable on the passenger side, but can't seem to find a grommet to run it through.

I'm running 4 gauge to a fused distribution block in the back, as I plan on adding a power inverter down the road, and doing this will save me from having to run a separate power wire for the inverter. If I have to drill a hole in the firewall, that's ok (as long as I can get my drill in), but looking in the footwell area, I'm not sure where I should drill.

Anyone else run power wire down the passenger side instead of the drivers?

2005 TJ Rubicon
derekmac is offline  
post #31740 of 42541 Old 09-05-2014, 10:08 AM
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor
Posts: 5,783
Quote:
Originally Posted by derekmac View Post
Ordered a Viair kit, coiled hose, and a couple of odds and ends for the install. I'd rather run the power cable on the passenger side, but can't seem to find a grommet to run it through.

I'm running 4 gauge to a fused distribution block in the back, as I plan on adding a power inverter down the road, and doing this will save me from having to run a separate power wire for the inverter. If I have to drill a hole in the firewall, that's ok (as long as I can get my drill in), but looking in the footwell area, I'm not sure where I should drill.

Anyone else run power wire down the passenger side instead of the drivers?
I did. Found a grommet on the firewall about six inches from the inner fender and about the height of the glovebox. The cable that powers my 1000w inverter (that lives under the steering column) goes through it along with the relay trigger wire for my roof lights. Ok, Im right hand drive but nearly everthing else is just mirrored so worth a look.

If you can't fix it with a hammer, you've got yourself an electrical problem!
alfaitalia is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Tried to do Spark Plugs today in the 4.7--Didn't happend Astorm WJ Grand Cherokee Forum 43 03-24-2014 08:35 PM
Died today... jimbo141 WJ Grand Cherokee Forum 28 05-09-2011 08:20 PM
I want to order some brakes today matrix849 WJ Grand Cherokee Forum 30 07-25-2010 01:01 AM
found an ad today KI4KWF WJ Grand Cherokee Forum 3 07-30-2007 12:27 AM
Just got my xenon on today ! unbelivable ! gaignstar WJ Grand Cherokee Forum 8 05-12-2002 08:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome