What did you do to your WJ today? - Page 1942 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueRough Country Lift Kits and Parts!

Reply
Unread 03-24-2014, 09:45 PM   #29116
fayceoff
Ninja pirate
 
fayceoff's Avatar
1999 WJ 
 
Join Date: Aug 2013
Location: VA Beach, VA
Posts: 316
Quote:
Originally Posted by Johnyre View Post
Thank you!!!
Glad to contribute something!

__________________
"A good plan [committed to and] violently executed now is infinitely better than a perfect plan at some indeterminate time in the future." - Gen. Douglas MacArthur

"Be polite... Be professional... But have a plan to kill everyone you meet."

Engine compartment LED mod http://www.jeepforum.com/forum/f310/...te-up-2260105/
fayceoff is offline   Reply With Quote
Unread 03-25-2014, 05:05 AM   #29117
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor, West Sussex. England. Great Britain
Posts: 2,764
Changed my 12000 mile old oil (standard change time for a CRD). Put in 5w 40 Castrol EDGE.....usually use a 10w 40 semi synthetic but Castrols website advised a fully synthetic 5 w 40 for max protection for my engine. The choice was obviously nothing to do with being able to get it cheap!!....well maybe a little. Being a diesel the old oil was very black....usually is after a very short time to be honest. Used STP engine flush and left the sump to drain overnight. I like to do that to get as much oil stuff out as possible and I never put cold new oil into a hot engine anyway so it allows the motor to cool right down. Fitted a new WIX filter (cheapest on Ebay too!) Added my usual bottle and a half of XIR as well.....not for any claimed performance gain but as protection for my engine on cold starts and if the engine should suffer a major failure (oil pump etc) it give it half a chance of stopping it before any serious damage. The company has quite a good video of them flying a small plain with an empty sump....just relying on the X1R for protection! Im not saying whether it really works or not but its never caused my motors any harm so why not?
I have noticed (probably due to the 5w oil) that it turns over quicker from cold and picks up revs faster....feels like a warm engine from the off. The whole car just feels smoother. Hope it lasts. The only downside is that it has slightly lower oil pressure when hot and idling....but not so low to worry about.
__________________
If at first you don't succeed, skydiving is not for you.
alfaitalia is offline   Reply With Quote
Unread 03-25-2014, 07:11 AM   #29118
Zacedward
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Midvale, Utah
Posts: 551
Quote:
Originally Posted by fayceoff View Post

http://www.jeepforum.com/forum/f46/a.../#post21540945

Zacedward, Johnyre, heres a link to my engine compartment light mod. Hope it helps. Let me know!
Sweet thanks so much that helps alot much appreciated your a gentleman and a scholar
__________________
UJC #181 2004 jeep Grand Cherokee 4.7L v8, 2"bb, kolak 3 " exhaust flowmaster 50 SUV , Rola roof basket, k&n cai,245/75 /16 A/T
Zacedward is offline   Reply With Quote
Unread 03-25-2014, 11:18 AM   #29119
03CUSEWJ
Registered User
2003 WJ 
 
Join Date: Jan 2012
Location: Syracuse, New York
Posts: 147
Now that I cracked my front bumper I thought I would go ahead and convert to the 04 bumber that I already have. I want to use these 6" Hellas I have. It will save me money and I think they look good..I will post when its all mounted up.
04wj_fog.jpg  
03CUSEWJ is offline   Reply With Quote
Unread 03-25-2014, 11:38 AM   #29120
99WJ539918
Registered User
1999 WJ 
 
Join Date: Aug 2008
Location: , Northern New Jersey
Posts: 1,373
Quote:
Originally Posted by 4x4Jeep View Post
got my clockspring today. now i just have to figure out how to install it.
Where did you get yours from? What did you pay for it? My AIRBAG light goes on and off twenty times throughout my commute to work. It's really annoying me now. Thanks.
__________________
PSA - It would be nice if people made an attempt while typing to discuss their problems or opinions instead of one long sentence with no punctuation. Maybe I'm cynical, but that really pisses me off. Rant over.

"It's like saying I had a car I got that was painted by the previous owner. I had an accident so painting a car is unsafe." - cykaaro
99WJ539918 is offline   Reply With Quote
Unread 03-25-2014, 11:41 AM   #29121
Locutus
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Revere, Ma
Posts: 581
ebay

64 shipped

http://www.ebay.com/itm/170969660123...84.m1423.l2649
__________________
If it ain't broke, fix it till it is
Locutus is offline   Reply With Quote
Unread 03-25-2014, 12:49 PM   #29122
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 2,923
Quote:
Originally Posted by Locutus View Post
I also got mine off of eBay, but the newer WJ's have two wires. You have a '99 so I think that will work for you.
Clock spring didn't help me, I had to replace the ACM.

Sent from my iPad using electrons
rdkendrick is offline   Reply With Quote
Unread 03-25-2014, 02:38 PM   #29123
Highschool_WJ
Registered User
1999 WJ 
 
Join Date: Jan 2013
Location: Minot, ND
Posts: 238
Yesterday, i replaced the passenger side ball joints and hub assembly. Handles much better now!

And today i order a set of rigid industries dually spots with the 4x4 fabworks inside bumper mount, started collecting parts for my future led rock light setup, and bought a fire extiguisher to mount in the cargo area
Highschool_WJ is offline   Reply With Quote
Unread 03-25-2014, 02:56 PM   #29124
VestaviaPirate
Registered User
2004 WJ 
 
Join Date: Feb 2010
Location: Sardis, NC
Posts: 98
Bought and installed one of those LED ring cup holder sets.

Can only get it to light up blue, will not change any settings. Thought it was the controller, but tested it directly on my battery, the product works then as advertised.

Now I'm trying to hunt down why my set will only light up blue, but won't change any other settings when connected to a power source inside the Jeep. I'm thinking I can't find a sufficient ground. Tried connecting to both aux power plugs (cigarette lighter) and even the fuse, which is why I think it's the ground. My hunt continues!!!
VestaviaPirate is offline   Reply With Quote
Unread 03-25-2014, 03:25 PM   #29125
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 2,923
Quote:
Originally Posted by VestaviaPirate View Post
Bought and installed one of those LED ring cup holder sets. Can only get it to light up blue, will not change any settings. Thought it was the controller, but tested it directly on my battery, the product works then as advertised. Now I'm trying to hunt down why my set will only light up blue, but won't change any other settings when connected to a power source inside the Jeep. I'm thinking I can't find a sufficient ground. Tried connecting to both aux power plugs (cigarette lighter) and even the fuse, which is why I think it's the ground. My hunt continues!!!
I think the guy that sells those offered to replace your controller. Just PM him.

Sent from my iPad using electrons
rdkendrick is offline   Reply With Quote
Unread 03-25-2014, 05:59 PM   #29126
Kilopup
Registered User
2000 WJ 
 
Join Date: Dec 2012
Location: Fruit Heights, Utah
Posts: 61
Came out to the driveway to realize I wouldn't be driving it until this is fixed...

image-1254829156.jpg

My wife said she heard a weird noise but didn't think anything of it.
__________________
-Doug 2000WJ 4.7, IRO 3", MB TKO 16 wheels, 245/75/16 Goodyear Duratrac's, Bilstein 5100's, JKS adj. trackbar, MOOG super trail boss SS
Kilopup is offline   Reply With Quote
Unread 03-25-2014, 06:52 PM   #29127
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA, PA
Posts: 2,112
Quote:
Originally Posted by alfaitalia View Post
Changed my 12000 mile old oil (standard change time for a CRD). Put in 5w 40 Castrol EDGE.....usually use a 10w 40 semi synthetic but Castrols website advised a fully synthetic 5 w 40 for max protection for my engine. The choice was obviously nothing to do with being able to get it cheap!!....well maybe a little. Being a diesel the old oil was very black....usually is after a very short time to be honest. Used STP engine flush and left the sump to drain overnight. I like to do that to get as much oil stuff out as possible and I never put cold new oil into a hot engine anyway so it allows the motor to cool right down. Fitted a new WIX filter (cheapest on Ebay too!) Added my usual bottle and a half of XIR as well.....not for any claimed performance gain but as protection for my engine on cold starts and if the engine should suffer a major failure (oil pump etc) it give it half a chance of stopping it before any serious damage. The company has quite a good video of them flying a small plain with an empty sump....just relying on the X1R for protection! Im not saying whether it really works or not but its never caused my motors any harm so why not?
I have noticed (probably due to the 5w oil) that it turns over quicker from cold and picks up revs faster....feels like a warm engine from the off. The whole car just feels smoother. Hope it lasts. The only downside is that it has slightly lower oil pressure when hot and idling....but not so low to worry about.
You should make your oil decision and OCI decision based on your driving habits and a UOA, not based on what the oil company tells you ......
Not sure if you can get Rotella there but there T6 would be a better choice.
__________________
QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline   Reply With Quote
Unread 03-25-2014, 07:30 PM   #29128
Stimmel
Registered User
2001 WJ 
 
Join Date: Sep 2012
Location: Worthington, OH
Posts: 345
Got this to install with my tranny cooler and pan with a drain plug
image-1318288717.jpg

Stimmel is offline   Reply With Quote
Unread 03-25-2014, 07:55 PM   #29129
cr8zynelly
Senior Member
 
cr8zynelly's Avatar
2002 WJ 
 
Join Date: May 2013
Location: Wilmette, IL
Posts: 784
Quote:
Originally Posted by cr8zynelly
Not today but tomorrow I will be picking these up. . .possibly installing them depending on the condition of the tires. Been chasing a set of these for a while.
As promised. . .

Crazy that this Sahara rim/tire package with 18k miles seems to ride better than the brand new (0 mile) set I just took off? Filled with nitrogen? Couldn't make that much of a difference, could it? Or "Christine" just likes being back in black!

Def gonna move white letters in at some point.

Mopar molded grill to come next. . .
image-3604958635.jpg

cr8zynelly is offline   Reply With Quote
Unread 03-25-2014, 08:03 PM   #29130
pyre24
Registered User
2000 WJ 
 
Join Date: Jan 2013
Location: sterling, illinois
Posts: 169
^ Sexy!!!!! I wish I had my own wj to play with instead of my wifes.
pyre24 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.