What did you do to your WJ today? - Page 1763 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

Savvy/Currie Aluminum Control ArmsSavvy FOX IFP 4" Lift Shocks in StockSavvy Aluminum Bumpers

Reply
Unread 12-11-2013, 01:04 PM   #26431
Hytek
Senior Member
1998 ZJ 
 
Join Date: Aug 2012
Location: Romeoville, IL
Posts: 787
About to hit 75k so I'm gathering tune up stuff. Champion plugs, throttle body cleaner for tb and IAC, pcv, and air filter. Think I have everything covered....just need a day that's not freezing out now.

__________________
98 5.9 Limited - IRO 3.5", IRO short arms track bars Bilsteins, Addco, JK wheels, 255-75/17 BFG, Magnaflow, Flowmaster
04 Limited 4.7H.O QD, UC+BB, Bilsteins, 245/75-16 Duratracs Addco sway bar
Hytek is offline   Reply With Quote Quick reply to this message
Unread 12-11-2013, 02:02 PM   #26432
joshtarmy1
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Auburn, Maine
Posts: 49
Put on muffler on my WJ today. Stopped by Meineke and my brother put it on his charge account. $140 installed for an off brand of Magnaflow they called it. Sounds decent, no drone so far and best part it doesn't leak. Gotta look into this delayed start problem that started a few days ago. Starts up fine but every once in a while I turn the key it does nothing for maybe 5 seconds and then fires right up. Seems to happen mostly when the engine is cold. Battery is reading 672 CCA. Battery terminals are clean, gonna check the connections at the starter and double check the battery terminals.
joshtarmy1 is offline   Reply With Quote Quick reply to this message
Unread 12-11-2013, 05:16 PM   #26433
bgohsman
Registered User
1999 WJ 
 
Join Date: May 2009
Location: Grand Rapids, MI
Posts: 229
Today, I finished my seemingly endless front end project. It started with bad pinion bearings. That lead to purchasing a used axle assembly to swap with it. While I had it on a bench, replaced the seals, races and bearings. While swapping the assemblies, I replaced the ball joints, tie rod ends and tie rod. Ended up purchasing new axles because I went from a Dana 30 vari-loc to a Dana 30 standard/open differential. Finally got everything together, greased, torqued and took her for her maiden voyage today. No, shimmy, vibration or noise. Me happy.

http://www.echobox.com/jeep_axle
__________________
Brandon Gohsman
bgohsman is offline   Reply With Quote Quick reply to this message
Unread 12-11-2013, 05:25 PM   #26434
65novalt1ss
Registered User
2002 WJ 
 
Join Date: Oct 2011
Location: Glasgow, KY
Posts: 139
Had water run down the inside of my windshield. Started a thread.
65novalt1ss is offline   Reply With Quote Quick reply to this message
Unread 12-11-2013, 09:49 PM   #26435
DarkStarr
Registered User
2003 WJ 
 
Join Date: Aug 2011
Location: Kansas City, Missouri
Posts: 120
Quote:
Originally Posted by joshtarmy1 View Post
Put on muffler on my WJ today. Stopped by Meineke and my brother put it on his charge account. $140 installed for an off brand of Magnaflow they called it. Sounds decent, no drone so far and best part it doesn't leak. Gotta look into this delayed start problem that started a few days ago. Starts up fine but every once in a while I turn the key it does nothing for maybe 5 seconds and then fires right up. Seems to happen mostly when the engine is cold. Battery is reading 672 CCA. Battery terminals are clean, gonna check the connections at the starter and double check the battery terminals.
The OEM specs say minimum of 650 Cold Cranking Amps, your battery is damn close to that.

Also remember the colder it gets, the more power is needed. I am dropping in a new battery very soon for this reason, mine SHOULD be fine but when its really cold and I go to start it the Jeep kinda hard starts. It takes it a few seconds and then it kinda rumbles to life. Didn't really pay attention but noticed the other day that when doing starting the first time things dimmed. I checked the voltage and its all good so I am gonna swap it before it leaves me stuck somewhere.
DarkStarr is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 05:47 AM   #26436
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,385
Sold my front Dana 30 axle from my part out Jeep to fund more parts'n upgrades
image-1423303710.jpg

__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 07:38 AM   #26437
NOTW_WJ
Member
 
NOTW_WJ's Avatar
2004 WJ 
 
Join Date: Jan 2013
Location: Orange County, CA
Posts: 198
Pulled my front driveshaft because the transfer case chain is soooo strectched and is needing an overhaul. Also, scored a smoking deal on a NP231D HD Transfer case for $50!!! I'm going to scavenge parts from it to upgrade my 231J... when I get some time to work on it that is..lol... I have a input speed sensor for the tranny, fuel filter, and new rock sliders that need to be installed still, as well as a truss/skid plate, Aussie locker, master install kit, and spare axle waiting to be built....lotsa parts and not enough time to wrench
NOTW_WJ is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 12:02 PM   #26438
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Quote:
Originally Posted by NOTW_WJ View Post
Pulled my front driveshaft because the transfer case chain is soooo strectched and is needing an overhaul. Also, scored a smoking deal on a NP231D HD Transfer case for $50!!! I'm going to scavenge parts from it to upgrade my 231J... when I get some time to work on it that is..lol... I have a input speed sensor for the tranny, fuel filter, and new rock sliders that need to be installed still, as well as a truss/skid plate, Aussie locker, master install kit, and spare axle waiting to be built....lotsa parts and not enough time to wrench
I havecthe opposite, lots of time no money for parts
Trxgedy is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 12:46 PM   #26439
NOTW_WJ
Member
 
NOTW_WJ's Avatar
2004 WJ 
 
Join Date: Jan 2013
Location: Orange County, CA
Posts: 198
Quote:
Originally Posted by Trxgedy View Post
I have the opposite, lots of time no money for parts
I hear ya, I've been there more often than not.
NOTW_WJ is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 04:47 PM   #26440
joshtarmy1
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Auburn, Maine
Posts: 49
Well my WJ is running like crap again. shaking at idle and when giving it gas. Not sure but it seems to start acting up everytime I go below half tank of gas. Getting a code P0307 again. New TPS, IAC, plugs, new coil on Cyl 7. I guess next thing to check would be injectors. Noticed the positive terminal on the battery was a little loose. Gonna pick up some new terminals tomorrow. Not sure if that would cause it. Also got a delay when starting. Noticing it seems to take longer to start then usual. Turn the key and hold it and after about 10-15 seconds it turns right over. Battery is at 672 cca yesterday at 20 something degrees. Today was in the single digits. Not sure if maybe I should go ahead and buy a new battery tomorrow.
joshtarmy1 is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 06:08 PM   #26441
Hytek
Senior Member
1998 ZJ 
 
Join Date: Aug 2012
Location: Romeoville, IL
Posts: 787
My new front upper shock bushings showed up today. Only problem is they don't look like what's on there now and it's too damn cold to mess with them now.
__________________
98 5.9 Limited - IRO 3.5", IRO short arms track bars Bilsteins, Addco, JK wheels, 255-75/17 BFG, Magnaflow, Flowmaster
04 Limited 4.7H.O QD, UC+BB, Bilsteins, 245/75-16 Duratracs Addco sway bar
Hytek is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 06:13 PM   #26442
north50
Senior Member
 
north50's Avatar
1998 TJ Wrangler 
 
Join Date: Oct 2010
Location: florida
Posts: 681
Pulled it out of the garage after finishing the 6" Clayton lift. I have a slight vibration in the front under load, should just need to adjust the pinion angle. Also I had flushed the front diff and put in new fluid (Mobil1 Syn 75W140 and the mopar modifier) but thinking it needs more modifier added because it feels like it is locking up a little. I used 2.5oz of the modifier as suggested for the Quadradrive front axle.


north50 is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 07:31 PM   #26443
03azwj
Registered User
2003 WJ 
 
Join Date: Aug 2012
Location: Prescott, AZ
Posts: 483
Quote:
Originally Posted by north50 View Post
Pulled it out of the garage after finishing the 6" Clayton lift. I have a slight vibration in the front under load, should just need to adjust the pinion angle. Also I had flushed the front diff and put in new fluid (Mobil1 Syn 75W140 and the mopar modifier) but thinking it needs more modifier added because it feels like it is locking up a little. I used 2.5oz of the modifier as suggested for the Quadradrive front axle.


Looks great.
__________________
3" OME HD springs, Bilstein 5100, JKS adjustable trackbar, Moog SS, IRO UCA'S & LCA'S, 3/4" front and rear spacers, BFG M/T km LT255/75R17, JK Rubicon takeoffs, 8K HIDS Hi's & Lo's. full Rockford Fosgate set-up, blue l.e.d. interior, clumsy driver
03azwj is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 07:40 PM   #26444
PhantomWJ
Registered User
2003 WJ 
 
Join Date: Jan 2010
Location: IE
Posts: 3,246
Waiting on Mr. BROWN to deliver my 5 Soft 8's so I can mount the 5 35x12.5 GY MTRs i have......
PhantomWJ is online now   Reply With Quote Quick reply to this message
Unread 12-12-2013, 07:41 PM   #26445
PowderHound
Registered User
2003 WJ 
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 294
^X2 looks great^
__________________
2003 WJ♦Inferno Red Limited(4.7 H.O., Vari-Lok axles)♦OME HD/BILLY 5100S♦IRO t-case skid, adj. tb, sway links♦Moog SS♦Factory tow package w/harness & tow hooks♦ Amp/12 sub box♦new bad b**ch passenger♦1993 XJ country♦lift/muds/winchbumper-sold♦build thread instead of long A$$ sig soon...
PowderHound is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.