What did you do to your WJ today? - Page 1748 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

ZONE 4.25" combo lift for TJ available at Rockridge4wRough Country Lift Kits and Parts!Warrior Products @ Oconee Off-Road! 706-534-9955

Reply
Unread 11-29-2013, 07:01 PM   #26206
TwinchargedRX7
Registered User
2002 WJ 
 
Join Date: Sep 2012
Location: Lyndhurst, NJ
Posts: 76
Yesterday I changed the plugs and changed the last evap hose by the rear axle and the CEL finally went away.

Today I tried to get the airbag light to go away by swapping the clock spring with a used one. Unfortunately the problem didn't go away so either the used clock spring was junk or there is something else wrong.

Next on the list:
Tires
Alignment and hopefully fix my clunk (I think the jus track bar bushings, but also have some kind of clunk in the rear)
New petcock for radiator drain (it's slowly dripping)
Change oil

TwinchargedRX7 is offline   Reply With Quote Quick reply to this message
Unread 11-29-2013, 08:05 PM   #26207
Jaketit
Registered User
2002 WJ 
 
Join Date: Mar 2011
Location: Port St. Lucie, Florida
Posts: 705
Quote:
Originally Posted by vagov
my buddy put a set of nittros on his ford 150 so far he is happy with them. wearing good
no no to niitos they always look like squares
Jaketit is offline   Reply With Quote Quick reply to this message
Unread 11-29-2013, 09:37 PM   #26208
4x4Jeep
Registered User
2001 WJ 
 
Join Date: Jan 2009
Location: Orlando, FL
Posts: 2,232
great day of wheeling...i don't think i broke anything either.
__________________
Build - http://www.jeepforum.com/forum/f197/4x4jeeps-build-thread-1341031
Florida 4x4
4x4Jeep is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 07:20 AM   #26209
Locutus
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Revere, Ma
Posts: 623
Received my calipers and pads

Locutus is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 07:39 AM   #26210
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor, West Sussex. England. Great Britain
Posts: 3,062
Just fitted underbody LED strip, rock lights or access lights ....whatever you want to call them. I can switch them on by themselves or they come on with the courtesy lights when you unlock the door with the remote. I would be lying if I said they would get much "rock light" use as there are next to no rocks around here....and if you go out night trail driving around these parts you will more than likely get arrested for poaching! I have to park off road a bit a get fed up walking back to the car and standing in a big puddle I did not see due to no car or street lighting! Hence the ability to come on with the interior lights!
Pics when it gets dark ....in 3 hours (UK time..winter is the pits!)
__________________
Before you judge a man, walk a mile in his shoes; after that, who cares?! He's a mile away and you've got his shoes!
alfaitalia is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 08:45 AM   #26211
Thomahawk
Registered User
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,387
^^^Waiting for pics,,,

Had another look at fluid leaks after radiator change today, wiped everything down again to locate it easier.

PS fluid conections at fan seems good and tight now.
Minor coolant dripping at big lower hose/clamp engine side, got the rubber tube wiggled alittle and moved the clamp some seemed to cure this
ATF leak at lower radiator conection, got it tightened up by half a turn, looks ok, but will keep an eye on this on.


image-3361719799.jpg


This is my hand after radiator swap, no question that its tight behind there,,,


image-3648811348.jpg

Sent from my iPhone using JeepForum
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread [url]http://www.jeepforum.com/forum/f197/jeep-norway-2th-buildt-overland-upgrade-1813490/[/url]

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 12:53 PM   #26212
doorjamm
Registered User
2000 WJ 
 
Join Date: Sep 2012
Location: Granite Bay, California
Posts: 649
So fed up with my jeep. Ready to sell it or part it out right now. Drivers door latch stopped working on Monday. Gcjeeping helped me out and grabbed me one from one of his extra doors he has, but it wasn't a matching part. Mine had more doo dads and gizmos and was marked GL4 and the one he gave me was marked GL2. So I took mine apart, cleaned/regreased it, and reinstalled to find it working again. It went out again last night. Have to keep my windows rolled down and zip ties on the b pillar to keep it from swinging open and I get the whole EVIC beeping CONSTANTLY when I drive about it being open. So ****ing annoying. Then of course the motor I just spent 3 grand into rebuilding myself, leaks at the rear main seal some how and I have to pull the whole engine to get to that. Because of that leak, it falls onto the cat, and smoke billows from underneath the hood and you get a lovely smell wherever you go. And of course my radiator decided this would be a good time to start going out so that it could overheat.

Oh and I forgot, my death wobble is back. So done with my WJ.
doorjamm is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 01:04 PM   #26213
aralph30
Registered User
2003 WJ 
 
Join Date: Apr 2013
Location: melville, ny
Posts: 600
Quote:
Originally Posted by doorjamm
So fed up with my jeep. Ready to sell it or part it out right now. Drivers door latch stopped working on Monday. Gcjeeping helped me out and grabbed me one from one of his extra doors he has, but it wasn't a matching part. Mine had more doo dads and gizmos and was marked GL4 and the one he gave me was marked GL2. So I took mine apart, cleaned/regreased it, and reinstalled to find it working again. It went out again last night. Have to keep my windows rolled down and zip ties on the b pillar to keep it from swinging open and I get the whole EVIC beeping CONSTANTLY when I drive about it being open. So ****ing annoying. Then of course the motor I just spent 3 grand into rebuilding myself, leaks at the rear main seal some how and I have to pull the whole engine to get to that. Because of that leak, it falls onto the cat, and smoke billows from underneath the hood and you get a lovely smell wherever you go. And of course my radiator decided this would be a good time to start going out so that it could overheat. Oh and I forgot, my death wobble is back. So done with my WJ.
we'll if u do part it out. Do u have any tow hooks I'll buy them from u.
__________________
I LOVE MY JEEP MORE THAN MY GIRLFRIEND :p
aralph30 is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 01:19 PM   #26214
doorjamm
Registered User
2000 WJ 
 
Join Date: Sep 2012
Location: Granite Bay, California
Posts: 649
Quote:
Originally Posted by aralph30
we'll if u do part it out. Do u have any tow hooks I'll buy them from u.
Got Aspen creek offroad d ring mounts and shackles. I'll post up if I start selling things like the lift and all the mods
doorjamm is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 03:51 PM   #26215
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor, West Sussex. England. Great Britain
Posts: 3,062
As I mentioned earlier I fitted under body lights. Here they are.

imgp2097.jpg

imgp2098.jpg
My camera really struggles to focus on bright lights when its dark so you cant really tell that there is a bright LED every 3/8 of an inch or so...looks like a neon but its not!

imgp2095.jpg

imgp2096.jpg

imgp2099.jpg
They are not blue at all...they are a bright white...the camera does lie! Also makes the light look tighter to the car than it is. Usable light is produced to about a foot away from the car.

Going to put some acroos the front and rear too which will have a beam pattern a little further away from the car so i can see the wheels....just in case I go off road at night...unlikely!
__________________
Before you judge a man, walk a mile in his shoes; after that, who cares?! He's a mile away and you've got his shoes!
alfaitalia is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 03:52 PM   #26216
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,129
Quote:
Originally Posted by alfaitalia View Post
Just fitted underbody LED strip, rock lights or access lights ....whatever you want to call them. I can switch them on by themselves or they come on with the courtesy lights when you unlock the door with the remote. I would be lying if I said they would get much "rock light" use as there are next to no rocks around here....and if you go out night trail driving around these parts you will more than likely get arrested for poaching! I have to park off road a bit a get fed up walking back to the car and standing in a big puddle I did not see due to no car or street lighting! Hence the ability to come on with the interior lights! Pics when it gets dark ....in 3 hours (UK time..winter is the pits!)
Where did you mount them, to your rock rails? And, how did you run the wiring into the cabin? I am assuming you wired it into the courtesy light?

Sent from my iPad using my fingers
rdkendrick is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 03:59 PM   #26217
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor, West Sussex. England. Great Britain
Posts: 3,062
Quote:
Originally Posted by rdkendrick View Post
Where did you mount them, to your rock rails? And, how did you run the wiring into the cabin? I am assuming you wired it into the courtesy light?

Sent from my iPad using my fingers
No they are on the flat panel just in from the plastic sill (you say rockers!) covers. The wires run up behind the front plastic arch liners, behind the wings (fenders!) and into the car through the door rubber boot. Yes they are wired to both the front footwell lights. This means toy can turn them on of off with the slider on the indicator stalk...but I might use a five pin relay and a switch so I can turn them on and off independantly as well. Was pushed for time today as I was supposed to be working....shhh...dont tell the Boss!
__________________
Before you judge a man, walk a mile in his shoes; after that, who cares?! He's a mile away and you've got his shoes!
alfaitalia is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 04:02 PM   #26218
Chris00WJ
Registered User
2000 WJ 
 
Join Date: Sep 2009
Location: Calgary, Alberta
Posts: 126
I checked my local JY bright and early this morning and saw online that they had a new WJ. So a buddy and I headed down bright and early hoping to replace my broken header panel. No such luck. It was in a front end collision.

HOWEVER, it had near mint leather seats that were the correct color, and was a limited so it had the white face cluster I needed/wanted. I havent been able to buy one online because they are all in MPH and Im in Canada and needed one in KM/hr. So everything got installed this afternoon.

I've gotta say, I love the leather. It really made me appreciate the Jeep again. She has been neglected for a while.
Chris00WJ is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 05:40 PM   #26219
joshtarmy1
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Auburn, Maine
Posts: 49
Swapped in a new IAC fix a bad negative terminal on the battery that I just noticed and put in some new plugs. Gonna try to change the oil tomorrow. Idle is smooth now, no more hesitation and it doesn't shake anymore. Just hoping that my misfire code doesn't come back. The plug on Cyl 8 wasn't too bad but 7 was a pain in the butt. Looked like a rubber o-ring melted to the plug. Used an idea I found on here with the sharpened coat hanger and heated it up with a torch to break the rubber apart. Didn't feel like going to Napa for the stock champions so I went with a set of the Bosch Copper plugs.
joshtarmy1 is offline   Reply With Quote Quick reply to this message
Unread 11-30-2013, 07:58 PM   #26220
fast540
Registered User
1999 WJ 
 
Join Date: Aug 2012
Location: rohnert park, ca
Posts: 1,551
Just picked ups 6" rock krawler lift. Super stoked as it's not made anymore
fast540 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.