What did you do to your WJ today? - Page 1747 - JeepForum.com

 481Likes
 
LinkBack Thread Tools
post #26191 of 43274 Old 11-28-2013, 07:26 PM
jamesrw30
Registered User
2004 WJ 
 
Join Date: Jul 2010
Location: Kingsport
Posts: 242
Pretty freaking awesome.

jamesrw30 is offline  
Sponsored Links
Advertisement
 
post #26192 of 43274 Old 11-29-2013, 08:22 AM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 8,050
Bought PS fluid this morning, refilled, bleeded, steering ok again
Added, bleeded and checked coolant once more, ok by now.
Checked, added Transmission fluid until level ok,
Ground strap mounted to driver side coil, thx to JF members, Thumbsup

Noticed That it leaked some fluid, cleaned everything down to trace it easier,
Looks like its coolant coming from the big lower radiator hose, just small dripping, so i will try to Fix this tomorow when i have axcess to a shop, its cold outside today, brrrrrr.

Quick clean of Jeep and engine compartment, it had been some spills with different fluids, lol
Looks Way better now
Attached Images
   

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
post #26193 of 43274 Old 11-29-2013, 09:30 AM
Hytek
Registered User
1998 ZJ 
 
Join Date: Aug 2012
Location: Romeoville
Posts: 824
Buying her new tires today but I can't decide between Nitto Terra Grapplers and Hankook Dynapro ATMs.

98 5.9 Limited - IRO 3.5", IRO short arms track bars Bilsteins, Addco, JK wheels, 255-75/17 BFG, Magnaflow, Flowmaster
04 Limited 4.7H.O QD, UC+BB, Bilsteins, 245/75-16 Duratracs Addco sway bar
Hytek is offline  
post #26194 of 43274 Old 11-29-2013, 12:54 PM
vagov
Registered User
2004 WJ 
 
Join Date: Aug 2012
Location: pittsburgh
Posts: 222
Quote:
Originally Posted by Hytek View Post
Buying her new tires today but I can't decide between Nitto Terra Grapplers and Hankook Dynapro ATMs.
my buddy put a set of nittros on his ford 150 so far he is happy with them. wearing good
vagov is offline  
post #26195 of 43274 Old 11-29-2013, 02:18 PM
TJSWJ
Registered User
2001 WJ 
 
Join Date: Mar 2010
Location: Olmsted Falls
Posts: 2,271
Finished the massive install ive been doing for the past 5 months, and flexed it!



Then picked up this to replace the 231hd that I just built lol



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TJSWJ is offline  
post #26196 of 43274 Old 11-29-2013, 02:51 PM
NOTW_WJ
Member
2004 WJ 
 
Join Date: Jan 2013
Location: Orange County
Posts: 201
[/QUOTE]Then picked up this to replace the 231hd that I just built lol
[/QUOTE]

Are You Interested In Selling It? My 231 Is Dying And I Was Looking To Rebuild It Into A HD.
NOTW_WJ is offline  
post #26197 of 43274 Old 11-29-2013, 03:08 PM
TJSWJ
Registered User
2001 WJ 
 
Join Date: Mar 2010
Location: Olmsted Falls
Posts: 2,271
Then picked up this to replace the 231hd that I just built lol
[/QUOTE]

Are You Interested In Selling It? My 231 Is Dying And I Was Looking To Rebuild It Into A HD.[/QUOTE]

Yes I will be selling it. I want to put a couple miles on it first though just to make sure everything is good.

Its a 231hd originally out of a durango. I put all new bearings and seals in it. Procomp sye kit, terra 2wd low kit, brand new chain (wide chain), and a brand new 6 pinion planatery set in it.

I think I have some pics in my build thread if you want to check it out.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TJSWJ is offline  
post #26198 of 43274 Old 11-29-2013, 04:02 PM
Jaketit
Registered User
2002 WJ 
 
Join Date: Mar 2011
Location: Port St. Lucie
Posts: 867
Changed the oil out today in the old girl. Refilled with Mobil 1 high mileage and boch filter. I had 20points on the autozone card so why not. And I always seem to spill oil NO MATTER WHAT!!! But it gave me a chance clean up the jewel box a little. Lol

Name:  image-3230691009.jpg
Views: 267
Size:  417.3 KB
Jaketit is offline  
post #26199 of 43274 Old 11-29-2013, 05:28 PM
vanillathrilla
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2010
Location: Roanoke, VA
Posts: 2,345
Getting quite frustrated from the car lot we got her WJ from..

We finally dropped the car off today to fix a few things that were issues when we bought it. The drivers side door panel was loose and caused the rubber window seal to get sucked down into the door frame when you put the window down. As far as I know, that friction against the glass will eventually kill the window motor or window regulator perhaps? Small fix, and surely something I could probably fix myself, but it's the principal of the matter. They agreed to fix it.

Then there was an issue where the car overheated on her once. It's been smoking a little bit lately, so that was a high priority to find out what was going on with it. It's only overheated once, but once is one too many times for me. Turns out they said the radiator had a big hole in it and the mechanic was telling me the radiator support was tweaked and the front end must have been hit at some point in time.. Told me he had to straighten it back out before he could drop the new radiator in. All is fine and well with that, and I didn't throw a fit about having to pay for it, although I'm certain it was that way when we bought it. I'm concerned that a shady mechanic may have used Stop Leak or something in the radiator to prevent it from being an issue until it was in our hands and our own problem. I know small shops and probably even big dealerships have practices like that from time to time. Whatever... No problem. We paid for it and apparently now have a new radiator.

The third issue was that it was having trouble starting. It will always start, but it has to turn over way too many times to be normal. You have to hold the key for a second while it's cranking to get it to start up. That sounds like a fuel issue to me, but I'm not a mechanic. Anyway, talked to the lot right after buying it, and he said they had just put a fuel pump in it recently before we bought it, and that they apparently didn't do a fuel filter. He agreed to have the fuel filter put in for us and that would surely resolve the hard start issue.

Well, here's my problem... Despite replacing all the clips and repositioning the window molding and whatever else he said he did, it still does it. It's more aggravating than anything because it was supposed to be fixed. They kept the car all day long. But wait, it gets better! It still hard starts!!!

Any input???

'99 TJ Sport | Rampage Frameless | 33x12.50x15 Goodyear MTR/K's | Poweraid TBS | Flowmaster 40 series | Herculined | 15% tint | LED interior lighting | AtoZ front/rear bumper | AtoZ tube rocker guards | Kenwood Excelon KDC-X993BT | Kicker 6.5's in soundbar | Alpine Type-R 4x6's in dash.
vanillathrilla is offline  
post #26200 of 43274 Old 11-29-2013, 05:40 PM
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 988
Found my noise! TC side of front drive shaft. Replaced with a rebuild kit and waiting for a warm spell to put it back in.
roadcrew is offline  
post #26201 of 43274 Old 11-29-2013, 06:27 PM
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 988
Found my noise! TC side of front drive shaft. Replaced with a rebuild kit and waiting for a warm spell to put it back in.

Grrr. I'm incapable of posing properly. Where's the pic?
Found it.
roadcrew is offline  
post #26202 of 43274 Old 11-29-2013, 06:30 PM
vanillathrilla
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2010
Location: Roanoke, VA
Posts: 2,345
How did you manage to post that a second time like 45 minutes later? lol!

'99 TJ Sport | Rampage Frameless | 33x12.50x15 Goodyear MTR/K's | Poweraid TBS | Flowmaster 40 series | Herculined | 15% tint | LED interior lighting | AtoZ front/rear bumper | AtoZ tube rocker guards | Kenwood Excelon KDC-X993BT | Kicker 6.5's in soundbar | Alpine Type-R 4x6's in dash.
vanillathrilla is offline  
post #26203 of 43274 Old 11-29-2013, 06:41 PM
pyre24
Registered User
2000 WJ 
 
Join Date: Jan 2013
Location: sterling
Posts: 370
Quote:
Originally Posted by wjidaho View Post
Took mine; Over the river, thought the woods, to grandmas house we go lol. Then after that stopped by my best friends, dropped a pie off and he gave me this for my late birthday present Man is such a artist, can't wait till we build my bumpers ;-)
That is awesome. Love it.
pyre24 is offline  
post #26204 of 43274 Old 11-29-2013, 08:01 PM
joshtarmy1
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Auburn
Posts: 49
On my WJ that ground strap goes to the bolt holding the coil on cylinder 7
joshtarmy1 is offline  
post #26205 of 43274 Old 11-29-2013, 08:01 PM
TwinchargedRX7
Registered User
2002 WJ 
 
Join Date: Sep 2012
Location: Lyndhurst
Posts: 87
Yesterday I changed the plugs and changed the last evap hose by the rear axle and the CEL finally went away.

Today I tried to get the airbag light to go away by swapping the clock spring with a used one. Unfortunately the problem didn't go away so either the used clock spring was junk or there is something else wrong.

Next on the list:
Tires
Alignment and hopefully fix my clunk (I think the jus track bar bushings, but also have some kind of clunk in the rear)
New petcock for radiator drain (it's slowly dripping)
Change oil
TwinchargedRX7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 4 (2 members and 2 guests)
Davy120 , LeakinOil
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Just got my xenon on today ! unbelivable ! gaignstar WJ Grand Cherokee Forum 10 11-19-2016 08:04 AM
Tried to do Spark Plugs today in the 4.7--Didn't happend Astorm WJ Grand Cherokee Forum 43 03-24-2014 09:35 PM
Died today... jimbo141 WJ Grand Cherokee Forum 28 05-09-2011 09:20 PM
I want to order some brakes today matrix849 WJ Grand Cherokee Forum 30 07-25-2010 02:01 AM
found an ad today KI4KWF WJ Grand Cherokee Forum 3 07-30-2007 01:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome