What did you do to your WJ today? - Page 1647 - JeepForum.com

 244Likes
 
LinkBack Thread Tools
post #24691 of 41993 Old 09-22-2013, 09:22 PM
scross1220
Member
 
scross1220's Avatar
2012 WK 
 
Join Date: Mar 2013
Location: Linden
Posts: 477
Completed my hitch install today with the electrical and electronic brake system. Getting ready to pull our first camper trailer next month

Attached Images
 


______ooooo
/__l_l_,\____\,___
l_---l_l__l---[o]llllll[o]
_.(o)_)__(o)_)--o-)_)


If you're not fixing it, you're not driving a Jeep.
scross1220 is offline  
Sponsored Links
Advertisement
 
post #24692 of 41993 Old 09-23-2013, 03:48 AM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 7,835
Got papers/documents from wrecker today, licence plates delivered to Norwegian car autorithy office, and reciepts for both send to adjuster man, now just waiting for insurance papers,,,,

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is online now  
post #24693 of 41993 Old 09-23-2013, 03:49 AM
Trxgedy
Registered User
 
Join Date: Jan 2013
Posts: 281
Nothing yet, shes just sitting pretty in the parking lot

Trxgedy is offline  
post #24694 of 41993 Old 09-23-2013, 06:17 AM
dadamets
Registered User
2002 WJ 
 
Join Date: May 2013
Location: Lewis Center
Posts: 147
Woke up Sunday morning and installed an Avital 4103 remote start system. After I got over my fear of cutting into the wiring harness (about an hour of rereading the directions several times) it wasn't too bad.
Attached Images
 
dadamets is offline  
post #24695 of 41993 Old 09-23-2013, 08:10 AM
bgohsman
Registered User
1999 WJ 
 
Join Date: May 2009
Location: Grand Rapids
Posts: 241
Wj

Quote:
Originally Posted by Jaspah View Post
Yep, I had the same problem. Previous owner let them corrode really bad to the point where it wasn't removable.

Picked up a few cans of Plastidip and couldn't be happier.



Yeah, I was a bit surprised at my own reaction of just how happy I was. That satin matt black look goes so much better with the Jeep than shiny aluminum. I knew I'd like it, but I really, really like it. lol


Brandon Gohsman
bgohsman is offline  
post #24696 of 41993 Old 09-23-2013, 08:39 AM
mdrum93
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Lexington <> Boone
Posts: 430
Just thought my jeep looked beautiful in the parking lot this morning..not bragging, just love my baby! (Maybe bragging a little)
Attached Images
 
mdrum93 is offline  
post #24697 of 41993 Old 09-23-2013, 09:22 AM
flightmedic238
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Saugerties
Posts: 127
For breakfast i finally decided to get off my a$$ and throw in the BB lift. Glad I did looks much better to me!!


Name:  image-3008952850.jpg
Views: 451
Size:  519.8 KB



Name:  image-55208616.jpg
Views: 452
Size:  491.0 KB
flightmedic238 is offline  
post #24698 of 41993 Old 09-23-2013, 10:47 AM
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA
Posts: 2,177
Quote:
Originally Posted by flightmedic238 View Post
For breakfast i finally decided to get off my a$$ and throw in the BB lift. Glad I did looks much better to me!!


Attachment 701289



Attachment 701297
what tires are they ??
and what lift ??

QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline  
post #24699 of 41993 Old 09-23-2013, 11:19 AM
flightmedic238
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Saugerties
Posts: 127
Quote:
Originally Posted by wsar10
what tires are they ?? and what lift ??
Goodyear dura trac's and a 2" BB lift
flightmedic238 is offline  
post #24700 of 41993 Old 09-23-2013, 01:40 PM
Big_Wall
Registered User
2010 JK Wrangler 
 
Join Date: Sep 2013
Location: Englewood
Posts: 48
Replaced my front sunroof drains. I took pics and will do a write up sometime. Once I can quit throwing money at my Jeep I can pay for a membership here
Big_Wall is offline  
post #24701 of 41993 Old 09-23-2013, 02:15 PM
whorunit1475
Registered User
 
Join Date: Oct 2012
Posts: 119
Not from today but over the past 2 months:

-new goodyear tires
-led tail lights
-new headlight housing
-crank sensor
-fan relay

-need a transmission service as well
whorunit1475 is offline  
post #24702 of 41993 Old 09-23-2013, 02:29 PM
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA
Posts: 2,177
Quote:
Originally Posted by flightmedic238 View Post
Goodyear dura trac's and a 2" BB lift
I figured that much !!

QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline  
post #24703 of 41993 Old 09-23-2013, 03:14 PM
jpat30
Registered User
 
Join Date: Sep 2012
Location: Groves
Posts: 506
Quote:
Originally Posted by Mav-Jason View Post
VERY NICE MAN!!!

That's the stance I'm goin for as well, looks great.
Sir Cuss,

What size KM2 are you running on those soft 8s? Thanks.

-Carpe Diem Phil 1:20
jpat30 is offline  
post #24704 of 41993 Old 09-23-2013, 03:44 PM
jpat30
Registered User
 
Join Date: Sep 2012
Location: Groves
Posts: 506
Quote:
Originally Posted by BigAl63 View Post
Started the bb install. Got the front on and realized I must have some serious sag going on. It's now level with 2" spacers on the front! I don't guess there's any problem leaving it like this is there?

Before and after:

Thanks to jpat30!
Glad they made it to you safe and sound. Your rig looks great and yeah you could leave it like that. In essence, you are running a leveling kit. Enjoy!

-Carpe Diem Phil 1:20
jpat30 is offline  
post #24705 of 41993 Old 09-23-2013, 07:32 PM
atinari
Registered User
1999 TJ Wrangler 
 
Join Date: Jan 2012
Location: Philadelphia
Posts: 234
Drove it to school today 50+ mph no front or rear swaybars connected but we were fine.

Ps sick of these small dubs i wanna see some BEEF.

Also the Jeff Daniels annual jeep show is on the 29th in Harleysville Pennsylvania. Last year there was only one wj. Its a really neat event and they have a sick course. My jeep doesnt want to be lonely. #wjmovement
atinari is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
big98tnzj
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Tried to do Spark Plugs today in the 4.7--Didn't happend Astorm WJ Grand Cherokee Forum 43 03-24-2014 08:35 PM
Died today... jimbo141 WJ Grand Cherokee Forum 28 05-09-2011 08:20 PM
I want to order some brakes today matrix849 WJ Grand Cherokee Forum 30 07-25-2010 01:01 AM
found an ad today KI4KWF WJ Grand Cherokee Forum 3 07-30-2007 12:27 AM
Just got my xenon on today ! unbelivable ! gaignstar WJ Grand Cherokee Forum 8 05-12-2002 08:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome