What did you do to your WJ today? - Page 1646 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 09-22-2013, 08:33 AM   #24676
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA, PA
Posts: 2,115
Quote:
Originally Posted by Trxgedy View Post
Ill have to take the das apart for that so ill check that later. I hav to ge some sleep I work 7pm-7am. Came home hoping to get this done. But ill do it when I wake up before work
C1 is a connector indicator.......... (BCM connector)

BUT the breaker you speak of is within the "junction block" and can be tested for power at pin 9 of "C2" which is the junction block connector.

This circuit breaker is the power for the coil side of the relay, and the coil gets its ground from pin 22 of teh BCM.........

Maybe you should start a new thread and we can work through this, its probably quite simple and very easy to troubleshoot. its power, switch, Relay, Motor !

__________________
QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline   Reply With Quote
Unread 09-22-2013, 09:42 AM   #24677
bgohsman
Registered User
1999 WJ 
 
Join Date: May 2009
Location: Grand Rapids, MI
Posts: 229
Plasti-Dipped my aluminum wheels. They were oyster shelled and the clear coat was stained in several places. Even after power washing them, cleaning them by hand and de-greasing them with Zylene, they still looked like crap. I'm amazingly happy with how they turned out. First time I've used Plast-Dip.
image-4196748950.jpg

image-1938737698.jpg

image-945670918.jpg

__________________
Brandon Gohsman
bgohsman is offline   Reply With Quote
Unread 09-22-2013, 09:56 AM   #24678
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,383
Hammer on wheel weights FTL. Should have had a local shop replace them with stick on weights before you dipped them.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote
Unread 09-22-2013, 10:29 AM   #24679
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,804
Quote:
Originally Posted by wjidaho View Post
Headed out to wheel ;-) night wheeling is so fun when you got six kc daylighter's lighting your way :-D
Now change them to run HID's in all of them and see what kind of output you get!

I have 4 sets running now. Quad retro, fogs and the WARN's I changed. Still have my rack lights which will add another 2 sets of HID's but haven't hooked them up at all as really not needed. But will eventually just cause they're there!
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote
Unread 09-22-2013, 10:47 AM   #24680
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,804
Quote:
Originally Posted by 03azwj View Post
Well after a little over a year its starting to overheat. I just replaced fan relay and thermostat and it will still climb to 260 when idling and no tow package.
Sounds like something else is going on. Adding another fan will only bandaid the issue. Relay and thermostat are done, so should rule those out as the issue. First question is was the system bled properly. Air trapped can be an issue. Also the waterpump could be an issue itself. This is of course that the fan is ok.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote
Unread 09-22-2013, 11:34 AM   #24681
03azwj
Registered User
2003 WJ 
 
Join Date: Aug 2012
Location: Prescott, AZ
Posts: 479
Quote:
Originally Posted by cykaaro

Sounds like something else is going on. Adding another fan will only bandaid the issue. Relay and thermostat are done, so should rule those out as the issue. First question is was the system bled properly. Air trapped can be an issue. Also the waterpump could be an issue itself. This is of course that the fan is ok.
Well I do know I need to replace the water pump. That will be the first thing...for now. And then I'll go from there.
__________________
3" OME HD springs, Bilstein 5100, JKS adjustable trackbar, Moog SS, IRO UCA'S & LCA'S, 3/4" front and rear spacers, BFG M/T km LT255/75R17, JK Rubicon takeoffs, 8K HIDS Hi's & Lo's. full Rockford Fosgate set-up, blue l.e.d. interior, clumsy driver
03azwj is offline   Reply With Quote
Unread 09-22-2013, 11:43 AM   #24682
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,804
Once you do make sure you get the air bled out. Hopefully it'll solve the issue.

As for doing anything on mine today, nope. Need to switch out the rear springs but too damn sick. Instead hacking up a lung or two.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote
Unread 09-22-2013, 11:56 AM   #24683
03azwj
Registered User
2003 WJ 
 
Join Date: Aug 2012
Location: Prescott, AZ
Posts: 479
Quote:
Originally Posted by cykaaro
Once you do make sure you get the air bled out. Hopefully it'll solve the issue.

As for doing anything on mine today, nope. Need to switch out the rear springs but too damn sick. Instead hacking up a lung or two.
Ok thanks. Rock auto has the pump for 35 or so and says it includes the gasket.
__________________
3" OME HD springs, Bilstein 5100, JKS adjustable trackbar, Moog SS, IRO UCA'S & LCA'S, 3/4" front and rear spacers, BFG M/T km LT255/75R17, JK Rubicon takeoffs, 8K HIDS Hi's & Lo's. full Rockford Fosgate set-up, blue l.e.d. interior, clumsy driver
03azwj is offline   Reply With Quote
Unread 09-22-2013, 12:02 PM   #24684
Jaspah
Registered User
2002 WJ 
 
Join Date: Oct 2012
Location: Hamilton, NY
Posts: 236
Quote:
Originally Posted by bgohsman View Post
Plasti-Dipped my aluminum wheels. They were oyster shelled and the clear coat was stained in several places. Even after power washing them, cleaning them by hand and de-greasing them with Zylene, they still looked like crap. I'm amazingly happy with how they turned out. First time I've used Plast-Dip.
Yep, I had the same problem. Previous owner let them corrode really bad to the point where it wasn't removable.

Picked up a few cans of Plastidip and couldn't be happier.



Jaspah is offline   Reply With Quote
Unread 09-22-2013, 12:02 PM   #24685
Linus
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Birmingham, AL
Posts: 454
Replaced the transfer case fluid, wish all the maintenance on the WJ was that easy.
__________________
04 WJ - 4.0L and Selec-Trac
BDS 2", 3/4" spacers, Bilstein 5100, and 31" General Grabber AT2's
Build Thread
Linus is offline   Reply With Quote
Unread 09-22-2013, 12:41 PM   #24686
zephyr80
Registered User
2000 WJ 
 
Join Date: Aug 2012
Location: keizer, Oregon
Posts: 380
Loaded her up to go to the dump today, and it was the first time i got to use the winch!!!

Sent from your back seat!!!
_conv_2013-09-22-09.00.11.jpg

zephyr80 is offline   Reply With Quote
Unread 09-22-2013, 02:02 PM   #24687
flightmedic238
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Saugerties, NY
Posts: 127
Quote:
Originally Posted by BigAl63
Started the bb install. Got the front on and realized I must have some serious sag going on. It's now level with 2" spacers on the front! I don't guess there's any problem leaving it like this is there? Before and after: Thanks to jpat30!
I may do the same to mine. I have the BB in the garage. I'll have to see how mine looks with just the fronts. I don't see an issue leaving it like that. Looks much better!!
flightmedic238 is offline   Reply With Quote
Unread 09-22-2013, 02:31 PM   #24688
bcvetter
Registered User
2004 WJ 
 
Join Date: May 2013
Location: acworth, ga
Posts: 169
Put some mopar hooks on. Took less that 45 mins to do.
bcvetter is offline   Reply With Quote
Unread 09-22-2013, 04:10 PM   #24689
StormChaserTim
Registered User
2000 WJ 
 
Join Date: Sep 2013
Location: Wichita, KS
Posts: 113
Cleaned!

Still didn't come out good, the paint is pretty trashed out. Lots of places where sap and bug guts have ate the paint off. But, all shined up, I don't think it looks bad for an $1800 car.






Tim
__________________
2000 Grand Cherokee Limited 2wd, 4.7L V8 - It's blazing fast, blue, and the heap of Jeep.
2002 Dodge Ram Quad Cab 2wd, 4.7L V8 - Hailstoned, windshield cracked, storm chasin' truck. But dependable.
StormChaserTim is offline   Reply With Quote
Unread 09-22-2013, 04:46 PM   #24690
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,023
Quote:
Originally Posted by StormChaserTim View Post
Cleaned! Still didn't come out good, the paint is pretty trashed out. Lots of places where sap and bug guts have ate the paint off. But, all shined up, I don't think it looks bad for an $1800 car. Tim
Looks nice and shiny to me.

Sent from my iPad using my fingers
rdkendrick is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.