What did you do to your WJ today? - Page 1546 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

FS: Wranger BRIGHT License Plate LED! Just $3! Great valuePANDEMIC-USA 50" Double row LED LIGHT BAR!! These thiFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 07-31-2013, 09:49 PM   #23176
kaestacrunch
Registered User
2002 WJ 
 
Join Date: Aug 2012
Location: Salt Lake City, Utah
Posts: 351
Quote:
Originally Posted by doorjamm

That's looking sexy man! And the Fawkes bull bar mount with shackles is so good looking. my favorite looking WJ that has a minor lift man
Wow, thank you! =D

kaestacrunch is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 07:15 AM   #23177
wschilawski
Registered User
2002 WJ 
 
Join Date: Sep 2011
Location: Green Bay, WI
Posts: 187
Quote:
Originally Posted by wjidaho

I am thinking of doing the same thing with mine good looking rig like the color :-)
Thanks! Yeah, the cut was fairly easy with the Dremel.

Sent from my iPhone using JeepForum
__________________
Current Build | 08 JKU Sahara
Previous Build | 02 WJ | 2" BDS Lift
wschilawski is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 11:52 AM   #23178
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony, TX
Posts: 110
Fixed my transmission (cooler lines) leak last week, replaced the driver's window regulator last night... Still need to get back under there and readjust the trackbar - need to grab a ratcheting strap and move the chassis about a 1/2" or so, the axle's not centered very well at the moment.

Also need to get some brake cleaner and see if it'll take the ATF off my passenger front brake pads. It's a bit disconcerting when the WJ pulls to the left if I brake hard at anything over 25mph!

I like that baja cut... May give that a shot since the dude on here I was trying to buy the Iceland bumper from flaked out (after giving me the runaround for 2+ months)... At least I got my money back, I guess...
SirCussFreq is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 11:56 AM   #23179
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony, TX
Posts: 110
Quote:
Originally Posted by wschilawski View Post
I'm also trying to find my "over a bump" grinding noise coming from the rear axle...
Please let me know if you figure this out! Since the lift, I get a grinding / rubbing noise on medium sized bumps, but I can't figure out where it's coming from. Nothing seems to be touching or rubbing. Planning on crawling under and having a friend jump up and down on the bumper when I get the chance, maybe I'll see some clearance issue that's not immediately apparent.
SirCussFreq is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 11:59 AM   #23180
wschilawski
Registered User
2002 WJ 
 
Join Date: Sep 2011
Location: Green Bay, WI
Posts: 187
Quote:
Originally Posted by SirCussFreq View Post
Please let me know if you figure this out! Since the lift, I get a grinding / rubbing noise on medium sized bumps, but I can't figure out where it's coming from. Nothing seems to be touching or rubbing. Planning on crawling under and having a friend jump up and down on the bumper when I get the chance, maybe I'll see some clearance issue that's not immediately apparent.
I'll be tightening everything down before the trails on Saturday - mine sure sounds like the splines on the axle shaft grind once in awhile - not saying that that's it, but that is what is sounds like.
__________________
Current Build | 08 JKU Sahara
Previous Build | 02 WJ | 2" BDS Lift
wschilawski is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 12:18 PM   #23181
brouwmat
Registered User
2002 WJ 
 
Join Date: Nov 2006
Location: Sioux Falls, South Dakota
Posts: 1,277
Quote:
Originally Posted by SirCussFreq
Fixed my transmission (cooler lines) leak last week, replaced the driver's window regulator last night... Still need to get back under there and readjust the trackbar - need to grab a ratcheting strap and move the chassis about a 1/2" or so, the axle's not centered very well at the moment.

Also need to get some brake cleaner and see if it'll take the ATF off my passenger front brake pads. It's a bit disconcerting when the WJ pulls to the left if I brake hard at anything over 25mph!

I like that baja cut... May give that a shot since the dude on here I was trying to buy the Iceland bumper from flaked out (after giving me the runaround for 2+ months)... At least I got my money back, I guess...
No need for the ratchet strap.. Just straighten the wheels, disconnect your trackbar, start the engine, turn your steering wheel back and forth. The whole front end will shift back and forth. Center it, turn the engine off, adjust your trackbar and bolt it up.. voila! Go have a beer and act like it was a huge job and very difficult!
brouwmat is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 01:01 PM   #23182
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony, TX
Posts: 110
Psh... Who waits until AFTER a job is done for a beer? Cool, I'll see if that helps. We had it adjusted to what we thought was the proper length, but the suspension wasn't under load at the time. Turns out, we were off...
SirCussFreq is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 02:59 PM   #23183
CrazyWalnut13
Registered User
2000 WJ 
 
Join Date: Jan 2007
Location: Bozeman, MT
Posts: 1,282
FINALLY got around to taking care of my RR axle bearing. That thing was leaking for at least 8 months that I know about. I only put about 1000 miles on the Jeep since I found the leak. But, since I sold my DD and I'll be towing a ~4k lb trailer 700miles in a week (or maybe less), I figured I had to take care of it now.

Popped it out on Tuesday, and dropped it off at Randy's Ring & Pinion in Everett. Got it back Wednesday, put it back in and drained the diff fluid and put the cover back on. Then today filled the diff and test drove. I'm amazed at how much noise that rear end was making (yes I'm aware that will be quoted out of context). When I drained the diff, it only had about have the fluid that it should have. I guess the leak was pretty bad and/or going on for longer than I thought. Now I'm on to finding what's making noise in the front end. I know the CVs on the front DS need to be replaced, I think my TC has a problem (play in the front output shaft), and I'm pretty sure my front wheel bearing are starting to go(no play in them yet, but the noise sounds a lot like those front bearings). I'll take care of that little by little when I have some spare time/money.


Also, I have to give major thumbs up to Randy's. They're booked solid through next week, I explained to them that I was moving in a week and NEEDED the bearing done before then. They said if I popped out the axle shaft and brought it to them, they'd probably be able to have someone fix it in the next day or 2 if they got time, and I'd be saving a ton of money by doing the labor myself. I dropped it off Tuesday night as they were closing, and got a call at noon on Wednesday saying it was done. These guys saved me A LOT of headache.
__________________
Zak
Formerly Default Jeeper #13
2000 WJ Limited 4.7 with stuff. Look left for the deets.
CrazyWalnut13 is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 04:48 PM   #23184
HiPERnx
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: Tyresö, Sweden
Posts: 140
Took it for some offroding and on my way home i tested the top speed, it was just above 200 km/h ( ~124mph). Felt kind of bad pushing my 4.7 so hard
HiPERnx is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 05:03 PM   #23185
99WJ539918
Registered User
1999 WJ 
 
Join Date: Aug 2008
Location: , Northern New Jersey
Posts: 2,011
Quote:
Originally Posted by HiPERnx View Post
Took it for some offroding and on my way home i tested the top speed, it was just above 200 km/h ( ~124mph). Felt kind of bad pushing my 4.7 so hard
I hope this was on a closed/private road where you only put yourself in danger.


I got the brackets in the mail today for my brush guard. I removed the front bumper cover and then it started to rain. I guess I'll be trying to finish it up tomorrow.
99WJ539918 is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 05:43 PM   #23186
JRobes
Registered User
2004 WJ 
 
Join Date: Apr 2011
Location: , SD
Posts: 481
I did this... 2013 rubi takeoffs
wp_000342.jpg

wp_000348.jpg

__________________
2004 WJ Overland, 4.7HO, Quadradrive, 3" OME HD/Bilstein lift
1999 Honda Magna VF750C
JRobes is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 05:46 PM   #23187
Zacedward
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Midvale, Utah
Posts: 706
Quote:
Originally Posted by JRobes View Post
I did this
Nice what size of lift
__________________
UJC #181 2004 jeep Grand Cherokee 4.7L v8, 2"bb, kolak 3 " exhaust flowmaster 50 SUV , Rola roof basket, k&n cai,245/75 /16 A/T
Zacedward is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 06:04 PM   #23188
cr8zynelly
Registered User
2002 WJ 
 
Join Date: May 2013
Location: Wilmette, IL
Posts: 826
Quote:
Originally Posted by JRobes
I did this... 2013 rubi takeoffs
Where's the rails??
cr8zynelly is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 06:07 PM   #23189
JRobes
Registered User
2004 WJ 
 
Join Date: Apr 2011
Location: , SD
Posts: 481
Quote:
Originally Posted by cr8zynelly View Post
Where's the rails??
rusted through and sitting in my garage waiting for me to either sell them or patch them
__________________
2004 WJ Overland, 4.7HO, Quadradrive, 3" OME HD/Bilstein lift
1999 Honda Magna VF750C
JRobes is offline   Reply With Quote Quick reply to this message
Unread 08-01-2013, 06:09 PM   #23190
gcjeeping
Web Wheeler
 
gcjeeping's Avatar
2001 WJ 
 
Join Date: Feb 2007
Location: -----Sacramento-----, USAF RETIRED 462X0
Posts: 3,663
Quote:
Originally Posted by cykaaro View Post
Hopefully won't be too much longer until you can get it in and running again!
Quote:
Originally Posted by doorjamm View Post
She's in storage as of last night. Had nowhere else to put her and now I have to pay monthly. I just hope she's safe, I'd hate for my light bar and stuff to get stolen by someone who wants it. Hopefully I can figure out my motor situation sooner than later
Sorry I couldnt help ya out with storage. Still have to get together.


.
__________________
__________________________________________________ _________

-GCJEEPING's build/mod thread-IT'S A GREEN THING...
gcjeeping is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.