What did you do to your WJ today? - Page 1419 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > What did you do to your WJ today?

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 05-22-2013, 04:01 PM   #21271
roadcrew
Registered User
1999 WJ 
 
Join Date: Sep 2010
Location: chicago, 60641
Posts: 939
Quote:
Originally Posted by gtg413i View Post
^^^^ Jeeps are very funny and jealous- don't let the Misses drive it or something will go wrong. After my wife was driving it home when the engine seazed, she doesn't even like to ride in it anymore.
Funny. I tell the wife that too.
She gets out and slams the door, and the jeep makes funny noises as I back in my parking spot.
I tell her the mistress disapproves of the rough treatment.

roadcrew is offline   Reply With Quote
Unread 05-22-2013, 04:16 PM   #21272
ZB_WJ
Registered User
2004 WJ 
 
Join Date: Mar 2011
Location: Columbia, Missouri
Posts: 2,998
My wife has wrecked or caused damage to everyone of my vehicles. She won't even drive it anymore because everyone she does something happens
__________________
I think we all just need a beer. :cheers2: (courtesy of ChrisHager)

This forum is a double edge blade, it's saved me thousands in repairs and cost me thousands in mods
ZB_WJ is offline   Reply With Quote
Unread 05-22-2013, 04:18 PM   #21273
madslynge87
Registered User
2000 WJ 
 
Join Date: Mar 2010
Location: Nuuk
Posts: 160
Quote:
Originally Posted by BigWheel7
Anybody have any ideas why the sunroof wouldn't be closing? Opened it today heading to work and when I got to work I went to close it and nothing at all. Wouldn't move at all and can't figured out why it wont.
Blown fuse ?
madslynge87 is offline   Reply With Quote
Unread 05-22-2013, 04:31 PM   #21274
BigWheel7
Registered User
1999 WJ 
 
Join Date: Oct 2011
Location: Brazil, IN
Posts: 397
Quote:
Originally Posted by madslynge87 View Post
Blown fuse ?
I thought about that and need to look once I get off work. Didn't know if there was anything else to look for that might of caused it.
BigWheel7 is offline   Reply With Quote
Unread 05-22-2013, 06:32 PM   #21275
pinky2252s
Registered User
2001 WJ 
 
Join Date: Oct 2011
Location: Broomfield, Colorado
Posts: 1,825
Changed the oil. 3 oil changes ago I switched to synthetic and was loosing a lot of oil. This oil change, im at about 5 quarts that came out of the pan. Figuring that there is about a quart sitting in the engine, we should be good. I wouldn't be surprised that this car is burning a little bit of oil, it has 125,000 on it. I am still going to do a compression test to make sure my piston rings are okay. And for peace of mind...

I also drained my coolant and refilled with G05. Had a little bit of a problem with air in the system (no heat) but after a few heat and cool down cycles and messing with the radiator cap and bleeder valve its all good and the upper hose is hard. She runs about 10 degrees cooler than before!
__________________
Is it broken?

Colorado Jeep Club Member #2252
2001 Laredo, 2004 Special Edition
pinky2252s is offline   Reply With Quote
Unread 05-22-2013, 07:23 PM   #21276
fast540
Registered User
1999 WJ 
 
Join Date: Aug 2012
Location: rohnert park, ca
Posts: 1,534
Just replaced the passenger front axle cus I destroyed the joint camping this weekend. I guess it was bad for awhile cus this strange rattle is gone now too
fast540 is offline   Reply With Quote
Unread 05-22-2013, 08:20 PM   #21277
wconkle
Registered User
2004 WJ 
 
Join Date: Oct 2011
Location: Harvest, AL
Posts: 42
I completed installation of an IRO 3 inch and put on a set of tires that I found on Craigslist.
keep-02.jpg  
wconkle is offline   Reply With Quote
Unread 05-22-2013, 08:37 PM   #21278
David5534
Registered User
2008 MK Patriot 
 
Join Date: Apr 2013
Location: Forest Hill, Maryland
Posts: 48
friend came over and helped put a new passenger rear lock actuator in. no more screech when I hit the unlock button. makes me very happy
David5534 is offline   Reply With Quote
Unread 05-22-2013, 08:48 PM   #21279
PhantomWJ
Registered User
2003 WJ 
 
Join Date: Jan 2010
Location: IE
Posts: 3,221
Quote:
Originally Posted by TJSWJ View Post

yesterday,I got my hydro assist setup in the mail..... Well, half of. It was re-boxed quite nicely, and inside the nice box were a steering gear box and a couple hydraulic hoses that have big gashes in them down to the steel cord. Also the ram, along with the mounting tabs were completely gone. In their place was instead a little note from USPS saying that my item was damaged during shipping and if I had insurance I need to contact them reguarding the matter.... FML! At least it was insured. But now I get to spend my lunch break batteling it out with the post office.

After that I locked my self out of work after putting a new wheel bearing in the silverado, had to wait there for someone to come and let me back in.

Since I had the silverado, my fiance was driving the jeep, no big deal right? Well apparently it was, even though the only place she drove it was around my complex because my daughter wanted a jeep ride. I come home to see it sitting with a nice lean to the passenger rear. Look, and sure enough the tire is completely flat! I go up stairs and ask what she did, "nothing, just drove around why?" FML #2! How the hell do you put a 1/4 in whole between the lugs, on a near new MTR'K? Looks like Ill be ordering another one of those next time I have some spare cash. Ive seen patches do wonderful things, but this is a massive hole!

Well, I sure as hell wasnt going to change a flat tire first thing in the morning, so I decide to tackle it tonight. Of course, my 2 year old (who is sick by the way) wanted to help dad, and of course I let her. I went out to change the tire and everything was going great. That is until she decided she wanted to help dad with the jack, and bent down to grab the handle and didnt realize how close her head was to the steal bumper. BONK! My 2 year old changed her first jeep tire today, and now has a goose egg on her forehead to prove it. FML #3

The whole situation sucks. I hope having insured the package results in compensation from USPS.
PhantomWJ is offline   Reply With Quote
Unread 05-22-2013, 08:49 PM   #21280
SuperStew11
Registered User
2000 WJ 
 
Join Date: Mar 2013
Posts: 183
Put a brand new brake caliper on.......but still haven't fixed my clunking/pulsing issue
SuperStew11 is offline   Reply With Quote
Unread 05-22-2013, 09:27 PM   #21281
charleswilson90
Registered User
2003 WJ 
 
Join Date: Nov 2012
Location: Colorado Springs, Colorado
Posts: 24
Finally finished the tank tuck!!! There is so much room now!
charleswilson90 is offline   Reply With Quote
Unread 05-22-2013, 09:28 PM   #21282
wjidaho
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: boise, id
Posts: 2,026
Quote:
Originally Posted by charleswilson90
Finally finished the tank tuck!!! There is so much room now!
You know the rules pics man pics lol
__________________
[SIZE="4"][url=http://www.exiledoffroad.com]EXILED OFFROAD[/url][/SIZE]

My build thread
[url]http://www.jeepforum.com/forum/f22/wjidahos-expedition-build-1904282/[/url]
wjidaho is offline   Reply With Quote
Unread 05-22-2013, 09:37 PM   #21283
charleswilson90
Registered User
2003 WJ 
 
Join Date: Nov 2012
Location: Colorado Springs, Colorado
Posts: 24
Quote:
Originally Posted by wjidaho View Post
You know the rules pics man pics lol
Yeah I know, pics or it didn't happen. I try to post pics of my stuff all the time but I don't know how to shrink the file so it will let it post
charleswilson90 is offline   Reply With Quote
Unread 05-22-2013, 09:45 PM   #21284
charleswilson90
Registered User
2003 WJ 
 
Join Date: Nov 2012
Location: Colorado Springs, Colorado
Posts: 24
Lets try this...
img_0369.jpg  
charleswilson90 is offline   Reply With Quote
Unread 05-22-2013, 09:53 PM   #21285
wjidaho
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: boise, id
Posts: 2,026
Quote:
Originally Posted by charleswilson90
Yeah I know, pics or it didn't happen. I try to post pics of my stuff all the time but I don't know how to shrink the file so it will let it post
Yeah it sucks now my iPhone dose it on its own, in the Fourm settings, someone should do a write up on it
__________________
[SIZE="4"][url=http://www.exiledoffroad.com]EXILED OFFROAD[/url][/SIZE]

My build thread
[url]http://www.jeepforum.com/forum/f22/wjidahos-expedition-build-1904282/[/url]
wjidaho is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.