What did you do to your WJ today? - Page 1141 - JeepForum.com

 384Likes
 
LinkBack Thread Tools
post #17101 of 42811 Old 02-03-2013, 02:53 PM
PAJeep6
Registered User
2002 WJ 
 
Join Date: Nov 2012
Location: Williamsport
Posts: 234
Installed a new CD player in my WJ today. Completed the install, but didn't buy an antenna adapter, so I had to run back to the stereo shop. All good now. Next weekend maybe I can finally install my sub and amp.


02 WJ - 4.7 | Black Rocks | 33" Treadwright Guard Dogs | 3" exhaust | 4" RC LA lift...
PAJeep6 is offline  
Sponsored Links
Advertisement
 
post #17102 of 42811 Old 02-03-2013, 03:01 PM
ZB_WJ
Registered User
2004 WJ 
 
Join Date: Mar 2011
Location: Columbia
Posts: 3,007
Carbon Fibered the dash. Still debating if I want to do the HVAC or not.
Attached Thumbnails
image-506937421.jpg  

I think we all just need a beer. :cheers2: (courtesy of ChrisHager)

This forum is a double edge blade, it's saved me thousands in repairs and cost me thousands in mods
ZB_WJ is offline  
post #17103 of 42811 Old 02-03-2013, 04:03 PM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 7,941
Quote:
Originally Posted by ZB_WJ
Carbon Fibered the dash. Still debating if I want to do the HVAC or not.
Looks good, you Will need to do that piece to,,,

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is online now  
post #17104 of 42811 Old 02-03-2013, 04:18 PM
XC_Jeeps
Registered User
2002 WJ 
 
Join Date: Sep 2012
Location: Richmond
Posts: 65
Picked up some overland rock rails today for $70... one of them was completely rusted over, the other one had been sand blasted. So I set to work with the belt sander and dremel to get the rusty one ready for paint.

Went from this
forumrunner_20130203_181557.jpg

And this...

forumrunner_20130203_181640.jpg


To this
forumrunner_20130203_181658.jpg

Sorry for the bad low light phone picture

2002 Special Edition 4.7L V8 2"BB
XC_Jeeps is offline  
post #17105 of 42811 Old 02-03-2013, 05:08 PM
tj_nite
Registered User
2014 MK Compass 
 
Join Date: Feb 2011
Location: Appleton
Posts: 194
washed it after our big snow storms and filled my coolant bottle i dont know why it keeps going low. before and after pics
Attached Thumbnails
0202132715.jpg   0203130756.jpg   0203130809.jpg   0203130818.jpg   0201150353.jpg  


*2014 compass sport FWD 5-speed manual no mods yet*

*SOLD 2001 wj laredo 4x4. will be missed *
tj_nite is offline  
post #17106 of 42811 Old 02-03-2013, 05:09 PM
doorjamm
Registered User
2000 WJ 
 
Join Date: Sep 2012
Location: Rocklin
Posts: 709
Quote:
Originally Posted by tj_nite
washed it after our big snow storms and filled my coolant bottle i dont know why it keeps going low. before and after pics
Have the same coolant problem and can't find the leak.
doorjamm is offline  
post #17107 of 42811 Old 02-03-2013, 05:13 PM
XC_Jeeps
Registered User
2002 WJ 
 
Join Date: Sep 2012
Location: Richmond
Posts: 65
Quote:
Originally Posted by doorjamm View Post

Have the same coolant problem and can't find the leak.
Have you checked the passenger floor?

2002 Special Edition 4.7L V8 2"BB
XC_Jeeps is offline  
post #17108 of 42811 Old 02-03-2013, 05:27 PM
CantFocus
Registered User
2003 WJ 
 
Join Date: Mar 2011
Location: Lafayette
Posts: 281
Hey TJ do you have a lift at all? I just found a set of black moabs on craigs for pretty cheap and you have the same color/model as me, so your pics are giving me an idea of how it would look.

Zombie Outbreak Response Unit #338
2003 WJ Laredo 4.7 Loaded including Upcountry Package - 2" BB - Rola rack - V3 Black Projectors - 55W 5000k HIDs - Yellow 9005 fogs - JKS Discos.... More to come
CantFocus is offline  
post #17109 of 42811 Old 02-03-2013, 05:59 PM
rickcricket
Registered User
2002 WJ 
 
Join Date: Nov 2010
Location: saint louis
Posts: 614
Quote:
Originally Posted by doorjamm

Have the same coolant problem and can't find the leak.
Get a pressure test if its not on your passenger floor.
rickcricket is offline  
post #17110 of 42811 Old 02-03-2013, 06:02 PM
tj_nite
Registered User
2014 MK Compass 
 
Join Date: Feb 2011
Location: Appleton
Posts: 194
Quote:
Originally Posted by CantFocus View Post
Hey TJ do you have a lift at all? I just found a set of black moabs on craigs for pretty cheap and you have the same color/model as me, so your pics are giving me an idea of how it would look.
i do not have any lift had to do allot of trimming to make these fit without rubbing but i am going to be putting a 3" lift on as soon as i have money. the back only rubs if i flex pretty good doesnt hit anything on the other side of the tire or the front of the tire only the rear of the tire if you can tell from the pic.
and on the front tire had to trim a little of the front bumper and in the wheel well. im very happy with them even with out a lift cant wait till spring hits and its warm out to work on my jeep again. if i was you i would get them
Attached Thumbnails
1208171235.jpg  

*2014 compass sport FWD 5-speed manual no mods yet*

*SOLD 2001 wj laredo 4x4. will be missed *
tj_nite is offline  
post #17111 of 42811 Old 02-03-2013, 06:03 PM
tj_nite
Registered User
2014 MK Compass 
 
Join Date: Feb 2011
Location: Appleton
Posts: 194
Quote:
Originally Posted by rickcricket View Post
Get a pressure test if its not on your passenger floor.
yeah its not on my passanger floor so i will

*2014 compass sport FWD 5-speed manual no mods yet*

*SOLD 2001 wj laredo 4x4. will be missed *
tj_nite is offline  
post #17112 of 42811 Old 02-03-2013, 06:07 PM
USMCBehrensDVLD
Registered User
2004 WJ 
 
Join Date: Aug 2011
Location: Smithtown
Posts: 609
Quote:
Originally Posted by tj_nite
washed it after our big snow storms and filled my coolant bottle i dont know why it keeps going low. before and after pics
Check your water pump, mine was leaking through the weep hole. Pretty easy fix too

2004 Jeep WJ Freedom,4.5inch TerraFlex Coils, CLAYTON Front Long Arms, 2014 Rubicon Wheels on 33s AT
USMCBehrensDVLD is offline  
post #17113 of 42811 Old 02-03-2013, 06:33 PM
gcjeeping
Registered User
2001 WJ 
 
Join Date: Feb 2007
Location: -----Sacramento-----
Posts: 3,884
Quote:
Originally Posted by ZB_WJ View Post
Carbon Fibered the dash. Still debating if I want to do the HVAC or not.
Just do it.

gcjeeping is offline  
post #17114 of 42811 Old 02-03-2013, 06:44 PM
Harriedtwo
Registered User
2011 JK Wrangler 
 
Join Date: Oct 2012
Location: Las Cruces, NM
Posts: 300
Garage
Wj What I've done since October

What have I done. I bought the Jeep WJ with just under 168,351 miles in mid October, 2012. I had no record of maintenance, I decided to fix the critical items and do the needed maintenance. My work so far: replaced front tie rods with Moog; replaced upper rear control arm and rear ball joint, replaced rear door actuator, replaced all six struts, bought anti-sway bar replacement rubber (I'll change this week), replaced tires with correct size (old tires were too big and didn't match in depth), aligned front and rear, replaced fluids in front and rear axles as well as transfer case. Changed oil, replaced power steering hoses and fluid, replaced all four O2 sensors (one had broken plug which triggered code). Still to do: change transmission fluid and filters (scheduled for this week), replace seal where driveshaft enters transfer case since its leaking. Sometime next month I'll change get the radiator flushed and new anti-freeze installed. Then, if the weather cooperates, I'll wash the Jeep and paste wax it.

Harried Harry
2011 Jeep Wrangler Unlimited Rubicon.
Wife: 2014 Grand Cherokee Limited
Harriedtwo is offline  
post #17115 of 42811 Old 02-03-2013, 06:56 PM
shockracer
Registered User
2001 WJ 
 
Join Date: Oct 2010
Location: Northern
Posts: 1,639
Quote:
Originally Posted by doorjamm View Post

Have the same coolant problem and can't find the leak.
I had this same problem just before my shaft seal on the water pump had blown.

2001 WJ 60th anniversary edition 4.7 quadra-drive
5" hybrid lift, 265/70/17 Guard Dogs load E, bilsteins 5100's, addco sway bars, JKS front quick disco's, JKS adjustable track bar, KOR durometer track bar bushings, IRO crucial path front L.A.s, 1.25" Spidertrax spacers

Colorado Jeep Club Member #262
shockracer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 5 (3 members and 2 guests)
bislexic , EisBlade , vimnjicki
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Tried to do Spark Plugs today in the 4.7--Didn't happend Astorm WJ Grand Cherokee Forum 43 03-24-2014 08:35 PM
Died today... jimbo141 WJ Grand Cherokee Forum 28 05-09-2011 08:20 PM
I want to order some brakes today matrix849 WJ Grand Cherokee Forum 30 07-25-2010 01:01 AM
found an ad today KI4KWF WJ Grand Cherokee Forum 3 07-30-2007 12:27 AM
Just got my xenon on today ! unbelivable ! gaignstar WJ Grand Cherokee Forum 8 05-12-2002 08:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome