v8 transmission problem (shifts hard) - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 02-06-2013, 03:28 AM Thread Starter
1salem1
Registered User
2002 WJ 
 
Join Date: Jan 2013
Location: riyadh
Posts: 22
v8 transmission problem (shifts hard)

Hi guys i have this problem since i came back from travelling 3000 KM and changing my engine oil from 5w30 to 10w30 (the next day i came back) and since then my trans started to shifts hard... Can U help me plz

1salem1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-06-2013, 03:39 AM
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville
Posts: 2,841
Is it all the time? or when it kicks down? Not sure how the V8's are setup, as I have a 4.0L but mine was missing the white piece that keeps the kickdown cable in place. The result was shifting to hard, or too soft, or not quite shifting up when it should. Once adjusted it, it was fine. Could be other issues, but a place to start.

The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline  
post #3 of 4 Old 02-06-2013, 04:03 AM Thread Starter
1salem1
Registered User
2002 WJ 
 
Join Date: Jan 2013
Location: riyadh
Posts: 22
No it is when i drive normally . when it shifts up or down it shifts hard . but sometimes when it's cold shift normal but thats rarely happens. Could it be something dropped ?? Because lately i have been takeing speed pumbs at high speed and the car hit the ground sometimes hard, i just changed the trans oil and filters before two weaks and when i came back i flushed 1 gallon. Thanks for respons
1salem1 is offline  
post #4 of 4 Old 02-06-2013, 04:51 PM
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville
Posts: 2,841
Well, hitting spped bumbs at high speed can't be doing anything good. I don't know too much about the internals, but it could be the kick back cable is out and is usually the more easier thing to do if it is. When you changed your fluid, how was the old fluid? Red and smelled ok? or did it smell burnt?

The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome