transmission is sounding strange!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > transmission is sounding strange!!!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitClayton Off Road - Come see us at these events!

Reply
Unread 03-14-2014, 03:03 PM   #1
MatthewBaker88
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2013
Location: Griffin, Georgia
Posts: 6
transmission is sounding strange!!!

hey all, i have a 1996 jeep grand cherokee laredo 2 wheel drive with the 42re transmission and after putting all kind of work into it such as new water pump and new freeze plugs on the side of the motor and now my transmission is making a winding noise and shifting really high out of second gear... now my question is, is it easier to pay to have it rebuild or buy a used one? thanks in advance

MatthewBaker88 is offline   Reply With Quote
Unread 03-14-2014, 04:59 PM   #2
braddf
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: clinton, NC
Posts: 571
before you start thinking about a fullk rebuild try checking the fluid. Maybe just time for a change
__________________
Lots of ideas, very little money build thread:
http://www.jeepforum.com/forum/f310/2001-laredo-build-braddf-1520783/
Leaking Coolant? Check this out:
http://www.jeepforum.com/forum/f310/disappearing-coolant-fix-thread-2103993/#post20305169
braddf is offline   Reply With Quote
Unread 03-18-2014, 02:07 PM   #3
MatthewBaker88
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2013
Location: Griffin, Georgia
Posts: 6
I had it replaced a year ago so I didn't think that would be the problem
MatthewBaker88 is offline   Reply With Quote
Unread 03-18-2014, 02:08 PM   #4
MatthewBaker88
Registered User
1996 XJ Cherokee 
 
Join Date: Apr 2013
Location: Griffin, Georgia
Posts: 6
I had the transmission fluid changed... Sorry lol
MatthewBaker88 is offline   Reply With Quote
Unread 03-18-2014, 02:18 PM   #5
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 2,476
This is really a question for the ZJ forum, anyway. Maybe they have a better answer.

Sent from my iPad using electrons
rdkendrick is offline   Reply With Quote
Unread 03-18-2014, 09:37 PM   #6
03CUSEWJ
Registered User
2003 WJ 
 
Join Date: Jan 2012
Location: Syracuse, New York
Posts: 112
I would take it to a transmission specialty shop for diagnosis. Could be solenoid or might need rebuild. If rebuild is needed why not do it and not have the worrying about a used one doing the same thing, right?
03CUSEWJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.