transmission shifting at 4000 rpm - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > transmission shifting at 4000 rpm

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 08-06-2011, 10:45 PM   #1
sam12345
Registered User
 
Join Date: Aug 2011
Location: hackensack, nj
Posts: 1
Wj transmission shifting at 4000 rpm

i have a 2001 jeep grand cherokee laredo, car starts fine and run up to 30 mph, then it wont shift into next gear unit 4000 rpm, car run fine until i get below 30 mph then it hapens again, once it kick in there no problem, i m not hearing any noise from transmission. turned ignition key 3 times gave me one fault code p1762. i brang it to the dealer they told me i need a new valve body, they didnt drop the pan, they just hooked up the scan tool, they told me they got a bunch of faults that the valve body was bad, i had this problem before and had taken it to another jeep dealer 4 years ago, they changed governer solenoid and problem was solved. do you think they were trying to rip me off, they kept telling me that i was going to get stuck on the road, i just got a bad feeling so i left and going to take to an aamco shop for a diagnostics. can someone give some advice on what this problem could be. thank you.


Last edited by sam12345; 08-06-2011 at 10:56 PM..
sam12345 is offline   Reply With Quote Quick reply to this message
Unread 08-07-2011, 12:42 PM   #2
fireman33
Registered User
2003 WJ 
 
Join Date: May 2009
Location: Canada (N-B)
Posts: 378
It sounds like the pressure sensor. Thats what that code means, and also your symptoms are leading to the sensor and solenoid acting up. Check your fluid level first and make sure it doesnt smell like burnt oil. If thats fine i would go ahead and change the solenoid and the sensor.
__________________
98% of Canadian say '' oh **** '' before taking the ditch in winter time. The other 2% are from New-Brunswick and say '' hold my beer and watch this ''

2003 WJ 4.0, 4'' IRO Critical Path, 31x10.5x15 goodyear wrangler territory on soft 8's, Tom Wood front drive shaft, Rough country SS, 4.56 G2 gears, D30 front, D35 rear/detroit trutrac, IRO adj. trackbar, Doetch tech 8000 shocks, nv242 TC, midland cb, 3' firefly antenna, Mopar TC Skid

My build thread--> http://www.jeepforum.com/forum/f197/...-build-957216/
fireman33 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.