Transmission governor and solenoid problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Transmission governor and solenoid problems

Rough Country Jeep Suspension Deals at Rockridge 4WD!Engo winches available at www.rockridge4wd.com! Free shippRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 05-07-2013, 06:52 AM   #1
frosty68
Registered User
2004 WJ 
 
Join Date: Apr 2008
Location: Mass
Posts: 55
Wj Transmission governor and solenoid problems

I have recently gotten the P1763 code. The tranny won't shift out of first gear when this occurs. I have had to disconnect the neg cable to battery for a few minutes to reset it and all is good for a couple weeks until it comes on again. Where is this part located on the tranny? Is it inside or outside and how do I know what tranny I have? I have an 04 GC rocky Mountain Edition with 4.0 I6 Auto tranny with 4 wheel drive.

frosty68 is offline   Reply With Quote
Unread 05-07-2013, 02:19 PM   #2
WJ4x4LIFE
Registered User
 
Join Date: Sep 2012
Posts: 574
What you have is possibly a short-circuit issue. To answer your three questions.

#1. internally located in the transmission.
#2. Inside, you need to remove your transmission oil pan.
#3. ALL 99'-04' WJ USA built (export models excluded) with a 4.0L engine, have a 42RE transmission, regardless of what drive-train system you have, 2wd or 4wd/Awd.
WJ4x4LIFE is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.