Transmission delay in moving - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Transmission delay in moving

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueNitro Gear Packages Now Available at Rockridge 4wdG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ Ch

Reply
Unread 07-17-2013, 03:55 PM   #1
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,074
Transmission delay in moving

I cannot remember where I read about the fix for a transmission. Some times when I put my '03 Jeep GC Overland into drive, it starts to move slowly, then when I hit the gas, it moves normally. If I rev it up before putting it into gear, it is OK. I recently read (I could have sworn it was a TSB) where the torque converter is not primed and filled up with fluid and the fix wax to replace one of the filters and something else, but I cannot remember.
I went over the TSB's at wjjeeps.com, but cannot find it, unless I am just not seeing it. Has anyone else seen this?

Sent from my iPad using Forum Runner

rdkendrick is online now   Reply With Quote
Unread 07-17-2013, 05:43 PM   #2
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,074
Quote:
Originally Posted by rdkendrick View Post
I cannot remember where I read about the fix for a transmission. Some times when I put my '03 Jeep GC Overland into drive, it starts to move slowly, then when I hit the gas, it moves normally. If I rev it up before putting it into gear, it is OK. I recently read (I could have sworn it was a TSB) where the torque converter is not primed and filled up with fluid and the fix wax to replace one of the filters and something else, but I cannot remember.
I went over the TSB's at wjjeeps.com, but cannot find it, unless I am just not seeing it. Has anyone else seen this?

Sent from my iPad using Forum Runner
Never mind, I must be blind. I found it. Good thing I printed it out last night. It is TSB 21-015-05
45RFE/545RFE Trans-Delayed Engagement Due to Cooler Return Filter Replacement.

Sent from my iPad using Forum Runner
rdkendrick is online now   Reply With Quote
Unread 07-19-2013, 02:56 AM   #3
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,804
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.