Thumping in rear - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 06-27-2013, 07:49 PM Thread Starter
outbackmatt
Registered User
 
Join Date: Sep 2012
Location: chickamauga
Posts: 630
Thumping in rear

I have been hearing clunking and thumping coming from my wj suspension that has a new 3" iro lift, adj track bar, adj upper and lower front ca's.
The noises were getting worse so I decided to crawl under and have a look around while someone pushed on the jeep laterally. I found that in the front the pass side sway bar link was loose and causing the clunking. I tightend it down and solved that problem.

The rear however has a lot of movement in the a-arm at the center and outer joints. When I drive the jeep it sounds like there are bowling balls bumping around in the spare tire well. I didnt see anything unusual in the rear control arm bushings from what I could tell.

Does this sound like I need new a arm joints? Do I need an adjustable a arm at 3" lift or would that be a waste of money? Do I need an a arm spacer at 3" lift?

outbackmatt is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-27-2013, 07:53 PM
adavis39
Registered User
2002 WJ 
 
Join Date: Nov 2011
Location: Nashville
Posts: 2,808
U dont really need a new arm or spacer. But certainly sounds like u need a new ball joint

2002 WJ Limited 4.7: 6" Clayton REALLY long arms....yep, they are longer than yours SOLD : (
1998 Platinum 5.9 DD
2007 WK Overland 5.7 wifes DD
TNJEEPS.COM

BUILD: http://www.jeepforum.com/forum/f197/...-crap-1399123/

"In a world that he did not create, but he will go through it as if it is his own creation. Half man, half beast, whatever it is it is weird, it is ticked off and it calls itself Slash"
adavis39 is offline  
post #3 of 3 Old 08-24-2013, 02:45 PM
redsilver2
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: Albuquerque
Posts: 41
Outbackmatt .... did you ever fix/find the problem? I Just installed an IRO 4" LA Critical path lift and my WJ also sounds like bowling balls are bouncing around in the back when I hit a bump.
Wondering how it's going for ya.
Thanks for any info!
redsilver2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome