Stupid 10 disc changer not spinning CD's - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Stupid 10 disc changer not spinning CD's

Savvy Aluminum Gas Tank SkidFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Savvy/Currie Aluminum Control Arms

Reply
Unread 03-26-2013, 09:48 AM   #1
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
Stupid 10 disc changer not spinning CD's

My 10 disc changer has been giving me intermittent trouble, which turned into permanent trouble so I finally took it apart. All I'm getting on the head unit is "error". With the covers off, it appears to load the CD, but does not attempt to spin it, it just says error. Everything seems to move freely, and I can turn the disc by hand.
I don't listen to CD's so I'd pull it all together, but I've been using it with my aux input. I have to have a "blank" CD playing in order to use my aux in jack. With no CD changer (or CD, or magazine) I am not able to turn the volume up, only down.
Does anyone know a fix for either ditching the changer altogether but keeping the input mode, or fixing the cd changer? I'm not going to invest money in the changer, if I spend anything it will be on aux the hookup that replaces it altogether. If there's a cheap/easy solution here though I'd love to know about it. Thanks!

__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote
Unread 03-26-2013, 09:56 AM   #2
Merc1973
Registered User
2002 WJ 
 
Join Date: Jun 2008
Location: Ellicott city, MD
Posts: 1,729
Search?

Cheap and Easy!

Remove the CD changer from the WJ, get some anti-seize and lightly lube the slides (movable parts) in the CD changer. Reinstall and Viola, it works!
__________________
2002 WJ Ltd. 4.7 V8, QuadraDrive
1973 Mercury Cougar Xr7 convertible 351CJ, C6, 9" rear
1970 Kaiser-Jeep M35A2 W/OW 6x6 Multifuel D-Turbo.


ΜΟΛΩΝ ΛΑΒΕ!
Merc1973 is offline   Reply With Quote
Unread 03-26-2013, 10:10 AM   #3
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
Quote:
Originally Posted by lazyWJ View Post
SNIP Everything seems to move freely, and I can turn the disc by hand.
/SNIP
The factory grease is still in place and lubricating. Everything loads/unloads as it should. CD just doesn't start spinning once loaded.
__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote
Unread 03-26-2013, 10:57 AM   #4
kingmeirl
Registered User
2003 WJ 
 
Join Date: Jun 2008
Location: Georgia
Posts: 100
http://m.radioshack.com/radioshack/p...egoryId=&path=

Or if you live in Ga you can swing by and have my CD changer. No deck so I don't know if it works. I took it out a few days ago.
kingmeirl is offline   Reply With Quote
Unread 03-26-2013, 01:21 PM   #5
Merc1973
Registered User
2002 WJ 
 
Join Date: Jun 2008
Location: Ellicott city, MD
Posts: 1,729
Quote:
Originally Posted by lazyWJ View Post
The factory grease is still in place and lubricating. Everything loads/unloads as it should. CD just doesn't start spinning once loaded.
"Seems" to move freely? Yeah, I thought so on mine as well. Trust me, give it a shot. I partially disassembled it to grease it. You could even try using lens cleaner on the laser lens.

BTW, the CD changer does not read "Burned" CD's, only originals.

__________________
2002 WJ Ltd. 4.7 V8, QuadraDrive
1973 Mercury Cougar Xr7 convertible 351CJ, C6, 9" rear
1970 Kaiser-Jeep M35A2 W/OW 6x6 Multifuel D-Turbo.


ΜΟΛΩΝ ΛΑΒΕ!
Merc1973 is offline   Reply With Quote
Unread 03-26-2013, 03:02 PM   #6
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,071
Quote:
Originally Posted by Merc1973

"Seems" to move freely? Yeah, I thought so on mine as well. Trust me, give it a shot. I partially disassembled it to grease it. You could even try using lens cleaner on the laser lens.

BTW, the CD changer does not read "Burned" CD's, only originals.

My CD changer will read burned CD's all day. Most of the CD's in my changer are burned copies or mixes. Not sure why your's won't.
rdkendrick is offline   Reply With Quote
Unread 03-26-2013, 03:10 PM   #7
Merc1973
Registered User
2002 WJ 
 
Join Date: Jun 2008
Location: Ellicott city, MD
Posts: 1,729
Quote:
Originally Posted by rdkendrick View Post
My CD changer will read burned CD's all day. Most of the CD's in my changer are burned copies or mixes. Not sure why your's won't.
Do you use RW+ or - ?
__________________
2002 WJ Ltd. 4.7 V8, QuadraDrive
1973 Mercury Cougar Xr7 convertible 351CJ, C6, 9" rear
1970 Kaiser-Jeep M35A2 W/OW 6x6 Multifuel D-Turbo.


ΜΟΛΩΝ ΛΑΒΕ!
Merc1973 is offline   Reply With Quote
Unread 03-26-2013, 03:23 PM   #8
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,071
Quote:
Originally Posted by Merc1973
Do you use RW+ or - ?
CD-R's
rdkendrick is offline   Reply With Quote
Unread 03-26-2013, 03:28 PM   #9
OverlandInRI
Registered User
2004 WJ 
 
Join Date: Feb 2012
Location: Johnston, RI
Posts: 26
I have CD-RW and they work in mine. Although, they didn't with my first attempt. But that was because Windows media player defaulted to 'data CD' instead of 'music CD' when I first burned them. Once I figured that out they work fine now.
OverlandInRI is offline   Reply With Quote
Unread 03-26-2013, 05:09 PM   #10
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
By "seem" I mean that I can watch the all the cd's load and unload while the case is open. Anyway, from what I've read the changer has a safety interlock so that it won't operate the laser with the case removed, so trying to run it with the case off wasn't going to work anyway. I reassembled it, and after loading the mag twice, it started working again. While burned discs are more finnicky, they work just fine in mine. When it works at all.

I guess greasing the lens helped after all
__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote
Unread 06-20-2013, 09:56 PM   #11
JoeFaz
Registered User
1999 WJ 
 
Join Date: Sep 2012
Location: San Rafael, Ca.
Posts: 65
Having the same issue with mine ('99). I can hear them all loading and changing, but I get "ERR" each time. Then once in a while it will work as though nothing was wrong. Turn it off and BAM, "ERR" again! ARRRRGGGGHHHHH!
JoeFaz is offline   Reply With Quote
Unread 06-21-2013, 04:44 AM   #12
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
Since I took it apart and put it back together, other than the first error it's been working OK. I found that removing and reloading the mag seemed to trigger it to work. I tried turning it on and off, and cycling through the cds for a couple days while driving, and it wouldn't work. Then I reloaded the mag a couple times and it worked. Very frustrating for sure.
__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote
Unread 06-21-2013, 04:54 AM   #13
Darnice
Registered User
2004 WJ 
 
Join Date: Nov 2012
Location: Windsor, Ontario
Posts: 448
Is it a direct drive motor or gear/belt driven? Could a gear failed, fell off or a belt gone.
Darnice is offline   Reply With Quote
Unread 06-21-2013, 06:22 AM   #14
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 3,472
It's a known issue with that unit. It will work perfectly for a week and then never load a disc... I've found that if I try to load a CD, then immediately request a track other than letting it start at 1, it will work when it is being problematic. Burned or bought discs are no factor to me either.
__________________
2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline   Reply With Quote
Unread 09-10-2013, 05:19 PM   #15
JoeFaz
Registered User
1999 WJ 
 
Join Date: Sep 2012
Location: San Rafael, Ca.
Posts: 65
When you say remove the changer, do you mean just the cartrage or take the whole unit (internals) apart?
JoeFaz is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.