Steam from under dash/defrost vents. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 12-18-2011, 01:43 PM Thread Starter
kevinrocks
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: Louisville
Posts: 13
Steam from under dash/defrost vents.

So I noticed when I did not have my heat on the other day, I seen a light flow of what looked to be steam. Then a few days later I noticed it from the defrost vents. I turn on the heat and its very warm and doesnt have the 'steam' while it's on. I do have a weird smell in the car, that seems to come back, and the floorboard is not wet.

I'm curious if it's the heater core. if it is, I'm worried, I could do it, but I don't exactly have the time to fix it right now. I can only assume if it is the heater core, the steam look will only get worse.


thanks.

kevinrocks is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 12-18-2011, 04:04 PM
BigBeefy
Registered User
2004 WJ 
 
Join Date: Oct 2007
Location: Knoxville
Posts: 201
Usually steam and an odor are signs of a leaking heater core. Pull the carpet and see if it is wet UNDER the carpet. There is a plastic membrane that can keep moisture from reaching the pad and carpet when wet from underneath.

2004 Overland, 75k miles, 4.7L H.O.
1997 ZJ TSi, 265k miles, 4.0 I6
BigBeefy is offline  
post #3 of 11 Old 12-18-2011, 04:56 PM
Doughboy8475
Registered User
1999 WJ 
 
Join Date: Dec 2011
Location: Clarksville
Posts: 24
mine is doing the same thing, floor board is wet, but thats from a leaking sunroof. hey kevin, does that weird smell kinda burn your eyes a little bit kinda like exhaust? just wondering cause mine does
Doughboy8475 is offline  
post #4 of 11 Old 12-18-2011, 04:58 PM
Doughboy8475
Registered User
1999 WJ 
 
Join Date: Dec 2011
Location: Clarksville
Posts: 24
hey one more thing kevin, does your vents not work very well? if they do, did you do anything to them? mine isnt working very well at all. pm me, ur right across the river
Doughboy8475 is offline  
post #5 of 11 Old 12-18-2011, 05:26 PM Thread Starter
kevinrocks
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: Louisville
Posts: 13
Quote:
Originally Posted by Doughboy8475 View Post
hey one more thing kevin, does your vents not work very well? if they do, did you do anything to them? mine isnt working very well at all. pm me, ur right across the river
mine, doesn't burn the eyes, but it smells weird. My vents work great and I have good heat too...it's going to suck to take the whole dash out...

yeah, i noticed that. you on any of the local forums?
kevinrocks is offline  
post #6 of 11 Old 12-18-2011, 05:33 PM
Doughboy8475
Registered User
1999 WJ 
 
Join Date: Dec 2011
Location: Clarksville
Posts: 24
no, none locally, just a BMW forum for my 2004 325i
Doughboy8475 is offline  
post #7 of 11 Old 12-18-2011, 05:57 PM Thread Starter
kevinrocks
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: Louisville
Posts: 13
There are a few local sites, one is a vw/audi forum...and they just love german cars. There is also another site, but they haze new members a lot, and some folks cant take the heat. lol.
kevinrocks is offline  
post #8 of 11 Old 12-18-2011, 06:51 PM
Doughboy8475
Registered User
1999 WJ 
 
Join Date: Dec 2011
Location: Clarksville
Posts: 24
Most of the vw/audi guys that I know are cool. What is the other site you are talking about? Most everybody that I know when they see me, then they see the car, they kinda stick their nose up in the air lol.
Doughboy8475 is offline  
post #9 of 11 Old 12-21-2011, 06:41 PM Thread Starter
kevinrocks
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: Louisville
Posts: 13
Quote:
Originally Posted by Doughboy8475 View Post
Most of the vw/audi guys that I know are cool. What is the other site you are talking about? Most everybody that I know when they see me, then they see the car, they kinda stick their nose up in the air lol.
louisvillevw.org

Lot's of cool people on there. Site has slowed down as of late, but we are trying to bring it back. I'm an aircooled guy, but most of them are watercooled folks.
kevinrocks is offline  
post #10 of 11 Old 12-21-2011, 07:54 PM
Doughboy8475
Registered User
1999 WJ 
 
Join Date: Dec 2011
Location: Clarksville
Posts: 24
Cool
Doughboy8475 is offline  
post #11 of 11 Old 12-21-2011, 09:09 PM
WJChris
Registered User
 
WJChris's Avatar
2000 WJ 
 
Join Date: Nov 2007
Location: Santa Rosa, California
Posts: 2,782
check UNDER the passenger carpet/padding and check for coolant.

Coolant has a sweet smell
WJChris is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
'04 GCL: Windshield defrost very weak - other vents good....??? jacknthebox WJ Grand Cherokee Forum 0 11-23-2011 10:53 AM
A/C on defrost....Turns off on front vents?? Neal WJ Grand Cherokee Forum 0 08-19-2011 06:42 PM
center vents blow about 10 degrees warmer than pass vents. likely not blend doors jclaudii WJ Grand Cherokee Forum 0 06-24-2011 09:46 AM
Main dash vents going in and out bluepoint WJ Grand Cherokee Forum 13 05-14-2011 05:48 PM
No air through vents defrost or floor? Gearhead177 WJ Grand Cherokee Forum 4 04-12-2011 06:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome