Speed sensor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Speed sensor

Alloy usa heavy duty ball joint kitsNEW!! HMF 50"-52" light bar mounting brackets!! ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 07-06-2012, 05:30 PM   #1
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
Speed sensor

I recently have heard my transmission do some weird things. First when it goes into overdrive it sounds like it readjust... Then a couple of times either in 2nd or 3rd it starts to sputter like, lurching forward i suppose. It doesnt happen all the time. And it seems like its shifting too high but idk about that. I went to AZ and got a speed sensor, they only had one, and i was going to replace the output first and drive and see what happens. Then if nothing happens switch them and try again. OR is this speed sensor not going to fix my problem?

__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:21 PM   #2
bradywgn71
Web Wheeler
 
bradywgn71's Avatar
2002 WJ 
 
Join Date: Apr 2011
Location: Tucson, Arizona
Posts: 1,033
It could be the Throttle Position Sensor. I replaced mine when I had shifting issues and it cured it. If it's bad, it could also cause lurching.
bradywgn71 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:23 PM   #3
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
naw i replaced that.. ALL THOUGH im not saying that it isnt bad too. but the only reason im not trying out the speed sensor right now is because im not getting a CEL...
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:26 PM   #4
bradywgn71
Web Wheeler
 
bradywgn71's Avatar
2002 WJ 
 
Join Date: Apr 2011
Location: Tucson, Arizona
Posts: 1,033
I didn't get a CEL for the throttle position sensor either. I had seen here on the forum that it had cured others shifting issues so, I gave it a try for $30. It just seems to be a part that wears out yet affects so many other things.
bradywgn71 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:33 PM   #5
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
which did you replace input or output? or both? like i said the second one wont get here till tomorrow. They only had one. The guy was like are you sure u need two? Im like uhhhh yeah bro i need two... SHESH
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:39 PM   #6
bradywgn71
Web Wheeler
 
bradywgn71's Avatar
2002 WJ 
 
Join Date: Apr 2011
Location: Tucson, Arizona
Posts: 1,033
The throttle position sensor (TPS) is on the side of the throttle body. There is only one. It's not a speed sensor.

bradywgn71 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:40 PM   #7
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
Quote:
Originally Posted by bradywgn71 View Post
I didn't get a CEL for the throttle position sensor either. I had seen here on the forum that it had cured others shifting issues so, I gave it a try for $30. It just seems to be a part that wears out yet affects so many other things.
crap i see what you actually said. I meant i didnt have a CEL for the speed sensors which is why i think its not the speed sensors.... Sorry
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:42 PM   #8
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
Yeah i took the TB off twice and cleaned it REAL good and replaced the TPS, IAC for a crap idle issue that I AM STILL HAVING on top of this. Sorry for the confusion.
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:48 PM   #9
bradywgn71
Web Wheeler
 
bradywgn71's Avatar
2002 WJ 
 
Join Date: Apr 2011
Location: Tucson, Arizona
Posts: 1,033
No worries! I bought my TPS from O'Reilly's and it has worked well. If you bought your TPS from AZ, I have read on the forum that there has been occasional issues when using one from there. Our WJs seem to be sensitive to the quality of the sensor and many on the forum won't use anything but genuine Mopar parts.
bradywgn71 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:48 PM   #10
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,239
Quote:
Originally Posted by Gunrunner23 View Post
Yeah i took the TB off twice and cleaned it REAL good and replaced the TPS, IAC for a crap idle issue that I AM STILL HAVING on top of this. Sorry for the confusion.
Did you get the TPS at Autozone too? If so, take it back and get a Mopar one.
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 06:50 PM   #11
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
No AAP BWD. Ive never had problems with Warner before so i went with it. BTW the IAC is mopar.
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 08:01 PM   #12
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
So back to the speed sensor. If one was going bad or is bad would it throw a CEL?
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 08:02 PM   #13
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,239
Quote:
Originally Posted by Gunrunner23 View Post
So back to the speed sensor. If one was going bad or is bad would it throw a CEL?
not necessarily. These WJs have all kinds of sensor issues without throwing codes.
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 08:08 PM   #14
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
Well I guess ill throw them in. 42 bucks isn't bad for two new sensors I suppose.
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Unread 07-06-2012, 08:09 PM   #15
Gunrunner23
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Knoxville, TN
Posts: 866
Thanks narnwv ur a lot if help!!!
__________________
2004 wj limited 4.7
IRO 3in lift with skyjacker hydro
265/75/16 TreadWright Claws
Gunrunner23 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.