Sooooo many issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 06-07-2013, 11:39 AM Thread Starter
jweaver1
Registered User
1999 WJ 
 
Join Date: Oct 2012
Location: Hanover
Posts: 6
Sooooo many issues

I have a 99 Laredo and it seems every week I have another problem.

For the past few years I've been dealing with the transmission. Hard shifting, shaking when you stop if you haven't gotten into 2nd gear yet, revving really high then a bang when it finally shifts. Had governors and sensors replaced, used Lucas transfix (I think that's what it was called), and I guess I gave up on that problem.

A few weeks ago the airbag light constantly comes on and goes off without and indication. I saw some posts saying it is a bad clock spring but there is no pattern to it (others said it would happen when you turn the wheel a certain way and the horn won't work if that's the problem?).

Now just today I drove it home, walked inside for 5 minutes, then when I tried starting it again it made an attempt for a few seconds then completely stopped. I took the key out and it made a weird humming noise and the gauge needles started flipping back and forth. I put the key back in and it stopped. Took it out, started again. Put it in, stopped. Took it out and this time everything seemed fine (well other than not starting).

Someone please tell me.... how bad am I screwed?!?!?!??!?!?!

jweaver1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-07-2013, 11:49 AM
ezflip
Moderator
 
ezflip's Avatar
2002 WJ 
 
Join Date: Oct 2008
Location: Michigan
Posts: 5,896
Garage
First, sounds like your tranny is on its way out the door. The 42re behind the 4.slo is a POS. Decent motor, horrible trans.

Second, there is a recall for the airbag that was just released in November. Last I heard, the dealerships still dont have the parts to fix the issue, but you should probably look into that.

Third, disconnect your battery, clean the terminals, clean the terminals again, and when you think they are perfect, clean them one more time.

~James

2002 Overland - 4.7 HO, "Select-Drive", 4" RC long arms, TAG front winch bumper, 32" BFG KM's, 3" exhaust, Magnaflow hi-flow cat, Flowmaster 50 series


Build Thread
ezflip is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome