Some problemos. Tried to fix, but nope... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 08-06-2011, 01:46 AM Thread Starter
Azaha
Registered User
2006 KJ Liberty 
 
Join Date: Jul 2011
Location: Honolulu
Posts: 13
Some problemos. Tried to fix, but nope...

Alright then. Got some engine trouble, I've done the forum searches and to no avail, got nothing.

So my check engine light comes on for about a week at a time, and then goes off for a couple days, then returns. Took it to a mechanic and they checked the code, all I got was that they said it was a "Soft"(Or did they call it "sub"?) code, so they reset the computer and sent me on my way. Well the check engine light still comes on at the frequency I described above.

While the check engine light is on, the vehicle doesn't idle well, it sounds like its dropping and raising RPM's. Now the first thing I did was take apart my throttle body, and cleaned the IAC valve. It was very very dirty and caked with crud. I cleaned everything associated with the throttle body very well, and reattached everything the correct way, and the jeep still has this problem of not idling well and the check engine light still comes on.

When the check engine light is off, it idles a little better, but I still feel some soft knocking. I also get some pretty horrendous gas mileage. I know my WJ isn't supposed to get great MPG's, but it seems to be way below par. About 12-13 MPG with mix of city and highway. I've been doing my best to drive like a grandma, but still get his horrible mileage.

While in motion, the engine runs fine, and it seems to have the appropriate amount of power.

The fuel system was cleaned recently, the air filter replaced, engine oil changed with new filter and correct oil and amount.

It's a 2000 WJ(Of course) with the 4.0, about 134,000 miles.

I like to consider myself a budding home garage mechanic, but I do not know what else to really do or check to fix this problem.

Thanks in advance for any future help or insight I can get.

Azaha is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-06-2011, 09:40 AM
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes
Posts: 6,416
When the light comes on, pull over and turn it off.

Without starting the engine, turn your key--> OFF-ON-OFF-ON-OFF-ON It will then roll through any codes on the odometer, when it's finished it'll say "d0nE" Post back any codes you get.
narnwv is offline  
post #3 of 5 Old 08-07-2011, 02:26 AM Thread Starter
Azaha
Registered User
2006 KJ Liberty 
 
Join Date: Jul 2011
Location: Honolulu
Posts: 13
Thanks for that trick. I just did it, with the check engine light OFF, and it still pulled up P1281.
Azaha is offline  
post #4 of 5 Old 08-07-2011, 03:08 AM Thread Starter
Azaha
Registered User
2006 KJ Liberty 
 
Join Date: Jul 2011
Location: Honolulu
Posts: 13
Did some interwebz research! Found out it's most likely the T-stat.

Thanks narnw, your hint was instrumental to me finding this info out! Thanks a lot.
Azaha is offline  
post #5 of 5 Old 08-07-2011, 05:44 AM
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes
Posts: 6,416
Quote:
Originally Posted by Azaha View Post
Did some interwebz research! Found out it's most likely the T-stat.

Thanks narnw, your hint was instrumental to me finding this info out! Thanks a lot.
No problem. That's what we're here for.
narnwv is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome