SERIOUS Jeep problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 06-05-2013, 08:49 PM Thread Starter
pmdowd6
Registered User
2002 WJ 
 
Join Date: Nov 2011
Posts: 324
SERIOUS Jeep problems

I'm sorry this is long but I hope at least some of you will read it. The past few weeks my WJ has been having some issues. The major problem is most of the electronics in the WJ don't work.

I took all 4 doors off May 24th and put them back on the 26th. The whole time I had them off it didn't rain and all exposed electronics and wires were covered in plastic bags so I know no water got in. That being said, ever since I put the doors back on the door electronics have been acting up. At this point none of the windows roll down, passenger side mirror doesn't move, only the passenger side lock works with my fob and using the lock button on the door, and the trunk is locked shut and I have no way of unlocking it.

I've read a few threads talking about similar problems and I've pulled the black boot back in between the body and door and there appears to be no broken wires.

Besides the doors, a few other electronics have been acting up as well. My dash lights seem to be fully turned on no matter how many times I try to adjust them with the brightness level. Also dome lights do not come on when any doors are opened and my headlights/tail lights do not flash when I use the key fob. On top of all that the EVIC doesn't display any information as shown below:





I've checked the EVIC and it says it passes. I've also retrieved the car codes and the only ones it gives me are unrelated to the electrical problems (P0122 & P1281)

Any help would be appreciated guys... I'm so lost on this one


2004 WJ
pmdowd6 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 06-05-2013, 09:23 PM
bugaboots
Registered User
2002 WJ 
 
Join Date: Feb 2012
Location: faribault
Posts: 154
Sounds like you could be having a problem with the bcm.

1995 Cherokee 4.0 Stock(for now)
2002 Grand Cherokee Sport, OME HD lift, Bilstien 5100's, 63mm Bored t-body, IRO 2.5 exaust, 245/75/16 Revo2, Front tow hooks, 4.6L long rod stroker, Factory Jeep brush gaurd
bugaboots is offline  
post #3 of 11 Old 06-05-2013, 11:56 PM
gordondude24
Registered User
2000 WJ 
 
Join Date: Aug 2007
Location: florida
Posts: 19
Have you tried unhooking the battery to reset the computer?
If not, unhook and leave it for about twenty minutes before hooking it back up. You never know, it might work.

John

2000 WJ
gordondude24 is offline  
post #4 of 11 Old 06-06-2013, 06:06 AM
KlampWJ
Registered User
2002 WJ 
 
Join Date: Apr 2013
Location: Upstate
Posts: 66
I am willing to bet you forgot to plug something back in or a single pin could have broke. I rewired all the speakers in my doors and had to pull the connectors. I also removed the passenger seat. Ever since I did that I noticed MANY weird things would happen.

Airbag light would stay on (this I found was due to disconnecting the passenger door specifically and/or the passenger seat);
Dome light would stay on even after car was locked;
Dash light brightness was maxed;
Windows didn't work (except drivers);
Only the passenger door would lock;
Memory thing didn't change seat position (something to do with the disconnected plug to a sensor in the passenger mirror???);

The list goes on... Point is a single plug in any of the doors can cause a multitude of problems. Double check them all.

2002 WJ Grand Cherokee Limited V8 4.7L HO Quadra-Drive - just gettin' started
KlampWJ is offline  
post #5 of 11 Old 06-06-2013, 02:57 PM Thread Starter
pmdowd6
Registered User
2002 WJ 
 
Join Date: Nov 2011
Posts: 324
Okay so I have an update. I unplugged the battery for about 20 minutes and now the EVIC is displaying all information, my dash lights dim, and my driver side windows roll down.

2004 WJ
pmdowd6 is offline  
post #6 of 11 Old 06-06-2013, 03:07 PM
WJChris
Registered User
 
WJChris's Avatar
2000 WJ 
 
Join Date: Nov 2007
Location: Santa Rosa, California
Posts: 2,801
so what is left that's not working?
WJChris is offline  
post #7 of 11 Old 06-06-2013, 08:19 PM Thread Starter
pmdowd6
Registered User
2002 WJ 
 
Join Date: Nov 2011
Posts: 324
^^ All locks and the passenger side windows

2004 WJ
pmdowd6 is offline  
post #8 of 11 Old 06-06-2013, 08:25 PM
its-me-B
Registered User
2002 WJ 
 
Join Date: Jul 2012
Location: milwaukee
Posts: 643
Double check you passenger side harness for broken pins or loose wires. Any pics with the doors off?

Do the world a favor, hurt a honda...
Iro 3" lift with pro comp 9000es shocks, adjustable trackbar, led rock lights, all interior lights converted to leds, two 10" kicker comp with Kenwood 600 watt amp
Zombie Outbreak Response Unit #396
its-me-B is offline  
post #9 of 11 Old 06-07-2013, 07:44 PM
WJChris
Registered User
 
WJChris's Avatar
2000 WJ 
 
Join Date: Nov 2007
Location: Santa Rosa, California
Posts: 2,801
Whatever you disconnected and re-connected when you re-installed the doors, check all the connections with a magnifying glass! That is the only thing you changed, so you need to start there.
WJChris is offline  
post #10 of 11 Old 06-07-2013, 09:09 PM
cuttysark
Registered User
 
Join Date: Mar 2012
Location: Hamilon
Posts: 305
yeah i second a short in the door somewhere as well..
re check!
cuttysark is offline  
post #11 of 11 Old 06-12-2013, 12:11 AM Thread Starter
pmdowd6
Registered User
2002 WJ 
 
Join Date: Nov 2011
Posts: 324
Thanks guys I'll double check them again tomorrow.

Quote:
Originally Posted by its-me-B View Post
Double check you passenger side harness for broken pins or loose wires. Any pics with the doors off?

2004 WJ
pmdowd6 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome