??? reading different threads.... 4.0 temp? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > ??? reading different threads.... 4.0 temp?

*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*Stainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 09-21-2013, 03:19 AM   #1
Knightrider9827
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: Everett, WA
Posts: 86
??? reading different threads.... 4.0 temp?

I have an 02 4.0 laredo, temp runs at 195 - 201 via torgue app. Mechanical and electric fan. Will only climb to 205 - 208ish during slow crawls up hill around 5 - 10 mph (but drops right back down when electric fan kicks in). See a lot of threads saying theirs runs at 210 normally. Just think this is weird, and maybe PO put in a cooler thermostat. Anyone else's 4.0 run right around these temps? I just think its weird, was even like that before I replaced the cracked radiator. The oe is supposed to be 195 right? Maybe mine is normal?

Knightrider9827 is offline   Reply With Quote
Unread 09-21-2013, 06:07 AM   #2
OffroadOran
Registered User
2004 WJ 
 
Join Date: May 2013
Location: , Massachusetts
Posts: 202
Mine is about where yours is, plus or minus 2-3degrees . Elecrric fan only
__________________
Jack of all trades, master of none

04 Steel Blue Pearl laredo WJ 4.0L, NV242 TC, 42RE Trans, Dana 30 & 35C, 3.55 gears: 99% stock. 80k miles
OffroadOran is offline   Reply With Quote
Unread 09-21-2013, 06:27 AM   #3
WJ4x4LIFE
Registered User
 
Join Date: Sep 2012
Posts: 574
To be on target, your gauge may read 1-2 degrees off in general (not perfect). Although, 205'F-210'F is where the 4.0L in general likes to be at "temperature" wise. I regularly maintenance my cooling system with a 195'F thermostat, the temperature gauge has never read past 200-205, that is with full load. Under any circumstance, if you feel there might be something off, I would suggest you get the system check for any issues that are in the "mist" of coming up.
WJ4x4LIFE is offline   Reply With Quote
Unread 09-21-2013, 10:52 AM   #4
Knightrider9827
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: Everett, WA
Posts: 86
I don't really think there is anything going on with mine, I was just curious why a lot of threads say theirs run at 210. Maybe mine is still as good as new as far as cooling goes.
Knightrider9827 is offline   Reply With Quote
Unread 09-23-2013, 10:08 AM   #5
MuddyWJ
Registered User
2004 WJ 
 
Join Date: Feb 2012
Location: San Rafael, Ca
Posts: 2,091
I just replaced my entire cooling system and it runs right at your temp. I also used the correct coolant. Those that run at 210* may just need a coolant change.
MuddyWJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.