Please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Please help

Flowmaster Overstock: Special Holiday Pricing!!!!Thanksgiving holiday sale in effect @ oconeeoffroad.com2" Lift Kits for JK, TJ, XJ, WJ~$125.00 w/free shippi

Reply
Unread 09-26-2013, 03:27 PM   #1
xj_96_FP
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2007
Location: TOMS RIVER, NJ
Posts: 371
Please help

My parents have 2001 grand and yesterday my dad backs down the drive way heard some sort if grinding noise when he steps on the brake, then when it goes into drive but non of the lights or blinkers or radio worked, if you put it in park it makes another grinding noise. The lights do come back on in park. They go off when it's put in gear.
Any suggestions?

xj_96_FP is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 05:41 PM   #2
wickedwj99
Registered User
1999 WJ 
 
Join Date: Oct 2012
Location: mililani, hi
Posts: 75
What is the spec on the grand engine trans model? How's the fluid levels in the trans was the parking brake off
__________________
I have also heard those stick on chrome vents from Walmart add like 75+ HP..
wickedwj99 is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 06:10 PM   #3
tim0
Member
 
tim0's Avatar
2002 WJ 
 
Join Date: Sep 2012
Location: Kansas City, Kansas
Posts: 216
Check all your battery and ground cables at the battery, engine, body and starter to insure you dont have a lose connection.

Bad connections can cause all kinds of electronic issues, even cause the electronic transmission to go in 2 gears at once.
tim0 is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 06:17 PM   #4
xj_96_FP
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2007
Location: TOMS RIVER, NJ
Posts: 371
It's a straight 6 I'm not sure the trans, is a lareado
xj_96_FP is offline   Reply With Quote Quick reply to this message
Unread 09-27-2013, 01:28 PM   #5
xj_96_FP
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2007
Location: TOMS RIVER, NJ
Posts: 371
How many grounds are there? Block and battery...
xj_96_FP is offline   Reply With Quote Quick reply to this message
Unread 09-30-2013, 09:13 PM   #6
xj_96_FP
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2007
Location: TOMS RIVER, NJ
Posts: 371
Ok so I resolved the issue, it was the starter shorting out, replaced it and works perfectly
xj_96_FP is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.