P0505- Plz Help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > P0505- Plz Help

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!

Reply
Unread 08-01-2007, 05:56 PM   #1
gilgrill
Registered User
 
Join Date: Aug 2007
Location: Currently in Florida
Posts: 13
P0505- Plz Help

Good afternoon all,

I am new to the forum and would really appreciated some advice with me 99 WJ. I recently got the dreaded Check Engine light and ran the code. It came up with P0505. So I Google it and saw somewhere were it says, "replace IAC". So I do. I replace the part, have Autozone remove the fault code. 4 days go by and the Check Engine light comes back on. I did notice the rough idling at start before and even after I changed the part. So then I start thinking maybe I need to reset the "Computer" So I disconnect the battery and waited about ten minutes. I am still getting the fluctuating idle on cold starts and minor fluctuation on warm starts. The Check Engine light has not come on, YET. I reset the computer today. So maybe after a dozen starts or so, it will recognize it, and come back on. I don't have any idling problems when I drive it, nor do I have it when stopping at lights. I have searched the forums for related posts, I found some similar posts but nothing that I have found to be relavent. I have checked for vacum leaks and found nothing. Your help is greatly appreciated. Thanks!

p.s. I am no mechanic but love to work on my cars

gilgrill is offline   Reply With Quote Quick reply to this message
Unread 08-01-2007, 06:24 PM   #2
ta2oodfreak
Registered User
1996 ZJ 
 
Join Date: Jun 2007
Location: arlington heights, IL
Posts: 126
make sure the throttle body is clean as well as the iac passage. an excessive carbon build up can cause a idle concearn. resetting the pcm will clear some learned info that takes a litlle time for the pcm to re-learn. so it may run a bit off for a short while. run it for a few mles, put it through its paces and see if it smoothes out. if not you need to do some more diagnisis
__________________
96 ZJ
TREC Series #44
ta2oodfreak is offline   Reply With Quote Quick reply to this message
Unread 08-01-2007, 07:57 PM   #3
gilgrill
Registered User
 
Join Date: Aug 2007
Location: Currently in Florida
Posts: 13
Ok new diagnosis. I went through the possible vacum leaks, and I stumbled upon leak. It is a broken T behind the passenger head light. It is connected to a diaphram looking part. Any ideas? could this be related to my idling problem?
gilgrill is offline   Reply With Quote Quick reply to this message
Unread 08-01-2007, 08:55 PM   #4
rm2001wj
Web Wheeler
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,116
How did you find that one? The only thing I can think of up there is the cruise control vacuum solenoid. Have you tried to use the cruise control lately?
__________________
2001 WJ Limited with Quadra-Drive, Kenne Bell Supercharger, 3-inch Kolak exhaust, Stillen rotors (F/R) and MM pads, Addco sway bars (F/R).
rm2001wj is offline   Reply With Quote Quick reply to this message
Unread 08-02-2007, 06:14 AM   #5
gilgrill
Registered User
 
Join Date: Aug 2007
Location: Currently in Florida
Posts: 13
Yeah actually I have tried to use it and it didn't work, It will light up on the dash but will not engage. Wow, try to fix one problem and find another.
gilgrill is offline   Reply With Quote Quick reply to this message
Unread 08-02-2007, 09:15 AM   #6
rm2001wj
Web Wheeler
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,116
Yeah, but fix one problem and you will likely fix the other one too.
rm2001wj is offline   Reply With Quote Quick reply to this message
Unread 08-02-2007, 10:36 AM   #7
gilgrill
Registered User
 
Join Date: Aug 2007
Location: Currently in Florida
Posts: 13
Just got back from the Jeep dealer. I ordered a cruise control resivior or something along those lines. I was told that the plastic T does not sell by itself and that I had to purchase the whole deal. So I agreed, why not do it right. 45.00 bucks. Thanks for all your input RM2001WJ. I hope this corrects both problems. I will probably post the results Monday.
gilgrill is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.